Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 47594 - [glibc/nptl?] gftp 2.0.17 crashes while uploading on AMD64 platform
Summary: [glibc/nptl?] gftp 2.0.17 crashes while uploading on AMD64 platform
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: AMD64 Project
Depends on: 70748
  Show dependency tree
Reported: 2004-04-12 04:08 UTC by Paul Caselton
Modified: 2005-02-04 13:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Paul Caselton 2004-04-12 04:08:57 UTC
While tyring to upload with gftp 2.0.17 (AMD64) the application will terminate.  If the app is run from a shell it just displays "killed" as the output when it ditches.

Have tried with a few different servers (RedHat & FreeBSD) to make sure that it's nothing to do with the server software.

This bug is possible to reproduce everytime.
Comment 1 Paul Caselton 2004-04-12 04:21:09 UTC
Have tried to run a backtrace to produce a more meaningful bug report but gftp-gtk doesn't seem to like running under gdb.  Whenever I try I get this output:

(no debugging symbols found)...
Program received signal SIG32, Real-time event 32.
---Type <return> to continue, or q <return> to quit---
Cannot remove breakpoints because program is no longer writable.
It might be running in another process.
Further execution is probably impossible.
0x0000002a967ae08e in pthread_getconcurrency () from /lib/

Then I have to quit gdb.
Comment 2 Travis Tilley (RETIRED) gentoo-dev 2004-04-12 04:46:37 UTC
that might be enough, actually. it might be related to bug #46674

could you post the result of "emerge info"? also, try re-compiling gftp and gtk+ with:

CFLAGS="-O2 -g3 -ggdb -pipe" FEATURES="nostrip" USE="debug" emerge gftp gtk+

before doing a backtrace. portage strips debugging info by default unless you tell it not to. (note that some of the above is probably redundant, but it never hurts to be safe)

if you can predictably reproduce this bug, and the failure is consistantly in pthread_getconcurrency () from /lib/, then we have yet another testcase for bug #46674. it seems gtk+ triggers an obscure linuxthreads bug on amd64.
Comment 3 Paul Caselton 2004-04-12 05:16:10 UTC
Ok, recompiled gftp and gtk with the flags that you listed this was the result I got:

(gdb) run
Starting program: /usr/bin/gftp-gtk
Program received signal SIG32, Real-time event 32.
Cannot remove breakpoints because program is no longer writable.
It might be running in another process.
Further execution is probably impossible.
0x0000002a967ae08e in pthread_getconcurrency () from /lib/

It's worth noting that when running through gdb gftp crashes while I try to connect to a site, whereas running it normally allows me to connect to sites and do pretty much everything (list files, delete etc.) except upload.

Here's the output from emerge info:

Portage 2.0.50-r5 (default-amd64-2004.0, gcc-3.3.3, glibc-2.3.3_pre20040207-r0, 2.6.3-rc2-gentoo)
System uname: 2.6.3-rc2-gentoo x86_64 4
Gentoo Base System version 1.4.6
distcc 2.13 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox"
USE="X aalib alsa amd64 apache2 apm avi berkdb bonobo cdr cdrw crypt dvd dvdr encode esd foomaticdb gd gdbm gif gnome gpm gtk gtk2 gtkhtml imlib innodb java jpeg libg++ libwww mikmod motif mozilla mpeg multilib mysql ncurses nls nogcj oggvorbis opengl oss pam pdflib perl png postgres python quicktime readline samba scanner sdl slang spell ssl tcltk tcpd tiff truetype usb xml xml2 xmms xv zlib"
Comment 4 Paul Caselton 2004-04-12 05:18:09 UTC
Forgot to mention too, I'm running under XFCE 4.04 and not Gnome, also gftp 2.0.15 worked fine once I had applied the AMD64 patch to it.
Comment 5 Travis Tilley (RETIRED) gentoo-dev 2004-04-12 05:25:39 UTC
and just like with the nautilus bug, gftp works perfectly here with NPTL support enabled in glibc. it just might be safe to say that this is a glibc and/or linuxthreads bug.
Comment 6 Travis Tilley (RETIRED) gentoo-dev 2004-04-13 23:39:03 UTC
i forgot to mention that this seems to be a bug that's randomly triggered, and seems to be triggered most often by gtk+ apps. it's not specifically a gnome, or possibly even gtk+ bug... especially since the workaround for now is to use NPTL instead of linuxthreads in glibc (nptl doesnt specifically fix this bug, but nptl forces thread local storage, which does... at least for me).

I want you to test to see if this solves your problem:

emerge sync
emerge /usr/portage/sys-kernel/linux-headers/linux-headers-2.6.5.ebuild
USE="nptl" emerge glibc

if it does, please let us know because that means you are experiencing the exact same bug, and we have a much simpler testcase for it than installing all of gnome 2.6
Comment 7 Paul Caselton 2004-04-21 11:40:40 UTC
Tried doing what you suggested and it made no difference at all, the crash doesn't seem to be random either, always at the exact same point.
Comment 8 Travis Tilley (RETIRED) gentoo-dev 2004-04-25 16:06:02 UTC
can you try the new glibc snapshot and see if this fixes things?
Comment 9 Travis Tilley (RETIRED) gentoo-dev 2004-05-07 15:49:42 UTC
with the pt pax patch applied to binutils:

lv@ayanami lv $ gftp
Segmentation fault

with the patch removed and glibc recompiled:

lv@ayanami lv $ gftp

(gdb) run
Starting program: /usr/bin/gftp-gtk
warning: Unable to find dynamic linker breakpoint function.
GDB will be unable to debug shared library initializers
and track explicitly loaded dynamic code.
Cannot insert breakpoint -2.
Error accessing memory address 0x12490: Input/output error.

Comment 10 Paul Caselton 2004-05-11 07:01:47 UTC
Have merged linux-headers 2.6.5 and then recompiled glibc with nptl enabled.  After this emerged gftp2.0.17 again, but am still getting it bomb out at the same point.

Do I need to recompile anything else, such gtk+?  Gnome doesn't work for me either, it'll freeze on metacity loading.
Comment 11 Travis Tilley (RETIRED) gentoo-dev 2004-06-16 02:36:08 UTC
can you emerge sync and re-install ORBit2?
Comment 12 Mike Foster 2004-07-28 19:32:23 UTC
Having same problem. Regarding last comment to re-emerge ORBit2, I do not have that app installed, and it was not required by gftp. My emerge info is as follows:

Portage 2.0.50-r9 (gcc34-amd64-2004.1, gcc-3.4.1, glibc-, 2.6.7-gentoo-r10)
System uname: 2.6.7-gentoo-r10 x86_64 4
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
CFLAGS="-O3 -march=k8 -mtune=k8 -fomit-frame-pointer -fprefetch-loop-arrays -pipe -maccumulate-outgoing-args"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"            
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=k8 -mtune=k8 -fomit-frame-pointer -fprefetch-loop-arrays -pipe -maccumulate-outgoing-args"
FEATURES="autoaddcvs ccache"
USE="X aim alsa amd64 apm arts avi berkdb crypt cups encode esd fbcon foomaticdb gdbm gif gnome gpm gtk gtk2 imlib java jikes jpeg kde libg++ libwww maildir mikmod motif mozilla mpeg multilib ncurses nls oggvorbis opengl oss pam pda pdflib perl png python qt quicktime readline samba sdl slang slp spell ssl tcltk tcpd tiff truetype usb xml2 xmms xv yahoo zlib"
Comment 13 Paul Caselton 2004-07-29 08:17:22 UTC
I've pretty much recompiled the whole system from scratch (from the new stages - 2004.2).  Latest version of glibc compiled with nptl on, both gnome 2.6.x (recompiled ORBit2) and gftp still refuse to work.  Exactly the same errors.  :-/
Comment 14 Mike Foster 2004-08-04 16:03:36 UTC
Portage "upgraded" me to 2.0.15 and all is working now.
Comment 15 Travis Tilley (RETIRED) gentoo-dev 2004-08-04 16:51:49 UTC
yeah, i narrowed it down to a change in .16 and then got distracted. ^^;
so i masked 16 and up
Comment 16 Simon Stelling (RETIRED) gentoo-dev 2004-11-30 02:58:19 UTC
*** Bug 71310 has been marked as a duplicate of this bug. ***
Comment 17 Simon Stelling (RETIRED) gentoo-dev 2004-12-03 07:42:15 UTC
Take a look at This should be fixed in 2.0.18rc1, so i set the dependency on our bug :)
Comment 18 Simon Stelling (RETIRED) gentoo-dev 2005-02-04 13:22:36 UTC
2.0.18 fixes this, please switch to this version