Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 475818 - =net-libs/gtk-vnc-0.5.2 - No screen updates.
Summary: =net-libs/gtk-vnc-0.5.2 - No screen updates.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2013-07-05 10:59 UTC by Lukas Elsner
Modified: 2013-08-30 16:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Elsner 2013-07-05 10:59:33 UTC

All applications which are using gtk-vnc library are behaving the same way on my box. (virt-viewer vinagre). 

When connecting to a remote-server I see a part of the first received image/frame. And then the VNC display is completely stuck. 
Mouse input is working fine, but I cannot see anything. :( 

Didn't find any bug report etc, and this problem persists since several weeks (cannot say exactly since when) 

Any hints where to look at? 

Reproducible: Always

Steps to Reproduce:
1. start any application using gtk-vnc
2. connect to vnc server

Actual Results:  
cannot see remote screen

Expected Results:  
see remote screen

Portage (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.10.0-gentoo x86_64)
System uname: Linux-3.10.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-3840QM_CPU_@_2.80GHz-with-gentoo-2.2
KiB Mem:    24322020 total,    398920 free
KiB Swap:   31262716 total,  31239308 free
Timestamp of tree: Fri, 05 Jul 2013 09:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5, 3.2.5-r1, 3.3.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.4, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x-portage x11 sunrise luman mate-overlay steam-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
EMERGE_DEFAULT_OPTS="--jobs=15 --load-average=8.5"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/x11 /var/lib/layman/sunrise /var/lib/layman/luman /var/lib/layman/mate /var/lib/layman/steam"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo caja cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk gtk3 gtkstyle iconv ipv6 java jpeg laptop latex lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mtp mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf perl png policykit ppds pulseaudio python qt3support qt4 rdp readline samba sdl session spell spice sse sse2 ssl startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vaapi vdpau vim-syntax vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia intel nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-09 19:06:30 UTC
Which version of gtk-vnc is this? Can you also try earlier / later versions?

Is this a regression? Did it work before? Can you try a different remote server?
Comment 2 Lukas Elsner 2013-07-09 21:02:49 UTC
First of all, thanks trying to help out on this Problem. Since I didnt get any answer in gentoo forums on this, I assume that it also could a weird local Problem. But I really have no clue what It could be about.

Is this a regression? 
Did it work before? 
Since I am always virtualizing with virt-manager, it was working fine for months. Then, there were some weeks, without booting any VM. Also there was a complete Hardware change (new Laptop, but without a whole reinstall)

Can you try a different remote server?
Tried several virtual machines through virt-viewer and some remote servers throug vinage. Same issue everywhere.

Which version of gtk-vnc is this?
le@w530 /lu $ eix gtk-vnc
[I] net-libs/gtk-vnc
     Available versions:  0.5.0-r1 0.5.1 (~)0.5.2 {examples gtk3 +introspection pulseaudio python sasl vala PYTHON_TARGETS="python2_6 python2_7"}
     Installed versions:  0.5.2(04:24:48 AM 07/02/2013)(gtk3 introspection pulseaudio python -examples -sasl -vala PYTHON_TARGETS="python2_7 -python2_6")
     Description:         VNC viewer widget for GTK

Can you also try earlier / later versions?
Later versions will be difficult! :D
When masking 0.5.2, I also have to downgrade virt-viewer, and some other packages. I can try, but I didnt do, yet.

Any more Infos, I can give?
Comment 3 Lukas Elsner 2013-07-09 21:09:41 UTC
same problem with gtk-vnc-0.5.1 :(
Comment 4 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-09 21:14:46 UTC
There is a 9999 version in the gnome overlay. Anyhow, assigned to the maintainers since I barely know this package. Thank you for the extra information.
Comment 5 Lukas Elsner 2013-07-09 22:30:35 UTC
also tried 0.5.0-r1 without success.

removed gtk3 useflag and merged vinagre 2.xx - no success

added gnome overlay now and upgrading all packages. however, gtk-vnc-9999 seems to throw some errors while building. but this is another bug I think...
Comment 6 Lukas Elsner 2013-07-10 10:37:09 UTC
Another hint...maybe...

Spice connections with virt-viewer and vinagre behaving exactly the same as VNC connections!
Comment 7 Lukas Elsner 2013-07-10 12:20:54 UTC
tried to get some debug output:

le@w530 /lu $ spicy -h localhost -p 5900 --spice-debug
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:1194 display-2:0: Peer version: 2:2
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:1691 display-2:0: spice_channel_recv_link_msg: 2 caps
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:1701 display-2:0: got common caps 0:0xB
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:1707 display-2:0: got channel caps 0:0x12
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2601 test cap 0 in 0xB: yes
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2601 test cap 1 in 0xB: yes
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2601 test cap 3 in 0xB: yes
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:1736 display-2:0: use mini header: 1
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:1100 cursor-4:0: channel up, state 2
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:930 cursor-4:0: Closing the connection: spice_channel_read() - ret=0
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2091 cursor-4:0: channel has error, breaking loop
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2345 cursor-4:0: Coroutine exit cursor-4:0
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2137 cursor-4:0: Delayed unref channel 0x1b10e40
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:1100 display-2:0: channel up, state 2
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/channel-display.c:901 display-2:0: spice_display_channel_up: cache_size 83886080, glz_window_size 12582912 (bytes)
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:913 display-2:0: Read error Error receiving data: Connection reset by peer

(spicy:19213): GSpice-CRITICAL **: recv hdr: Connection reset by peer
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2118 got socket error: 25
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2345 display-2:0: Coroutine exit display-2:0
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/spice-channel.c:2137 display-2:0: Delayed unref channel 0x1b14420
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/decode-glz.c:372 decode_header: 32x23, id 0, ref 0
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/decode-glz.c:372 decode_header: 32x23, id 1, ref 0
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/decode-glz.c:372 decode_header: 32x23, id 2, ref 0
(spicy:19213): GSpice-DEBUG: /var/tmp/portage/net-misc/spice-gtk-0.20/work/spice-gtk-0.20/gtk/decode-glz.c:372 decode_header: 32x23, id 3, ref 0

And vinagre (in vnc mode) gives many of this:

(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Requesting framebuffer update at 0,0 size 720x1280, incremental 1
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Read error Error receiving data: Resource temporarily unavailable
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c FramebufferUpdate type=7 area (720x91) at location 0,91
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Read error Error receiving data: Resource temporarily unavailable
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Read error Error receiving data: Resource temporarily unavailable
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Read error Error receiving data: Resource temporarily unavailable
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Read error Error receiving data: Resource temporarily unavailable
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Read error Error receiving data: Resource temporarily unavailable
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Read error Error receiving data: Resource temporarily unavailable
(vinagre:27102): gtk-vnc-DEBUG: /var/tmp/portage/net-libs/gtk-vnc-0.5.2/work/gtk-vnc-0.5.2/src/vncconnection.c Notify update area (720x91) at location 0,91
Comment 8 Lukas Elsner 2013-07-12 13:05:10 UTC
I really need my virtual machines!

Will spend a lot of beer for the right hint! :)
Comment 9 Lukas Elsner 2013-07-14 00:15:32 UTC
I made a complete fresh installation from stage3. Problem is still there! :(
Comment 10 Lukas Elsner 2013-07-14 00:27:34 UTC
removed some overlays (x11,sunrise,gnome), got the following downgrades and gtkmm was building fine.

I think gnome-overlay is the faulty one here!

(sorry for double posting, but this solved two problems at once! :D)

Calculating dependencies... done!
[nomerge       ] mate-base/mate-file-manager-1.6.1-r1::mate-overlay  USE="introspection -debug (-gtk3) -mate -xmp" 
[ebuild     UD ]  gnome-base/gvfs-1.14.2::gentoo [1.15.4::gnome] USE="afp archive bluetooth bluray cdda fuse gphoto2 gtk http udev udisks -avahi -doc -gdu -gnome-keyring -ios -samba -systemd (-gnome-online-accounts%) (-mtp%*)" 1,433 kB
[ebuild  N     ] media-sound/pavucontrol-2.0  USE="nls" 0 kB
[ebuild  NS    ]  dev-cpp/gtkmm-3.6.0:3.0 [2.24.4:2.4] USE="X (-aqua) -doc -examples {-test} (-wayland)" 0 kB
[ebuild     UD ]   x11-libs/gtk+-3.6.3-r2:3::gentoo [3.7.14:3::gnome] USE="X cups introspection (-aqua) -colord -debug (-egl) -examples (-packagekit) {-test} -vim-syntax (-wayland) -xinerama" 12,964 kB
[nomerge       ] media-sound/gmpc-11.8.16  USE="nls unique -xspf" 
[nomerge       ]  net-libs/libsoup-2.40.3:2.4  USE="introspection ssl -debug -samba {-test}" 
[ebuild     UD ]   net-libs/glib-networking-2.34.2::gentoo [2.35.9::gnome] USE="gnome libproxy ssl -smartcard {-test}" 339 kB
[nomerge       ] www-client/google-chrome-29.0.1547.18_alpha210974:unstable  USE="plugins" LINGUAS="de -am -ar -bg -bn -ca -cs -da -el -en_GB -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 
[ebuild     UD ]  dev-libs/atk-2.6.0::gentoo [2.7.91::gnome] USE="introspection nls" 0 kB
[ebuild     UD ]  x11-libs/cairo-1.12.14-r2::gentoo [1.12.14-r3::x11] USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) -legacy-drivers -openvg (-qt4) -static-libs (-gles2%) (-valgrind%)" 0 kB
[ebuild     UD ]   dev-libs/glib-2.34.3:2::gentoo [2.35.8:2::gnome] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" 0 kB
[ebuild     UD ] sys-devel/make-3.82-r4::gentoo [3.82-r5::gnome] USE="nls -static" 0 kB
Comment 11 Doug Goldstein (RETIRED) gentoo-dev 2013-08-10 20:21:59 UTC
(In reply to lukas elsner from comment #10)
> removed some overlays (x11,sunrise,gnome), got the following downgrades and
> gtkmm was building fine.
> I think gnome-overlay is the faulty one here!

So removing gnome-overlay made this issue go away?
Comment 12 Lukas Elsner 2013-08-10 23:01:38 UTC
I think so, but cannot confirm exactly!
Comment 13 Pacho Ramos gentoo-dev 2013-08-29 12:36:29 UTC
Are you still hitting this? (with updated tree)
Comment 14 Lukas Elsner 2013-08-29 13:27:13 UTC
you mean with using gnome overlay?
Comment 15 Pacho Ramos gentoo-dev 2013-08-29 17:20:26 UTC
At first try only with main tree, if it's solved, would be nice to get the offending package from overlay (specially since now most of the packages should be newer in the main tree and, then, you should only get a few updated from overlay)
Comment 16 Lukas Elsner 2013-08-29 18:21:29 UTC
I am very busy right now, but will try the next days if readding gnome-overlay will make some problems.
Comment 17 Lukas Elsner 2013-08-30 07:47:38 UTC
I readded gnome overlay, had just a few updates and everything is working fine. So no problems so far...
Comment 18 Pacho Ramos gentoo-dev 2013-08-30 16:22:16 UTC
Will close for now then, thanks for feedback