Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 475658 - app-editors/xemacs-21.4.22-r4 stable request
Summary: app-editors/xemacs-21.4.22-r4 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: XEmacs team
URL: http://tracker.xemacs.org/XEmacs/its/...
Whiteboard: WAS: app-editors/xemacs-21.4.22-r2 wi...
Keywords: STABLEREQ
Depends on:
Blocks: texinfo-5.1 EAPI1Removal 527998
  Show dependency tree
 
Reported: 2013-07-03 19:24 UTC by Ulrich Müller
Modified: 2014-12-04 08:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for xemacs-21.4.22-r3 (xemacs-21.4.22-texinfo-5.patch,12.45 KB, patch)
2014-10-17 17:59 UTC, Ulrich Müller
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Müller gentoo-dev 2013-07-03 19:24:27 UTC
With texinfo-5.1, xemacs-21.4.22-r2 fails to build custom.info:

cd /var/tmp/portage/app-editors/xemacs-21.4.22-r2/work/xemacs-21.4.22/man && make  info
make[1]: Entering directory `/var/tmp/portage/app-editors/xemacs-21.4.22-r2/work/xemacs-21.4.22/man'
makeinfo -o ../info/cl.info cl.texi
makeinfo -o ../info/custom.info custom.texi
custom.texi:63: raising the section level of @section which is too low
make[1]: *** [../info/custom.info] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-editors/xemacs-21.4.22-r2/work/xemacs-21.4.22/man'
make: *** [info] Error 2

Already reported upstream, see URL.
Comment 1 Mats Lidell gentoo-dev 2013-07-03 21:41:50 UTC
Thanks for the report.

A patch for 21.5 has been pushed upstream so the problem is known. 

I have raised the question upstream if 21.4 will get a patch in the same way as 21.5 and for more details what needs to be changed to be compatible with texinfo 5.x.
Comment 2 Pacho Ramos gentoo-dev 2014-10-17 09:32:41 UTC
Any news on this? texinfo-5.1 could be needed in stable soon :/

Thanks
Comment 3 Ulrich Müller gentoo-dev 2014-10-17 17:59:05 UTC
Created attachment 386808 [details, diff]
Patch for xemacs-21.4.22-r3

Attached patch fixes the build failure in xemacs-21.4.22-r3 for me. I've tested with both texinfo-5.1 and -5.2.

Basically, this is a backport of the upstream patch for 21.5: https://bitbucket.org/xemacs/xemacs/commits/d11efddf3617c0c74b8e0a029803f248c7630a61 with one additional change needed for 21.4.
Comment 4 Mats Lidell gentoo-dev 2014-10-19 07:52:48 UTC
Thanks for the patch and for testning. I'm out travelling and will attend to this in a few days.
Comment 5 Mats Lidell gentoo-dev 2014-10-21 16:59:43 UTC
app-editors/xemacs-21.4.22-r4 containing the attached patch has been committed.
Comment 6 Mats Lidell gentoo-dev 2014-10-30 20:46:23 UTC
Arch teams, please stabilize: app-editors/xemacs-21.4.22-r4
Comment 7 Jeroen Roovers gentoo-dev 2014-11-01 00:16:50 UTC
Stable for HPPA.
Comment 8 Agostino Sarubbo gentoo-dev 2014-11-03 10:27:11 UTC
amd64 stable
Comment 9 Agostino Sarubbo gentoo-dev 2014-11-10 10:51:45 UTC
ppc stable
Comment 10 Myckel Habets 2014-11-16 16:08:23 UTC
Builds and runs fine on x86. Rdeps also build fine. Please mark stable for x86.
Comment 11 Tobias Klausmann gentoo-dev 2014-11-20 15:20:16 UTC
Stable on alpha.
Comment 12 Agostino Sarubbo gentoo-dev 2014-11-25 08:38:38 UTC
x86 stable
Comment 13 Agostino Sarubbo gentoo-dev 2014-12-01 09:26:08 UTC
sparc stable
Comment 14 Agostino Sarubbo gentoo-dev 2014-12-04 08:44:10 UTC
ppc64 stable. Closing.