Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 475548 - x11-drivers/xf86-video-sunffb fails without XAA support
Summary: x11-drivers/xf86-video-sunffb fails without XAA support
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: Sparc Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
Depends on:
Blocks: 475480
  Show dependency tree
Reported: 2013-07-02 19:21 UTC by spock128
Modified: 2013-07-03 22:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description spock128 2013-07-02 19:21:55 UTC
x11-drivers/xf86-video-sunffb-1.2.2 fails to load without XAA support.  After applying patch from upstream, driver loads and appears to work correctly. (See URL for patch)

Reproducible: Always

Steps to Reproduce:
1. emerge -1 xf86-video-sunffb
2. /etc/init.d/xdm restart
Actual Results:  
Xorg fails to start (message in Xorg.0.log about missing xaa module).

Expected Results:  
X starts and presents login screen.
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-07-03 08:13:51 UTC
Patch applied in 1.2.2-r1
Comment 2 Matt Turner gentoo-dev 2013-07-03 21:16:29 UTC
I asked for testing in bug 453236 and no one ever responded. :(
Comment 3 spock128 2013-07-03 22:45:39 UTC
I didn't realize there was already a bug reported for this (searched beforehand, didn't see anything).

I initially tried installing 1.2.1, but it fails to compile against xorg-server-1.13 (as reported in  bug 453236).  I keyworded 1.2.2, which builds but doesn't load, hence the patch in 1.2.2-r1.  It works now.