Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 475406 - x11-drivers/nvidia-drivers-319.*: build failed on linux kernel 3.10
Summary: x11-drivers/nvidia-drivers-319.*: build failed on linux kernel 3.10
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal major with 1 vote (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-01 12:10 UTC by Zitian Li
Modified: 2013-07-02 05:24 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/x11-drivers/nvidia-drivers-319.23/temp/build.log (build.log,45.10 KB, text/plain)
2013-07-01 12:15 UTC, Zitian Li
Details
build.log (file_475406.txt,136.29 KB, text/plain)
2013-07-01 12:30 UTC, beizhuchun
Details
patch for kernel 3.10 (kernel-3.10.patch,16.87 KB, patch)
2013-07-01 14:10 UTC, Vadim Dyadkin
Details | Diff
patch for linux-3.10 (NVIDIA-Linux-x86_64-319.17-no-compat32.patch,17.24 KB, patch)
2013-07-02 05:24 UTC, beizhuchun
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zitian Li 2013-07-01 12:10:39 UTC
I have updated my kernel from 3.9.8 to 3.10.0. But when I emerge nvidia-drivers with the new kernel, a build error happened.

Reproducible: Always
Comment 1 Zitian Li 2013-07-01 12:15:22 UTC
Created attachment 352388 [details]
/var/tmp/portage/x11-drivers/nvidia-drivers-319.23/temp/build.log
Comment 2 beizhuchun 2013-07-01 12:28:42 UTC
Portage 2.1.12.11 (default/linux/amd64/13.0/desktop/gnome, gcc-4.8.0, glibc-2.17, 3.10.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.10.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-3610QM_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:     8077420 total,   6155536 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Mon, 01 Jul 2013 11:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5, 3.2.5, 3.3.2
dev-util/ccache:          3.1.9-r1::science
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.8.0
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo gentoo-zh science local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/portage/distfiles"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/ http://mirrors.sohu.com/gentoo/ http://mirrors.stuhome.net/gentoo/ http://mirrors.xmu.edu.cn/gentoo"
LANG="zh_CN.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/var/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/var/lib/layman/gentoo-zh /var/lib/layman/science /var/local"
SYNC="rsync://rsync.asia.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth bzip2 cairo cdda cdr cjk cli colord consolekit corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk i18n iconv ipv6 jpeg lcms ldap libnotify libsecret mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support readline sdl session socialweb spell sse sse2 ssl startup-notification svg symlink tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="zh_CN zh en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel nvidia fmodesetting" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

x11-drivers/nvidia-drivers-319.32 was built with the following:
USE="X acpi (multilib) tools -pax_kernel"
Comment 3 beizhuchun 2013-07-01 12:30:16 UTC
Created attachment 352390 [details]
build.log
Comment 4 Vadim Dyadkin 2013-07-01 14:10:44 UTC
Created attachment 352400 [details, diff]
patch for kernel 3.10

This patch helps, I found it on the nvidia forum
Comment 5 Jeroen Roovers gentoo-dev 2013-07-01 14:23:27 UTC

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 6 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-01 15:32:36 UTC
(Quoting Doug Goldstein from bug #447566 comment #56)
> It is and has always been Gentoo's policy to support what NVIDIA supports. The current versions of the drivers do not support 3.10. You are more than welcome to use the capabilities of epatch_user (which are present in all the ebuilds) to make the changes yourself but they do not go into the main tree.
Comment 7 beizhuchun 2013-07-02 05:24:11 UTC
Created attachment 352434 [details, diff]
patch for linux-3.10

This patch work fine with gentoo-source-3.10.0 + nvidia-drivers-319.32.