Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 475396 - x11-drivers/nvidia-drivers doesn't build with 3.10 kernel
Summary: x11-drivers/nvidia-drivers doesn't build with 3.10 kernel
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-01 10:13 UTC by Aleksander
Modified: 2013-07-01 10:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,120.79 KB, text/x-log)
2013-07-01 10:13 UTC, Aleksander
Details
emerge --info (info,15.00 KB, text/plain)
2013-07-01 10:14 UTC, Aleksander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksander 2013-07-01 10:13:51 UTC
Created attachment 352378 [details]
build.log

Nvidia drivers not compiles with new kernel from portage tree.
I saw warning, that officially supports only kernels < 3.10 but earlier drivers builds fine with this warning. Now build fails with:
    error: implicit declaration of function ‘create_proc_entry’ [-Werror=implicit-function-declaration]
    error: dereferencing pointer to incomplete type

and so on(full build log attached).

Maybe mask this version of kernel until nvidia makes drivers for it?

I'm using gentoo-sources.
Comment 1 Aleksander 2013-07-01 10:14:19 UTC
Created attachment 352380 [details]
emerge --info
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-01 10:28:06 UTC
(Quoting Doug Goldstein from bug #447566 comment #56)
> It is and has always been Gentoo's policy to support what NVIDIA supports. The current versions of the drivers do not support 3.10. You are more than welcome to use the capabilities of epatch_user (which are present in all the ebuilds) to make the changes yourself but they do not go into the main tree.

*** This bug has been marked as a duplicate of bug 447566 ***