Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 475382 - x11-drivers/nvidia-drivers fails to build with 3.10 kernel
Summary: x11-drivers/nvidia-drivers fails to build with 3.10 kernel
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-01 06:11 UTC by Jiri Netolicky
Modified: 2013-07-01 07:42 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Netolicky 2013-07-01 06:11:17 UTC
Building nvidia-drivers fails with 3.10 kernel. Problem is in
nv-i2c.c line 327.

 osstatus = i2c_del_adapter(pI2cAdapter);


In 3.10 kernel the i2c_del_adapter method is declared
as returning void:

extern void i2c_del_adapter(struct i2c_adapter *);

Reasons are described in this mail:

http://lkml.indiana.edu/hypermail/linux/kernel/1303.1/00616.html
Comment 1 Dmitry Suloev 2013-07-01 07:33:10 UTC
Looks like this is not one problem...
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-01 07:42:19 UTC
(Quoting Doug Goldstein from bug #447566 comment #56)
> It is and has always been Gentoo's policy to support what NVIDIA supports. The current versions of the drivers do not support 3.10. You are more than welcome to use the capabilities of epatch_user (which are present in all the ebuilds) to make the changes yourself but they do not go into the main tree.

*** This bug has been marked as a duplicate of bug 447566 ***