Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 472184 - net-fs/openafs-kernel-1.6.18 on handened kernel-4.6.5 - Error: Undefined symbols in modules
Summary: net-fs/openafs-kernel-1.6.18 on handened kernel-4.6.5 - Error: Undefined symb...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: NP-Hardass
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-03 16:44 UTC by Steffen
Modified: 2019-01-05 14:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,100.24 KB, text/plain)
2013-06-03 16:49 UTC, Steffen
Details
error.log (net-fs-openafs-kernel-1.6.18.2-20160805-194858.log,668.22 KB, text/plain)
2016-08-05 20:52 UTC, Toralf Förster
Details
emerge info (emerge-info.txt,7.65 KB, text/plain)
2016-08-05 20:53 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen 2013-06-03 16:44:15 UTC
emerge openafs-kernel fails during compilation:

  CC      /var/tmp/portage/net-fs/openafs-kernel-1.6.2/work/openafs-1.6.2/src/libafs/MODLOAD-3.8.6-hardened-MP/afspag.mod.o
  LD [M]  /var/tmp/portage/net-fs/openafs-kernel-1.6.2/work/openafs-1.6.2/src/libafs/MODLOAD-3.8.6-hardened-MP/afspag.ko
  CC      /var/tmp/portage/net-fs/openafs-kernel-1.6.2/work/openafs-1.6.2/src/libafs/MODLOAD-3.8.6-hardened-MP/libafs.mod.o
  LD [M]  /var/tmp/portage/net-fs/openafs-kernel-1.6.2/work/openafs-1.6.2/src/libafs/MODLOAD-3.8.6-hardened-MP/libafs.ko
make[5]: Leaving directory `/usr/src/linux-3.8.6-hardened'
Error: Undefined symbols in modules
rm: cannot remove 'exit': No such file or directory
rm: cannot remove '1': No such file or directory
make[4]: *** [libafs.ko] Error 1
 

Reproducible: Always

Steps to Reproduce:
1. emerge net-fs/openafs-kernel-1.6.2 on linux-3.8.6-hardened
2.
3.
Actual Results:  
The compilation failed.

Expected Results:  
Openafs-kernel gets compiled successfully.

The same happens for net-fs/openafs, but a possible workaround is this fix:
http://forums.gentoo.org/viewtopic-t-952344-start-0.html .
However the patch causes openafs-kernel to fail during the patch phase.

emerge --info
Portage 2.1.11.62 (hardened/linux/amd64, gcc-4.6.3, glibc-2.15-r3, 3.8.6-hardened x86_64)
=================================================================
System uname: Linux-3.8.6-hardened-x86_64-Dual_Core_AMD_Opteron-tm-_Processor_280-with-gentoo-2.2
KiB Mem:     8181064 total,     55628 free
KiB Swap:   16787920 total,  16787324 free
Timestamp of tree: Fri, 31 May 2013 06:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8-r1, 2.7.3-r3, 3.1.5-r1, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo                 http://distfiles.gentoo.org 		http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl amd64 apache2 berkdb bzip2 cli cracklib crypt cups curl cxx dri fortran gd gdbm gif gpm hardened iconv imap jpeg justify kerberos ldap maildir mmx mng modules mudflap multilib mysql ncurses nls nptl openmp pam pax_kernel pcre perl png readline sasl session sse sse2 ssl tcpd tiff truetype unicode urandom xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Steffen 2013-06-03 16:49:09 UTC
Created attachment 349982 [details]
build.log
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-08-27 08:17:09 UTC
Fixed in 1.6.5 per bug #478498.
Comment 3 Toralf Förster gentoo-dev 2016-08-05 20:50:57 UTC
happened for 1.6.18. again
Comment 4 Toralf Förster gentoo-dev 2016-08-05 20:52:43 UTC
Created attachment 442640 [details]
error.log
Comment 5 Toralf Förster gentoo-dev 2016-08-05 20:53:05 UTC
Created attachment 442642 [details]
emerge info
Comment 6 Andrew Savchenko gentoo-dev 2016-11-24 17:59:18 UTC
(In reply to Toralf Förster from comment #3)
> happened for 1.6.18. again

Toralf, please, open NEW bugs if you get some problem from LONG time ago.
Package has new maintainers since, bug has an outdated description, thus it was nearly lost. Or at least update all bug's metadata to up-to-date values if you are sure that old bug should be reopened..

Is this still an issue with 1.6.18.3?
Does this happens only on hardened kernels or on vanilla as well?
Comment 7 Larry the Git Cow gentoo-dev 2019-01-05 14:02:01 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2ee38441e0210b8d43f22bb8afe100d5c2a1c58c

commit 2ee38441e0210b8d43f22bb8afe100d5c2a1c58c
Author:     Andrew Savchenko <bircoph@gentoo.org>
AuthorDate: 2019-01-05 13:51:54 +0000
Commit:     Andrew Savchenko <bircoph@gentoo.org>
CommitDate: 2019-01-05 14:00:13 +0000

    net-fs/openafs: 1.8.2 version bump
    
    - Update to upstream version 1.8.2 and patches from 1_8_x branch
      till 20181001. This fixes some open Gentoo bugs:
        472184 (probably), 544162, 603890 (likely), 640874, 642542.
    - Merge openafs-kernel back into openafs:
      - save lots of build time (configure, compilling common code);
      - original split was required due to problems in the build system
        (e.g. -j1) which are fixed now.
      Now kernels < 4.21 are supported.
    - Add support for new features:
      - enable gssapi via kerberos;
      - allow to choose between namei and inode file servers;
      - add Tivoli TSM API support;
      - conrol ubik-read-while-write mode;
      - deprecate kauth tools (may be enabled via flag);
      - add support for perl bindings via swig;
    - Docs:
      - build api docs (using doxygen);
      - Build PDF docs, support all three generators (fop, dblatex,
        docbook2pdf).
    - Avoid file collision with heimdal (bug 631584).
    
    The client is tested on various configurations, the server is not.
    
    Closes: https://bugs.gentoo.org/472184
    Closes: https://bugs.gentoo.org/544162
    Closes: https://bugs.gentoo.org/603890
    Closes: https://bugs.gentoo.org/631584
    Closes: https://bugs.gentoo.org/640874
    Closes: https://bugs.gentoo.org/642542
    Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
    Package-Manager: Portage-2.3.53, Repoman-2.3.11

 net-fs/openafs/Manifest             |   3 +
 net-fs/openafs/metadata.xml         |  16 +-
 net-fs/openafs/openafs-1.8.2.ebuild | 341 ++++++++++++++++++++++++++++++++++++
 3 files changed, 358 insertions(+), 2 deletions(-)
Comment 8 Andrew Savchenko gentoo-dev 2019-01-05 14:13:03 UTC
It should be fixed in openafs-1.8.2 (please note there is no separate kernel package anymore), but I have no hardened kernels to test.