Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 471966 - =app-arch/pax-3.4.12.16 - configure.in:4: error: 'AM_CONFIG_HEADER': this macro is obsolete.
Summary: =app-arch/pax-3.4.12.16 - configure.in:4: error: 'AM_CONFIG_HEADER': this mac...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-06-01 01:55 UTC by Jason Mours
Modified: 2013-06-01 14:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
aclocal.out (aclocal.out,531 bytes, text/plain)
2013-06-01 01:56 UTC, Jason Mours
Details
build.log (build.log,2.87 KB, text/plain)
2013-06-01 01:56 UTC, Jason Mours
Details
emerge-info (emerge-info,16.39 KB, text/plain)
2013-06-01 01:57 UTC, Jason Mours
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mours 2013-06-01 01:55:36 UTC
Found another : configure.in:4: error: 'AM_CONFIG_HEADER': this macro is obsolete.: Error in =app-arch/pax-3.4.12.16. This one is kinds important. :

***** aclocal *****
***** PWD: /var/tmp/portage/app-arch/pax-3.4.12.16/work/pax-3.4
***** aclocal

aclocal-1.13: warning: autoconf input should be named 'configure.ac', not 'configure.in'
configure.in:4: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:4: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

:

Nothing exciting in the aclocal.out. Posting build.log

Reproducible: Always
Comment 1 Jason Mours 2013-06-01 01:56:13 UTC
Created attachment 349788 [details]
aclocal.out
Comment 2 Jason Mours 2013-06-01 01:56:24 UTC
Created attachment 349790 [details]
build.log
Comment 3 Jason Mours 2013-06-01 01:57:04 UTC
Created attachment 349792 [details]
emerge-info

My emerge info's are getting too big, geeez-o-man
Comment 4 Jeroen Roovers gentoo-dev 2013-06-01 12:23:50 UTC
Fixed without a revision bump. Thanks for the report!
Comment 5 Jeroen Roovers gentoo-dev 2013-06-01 12:24:54 UTC
(In reply to Jason Mours from comment #3)
> Created attachment 349792 [details]
> emerge-info
> 
> My emerge info's are getting too big, geeez-o-man

I don't think you ought to attach that every time, since the obsolete headers that trip up automake 1.13.1 are well known.
Comment 6 Jason Mours 2013-06-01 14:44:16 UTC
Thanks kind(ly)! ... I was just trying to follow so protocol, I like to include the -info as posted text in my bug reports. But it's out grown the size restraints on plain-text posts.
Comment 7 Jason Mours 2013-06-01 14:58:40 UTC
SO some(day)... I'll get the hang of this typing thing