Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 471324 - dev-libs/gobject-introspection-1.34.2-r1 fails to build due to PYTHON_SINGLE_TARGET
Summary: dev-libs/gobject-introspection-1.34.2-r1 fails to build due to PYTHON_SINGLE_...
Status: RESOLVED DUPLICATE of bug 470922
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-26 10:30 UTC by Paweł Rumian
Modified: 2013-05-28 14:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,1.78 KB, text/plain)
2013-05-26 10:32 UTC, Paweł Rumian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Rumian 2013-05-26 10:30:29 UTC
$ cat /etc/make.conf | grep PYTHON
PYTHON_SINGLE_TARGET="python3_3"
PYTHON_TARGETS="python2_7 python3_3"

>>> Emerging (1 of 16) dev-libs/gobject-introspection-1.34.2-r1
 * gobject-introspection-1.34.2.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                             [ ok ]
 * No Python implementation selected for the build. Please set
 * the PYTHON_SINGLE_TARGET variable in your make.conf to one
 * of the following values:
 * 
 * python2_7

 * ERROR: dev-libs/gobject-introspection-1.34.2-r1 failed (setup phase):
 *   No supported Python implementation in PYTHON_SINGLE_TARGET.
 * 
 * Call stack:
 *                                ebuild.sh, line  93:  Called pkg_setup
 *   gobject-introspection-1.34.2-r1.ebuild, line  40:  Called python-single-r1_pkg_setup
 *                  python-single-r1.eclass, line 242:  Called die
 * The specific snippet of code:
 *   		die "No supported Python implementation in PYTHON_SINGLE_TARGET."
 * 


Reproducible: Always

Steps to Reproduce:
1. Set PYTHON_SINGLE_TARGET="python3_3"
2. Set PYTHON_TARGETS="python2_7 python3_3"
3. emerge =dev-libs/gobject-introspection-1.34.2-r1
Actual Results:  
Build fails

Expected Results:  
Build proceeds using python2_7

$ emerge -pqv '=dev-libs/gobject-introspection-1.34.2-r1'
[ebuild   R   ] dev-libs/gobject-introspection-1.34.2-r1  USE="-doctool {-test}" PYTHON_SINGLE_TARGET="-python2_7*" PYTHON_TARGETS="python2_7" 

$ emerge --info
Portage 2.2.0_alpha177 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.9.2-gentoo x86_64)
=================================================================
System uname: Linux-3.9.2-gentoo-x86_64-AMD_Athlon-tm-_II_X3_450_Processor-with-gentoo-2.2
KiB Mem:    16415004 total,  11207844 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sun, 26 May 2013 09:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5, 3.2.5, 3.3.2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.2
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo local-repo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 bash-completion bluetooth branding bzip2 cairo cdda cdr cli cracklib crypt cups cxx dri dts dvd dvdr emboss encode exif fam firefox flac fortran gif gpm gtk iconv ipv6 jpeg lapack lcms mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png ppds python readline session smp spell sse sse2 ssl startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vorbis x264 xcb xml xmp xv xvid zlib" ABI_X86="64" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="directory" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Paweł Rumian 2013-05-26 10:32:01 UTC
Created attachment 349212 [details]
Build log
Comment 2 merwan kashouty 2013-05-26 23:56:01 UTC
have had this for the last week or so also
Comment 3 Gilles Dartiguelongue gentoo-dev 2013-05-27 08:46:00 UTC
This tool does not support python3_3 at this version add python2_7 to PYTHON_SINGLE_TARGETS and it will build.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-05-28 14:20:15 UTC

*** This bug has been marked as a duplicate of bug 470922 ***