Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 471294 - =sci-libs/gts-20120706 with =sys-devel/automake-1.13 - configure.in:46: error: 'AM_CONFIG_HEADER': this macro is obsolete.
Summary: =sci-libs/gts-20120706 with =sys-devel/automake-1.13 - configure.in:46: error...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-05-26 05:13 UTC by Alain Toussaint
Modified: 2013-07-09 23:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
output of aclocal (aclocal.out,765 bytes, text/plain)
2013-05-26 05:17 UTC, Alain Toussaint
Details
build.log (build.log,2.69 KB, text/x-log)
2013-05-26 05:18 UTC, Alain Toussaint
Details
emerge -pqv =sci-libs/gts-20120706 (emerge_pqv.txt,82 bytes, text/plain)
2013-05-26 05:18 UTC, Alain Toussaint
Details
environment file (environment,113.86 KB, text/plain)
2013-05-26 05:19 UTC, Alain Toussaint
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alain Toussaint 2013-05-26 05:13:29 UTC
In the process of building FreeCAD, my system tried to compile sci-libs/gts-20120706 and fail during the aclocal command. I rebuilt m4, autoconf and automake with these cflags "-O2 -march=btver1 -mtune=btver1 -D__NO_MATH_INLINES -pipe" using gcc-4.7.2 but sci-libs/gts-20120706 still fail to compile.

Reproducible: Always

Steps to Reproduce:
1. emerge --verbose freecad

Actual Results:  
 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/sci-libs/gts-20120706/temp/aclocal.out
 * ERROR: sci-libs/gts-20120706 failed (prepare phase):
 *   Failed Running aclocal !
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3235:  Called autotools-utils_src_prepare
 *   environment, line  744:  Called eautoreconf
 *   environment, line 1086:  Called eaclocal
 *   environment, line  989:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  859:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";


Expected Results:  
compilation of sci-libs/gts-20120706 without issues.

Program running: kde-desktop, chromium, Konsole, mpg123 and Kontact

cat /proc/meminfo:
MemTotal:        7764072 kB
MemFree:         1890416 kB
Buffers:              52 kB
Cached:          3580380 kB
SwapCached:            0 kB
Active:          2791732 kB
Inactive:        1893300 kB
Active(anon):     985072 kB
Inactive(anon):   141520 kB
Active(file):    1806660 kB
Inactive(file):  1751780 kB
Unevictable:           0 kB
Mlocked:               0 kB
SwapTotal:       4000180 kB
SwapFree:        4000180 kB
Dirty:                24 kB
Writeback:             0 kB
AnonPages:       1104516 kB
Mapped:           301528 kB
Shmem:             21992 kB
Slab:             734076 kB
SReclaimable:     688892 kB
SUnreclaim:        45184 kB
KernelStack:        3352 kB
PageTables:        35660 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:     7882216 kB
Committed_AS:    2868820 kB
VmallocTotal:   34359738367 kB
VmallocUsed:      283580 kB
VmallocChunk:   34359443883 kB
AnonHugePages:    524288 kB
HugePages_Total:       0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
DirectMap4k:       60032 kB
DirectMap2M:     5818368 kB
DirectMap1G:     2097152 kB



Portage 2.1.11.63 (default/linux/amd64/13.0/no-multilib, gcc-4.7.2, glibc-2.17, 3.9.2-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.9.2-gentoo-x86_64-AMD_E-350_Processor-with-gentoo-2.2
KiB Mem:     7764072 total,   1957108 free
KiB Swap:    4000180 total,   4000180 free
Timestamp of tree: Tue, 14 May 2013 02:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.4, 3.2.4
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=btver1 -mtune=btver1 -D__NO_MATH_INLINES -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=btver1 -mtune=btver1 -D__NO_MATH_INLINES -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"
LANG="fr_CA.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.ca.gentoo.org/gentoo-portage"
USE="R X acl alsa amd64 berkdb bindist bzip2 c++0x caps cli clucene cracklib crypt cxx dbus dri dvd fam ffmpeg fortran gd gdbm gles gmp go gpm graphite gtk gudev hwdb iconv idn inotify jpeg json justify keymap lame lzma minizip mmx mng modules mono mp3 mpeg mudflap ncurses newnet nls nptl ogg opencl openmp pam pch pcre pic pkcs11 png python qalculate qt3support qt4 readline semantic-desktop session sqlite sqlite3 sse sse2 sse3 sse4 sse4_1 ssl ssse3 svg taglib tcpd theora tiff udev unicode uuid vorbis x264 xattr xmp xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-minimizer nlpsolver scripting-javascript wiki-publisher" LINGUAS="fr" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Alain Toussaint 2013-05-26 05:17:44 UTC
Created attachment 349194 [details]
output of aclocal
Comment 2 Alain Toussaint 2013-05-26 05:18:15 UTC
Created attachment 349196 [details]
build.log
Comment 3 Alain Toussaint 2013-05-26 05:18:50 UTC
Created attachment 349198 [details]
emerge -pqv =sci-libs/gts-20120706
Comment 4 Alain Toussaint 2013-05-26 05:19:16 UTC
Created attachment 349200 [details]
environment file
Comment 5 Justin Lecher gentoo-dev 2013-05-27 08:51:52 UTC
Please use automake-1.13.2
Comment 6 Alain Toussaint 2013-05-28 19:56:03 UTC
Ok, I will test automake-1.13.2 this week-end and report back.

Alain
Comment 7 Alain Toussaint 2013-06-23 00:53:37 UTC
I haven't come around to testing automake 1.13.2 because I've been out of town for a few weeks but I'll be reinstalling my system during the next week and testing it.
Comment 8 Alain Toussaint 2013-07-09 23:01:35 UTC
The bug is fixed on my system, gts compile fine now.

Alain