Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 470936 - app-admin/webalizer-2.23.05 with dev-libs/geoip-1.5.0 - /usr/bin/webalizer: Symbol `GeoIPDBDescription' has different size in shared object, consider re-linking
Summary: app-admin/webalizer-2.23.05 with dev-libs/geoip-1.5.0 - /usr/bin/webalizer: S...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL: https://github.com/maxmind/geoip-api-...
Whiteboard:
Keywords: UPSTREAM
Depends on:
Blocks:
 
Reported: 2013-05-22 03:37 UTC by Christophe PEREZ
Modified: 2014-04-29 14:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe PEREZ 2013-05-22 03:37:20 UTC
After updating dev-libs/geoip from 1.4.8-r3 to 1.5.0, I now have an error with webalizer :
# /usr/bin/webalizer -Q -c /etc/webalizer/novazur.fr.conf 
/usr/bin/webalizer: Symbol `GeoIPDBDescription' has different size in shared object, consider re-linking

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2013-05-22 18:29:20 UTC
Hm, did upstream forget to bump the SONAME?
Comment 2 Christophe PEREZ 2013-07-01 15:03:21 UTC
updating to 1.5.1 didn't change anything.
I'll mask * > 1.5
Comment 3 Anthony Basile gentoo-dev 2013-07-01 19:30:23 UTC
there is nothing for webalizer to do here, the problem is in geoip.  I can look at it, but just to be clear, it should be assigned to netmon@gentoo.org
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-07-02 14:49:02 UTC
Did you actually rebuild webalizer yet? :)
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2013-07-20 05:31:25 UTC
./geoip-1.4.8-r3/work/GeoIP-1.4.8/libGeoIP/GeoIP.h:#define NUM_DB_TYPES (33+1)
./geoip-1.5.0/work/GeoIP-1.5.0/libGeoIP/GeoIP.h:#define NUM_DB_TYPES (38+1)
./geoip-1.5.1/work/geoip-api-c-1.5.1/libGeoIP/GeoIP.h:#define NUM_DB_TYPES (38+1)
Comment 6 Kristian Duus Østergaard 2013-07-24 09:29:16 UTC
I have had the exact same problem and rebuilding Webalizer solved it.

I think the ebuild of dev-libs/geoip should have a comment that rebuilding eg. webalizer is necessary or better yet force rebuilding of webalizer.
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2014-04-29 14:35:05 UTC
See URL, "We decided against changing the soname."

1.6.0 is now stable and we still haven't seen a SONAME update.