Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 470922 - app-text/asciidoc-8.6.8-r1 - No Python implementation selected for the build. Please set the PYTHON_SINGLE_TARGET variable in your make.conf to one of the following values: python2_5 python2_6 python2_7 pypy1_9 pypy2_0
Summary: app-text/asciidoc-8.6.8-r1 - No Python implementation selected for the build....
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo SGML herd
URL:
Whiteboard:
Keywords:
: 471324 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-21 22:59 UTC by Dmitry Isaenko
Modified: 2013-05-28 14:20 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Isaenko 2013-05-21 22:59:13 UTC
app-text/asciidoc-8.6.8-r1 failed to emerge because of PYTHON_SINGLE_TARGET collision.
System settings of PYTHON are:
USE_PYTHON="2.7 3.2"
PYTHON_TARGETS="python2_7 python3_2"
PYTHON_SINGLE_TARGET="python3_2"

More info about failure and make.conf + emerge --info below.


>>> Installing (2 of 91) sys-apps/usbutils-006-r1
 
>>> Emerging (3 of 91) app-text/asciidoc-8.6.8-r1
 * asciidoc-8.6.8.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                                                   [ ok ]
 * No Python implementation selected for the build. Please set
 * the PYTHON_SINGLE_TARGET variable in your make.conf to one
 * of the following values:
 *
 * python2_5 python2_6 python2_7 pypy1_9 pypy2_0
 
 * ERROR: app-text/asciidoc-8.6.8-r1 failed (setup phase):
 *   No supported Python implementation in PYTHON_SINGLE_TARGET.
 *
 * Call stack:
 *                 ebuild.sh, line  93:  Called pkg_setup
 *                 ebuild.sh, line 324:  Called python-single-r1_pkg_setup
 *   python-single-r1.eclass, line 242:  Called die
 * The specific snippet of code:
 *              die "No supported Python implementation in PYTHON_SINGLE_TARGET."
 *
 * If you need support, post the output of `emerge --info '=app-text/asciidoc-8.6.8-r1'`,
 * the complete build log and the output of `emerge -pqv '=app-text/asciidoc-8.6.8-r1'`.
 * The complete build log is located at '/var/tmp/portage/app-text/asciidoc-8.6.8-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/asciidoc-8.6.8-r1/temp/die.env'.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/app-text/asciidoc-8.6.8-r1/work/asciidoc-8.6.8'
 
>>> Failed to emerge app-text/asciidoc-8.6.8-r1, Log file:
 
>>>  '/var/tmp/portage/app-text/asciidoc-8.6.8-r1/temp/build.log'
 
 
------------------------------------------------------------------------------------------------------
# cat /etc/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
 
CFLAGS="-march=core2 -pipe -O2"
CXXFLAGS="-march=core2 -pipe -O2"
ACCEPT_KEYWORDS="~amd64"
ACCEPT_LICENSE="*"
PORTAGE_TMPDIR=/var/tmp
PORTDIR=/usr/portage
DISTDIR=/usr/portage/distfiles
PKGDIR=/usr/portage/packages
PORTAGE_RSYNC_RETRIES="3"
PORTDIR_OVERLAY=""
VIDEO_CARDS="nv vesa nvidia"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build=n"
ABI_X86="32 64"
PORTAGE_REPO_DUPLICATE_WARN="0"
 
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
MAKEOPTS="-j3"
GENTOO_MIRRORS="http://gentoo.iteam.net.ua/ http://gentoo.kiev.ua/ftp/ ftp://gentoo.kiev.ua/"
ALSA_CARDS="hda-intel"
CHOST="x86_64-pc-linux-gnu"
INPUT_DEVICES="evdev keyboard mouse synaptics"
# These are the USE flags that were used in addition to what is provided by the
CAMERAS="canon"
# profile used for building.
USE="python_single_target_python2_7 upcall oscar google libkms -lastfm hwdb vmware-tools prison g3dvl pdo upnp gudev sse3 sse4 ogg java6 kipi fbcon fbcondecor theora ntfs-3g apng vdpau encode declarative chm python3 scanner private-headers icq jabber static-libs xml rar dhcp mppe-mppc aqua v4l2 policykit fuse reiserfs ntfs ppds vpn qt3support x264 semantic-desktop extras fts3 cups gnutls icotools winetools connection-sharing dhclient dhcpcd resolvconf wifi mng bluetooth  sql webkit consolekit kde nxclient gd usb mustek dvd dvdr nowlistening synaptics mysql php apache2 xulrunner v4l laptop networkmanager emerald cairo glitz svg gtk mmx xcomposite truetype mmxext sse3 ssse3 xcb themes wma wavpack embedded suid sqlite mplayer animate visualization mp4 threads djvu smb 7zip samba vorbis ffmpeg flac aac pascal xinerama gimp nptl nptlonly foomaticdb cups ghostscript gstreamer -hal mp3 png jpeg gif alsa acpi X dbus sse sse2 opengl qt4 qt5 udev tiff"
LINGUAS="ru"
APACHE2_MODULES="access compat socache_shmcb unixd authn_core authz_core"
 
USE_PYTHON="2.7 3.2"
PYTHON_TARGETS="python2_7 python3_2"
PYTHON_SINGLE_TARGET="python3_2"
 
NETBEANS_MODULES="ide php visualweb webcommon"
source /var/lib/layman/make.conf
------------------------------------------------------------------------------------------------------
# emerge --info
Portage 2.1.12.1 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.17, 3.9.0-gentoo x86_64)
=================================================================
System uname: Linux-3.9.0-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-gentoo-2.2
KiB Mem:     2050572 total,    573548 free
KiB Swap:    2098844 total,   1531372 free
Timestamp of tree: Tue, 21 May 2013 18:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.4, 3.1.5-r1, 3.2.4
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.2
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -pipe -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=core2 -pipe -O2"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.iteam.net.ua/ http://gentoo.kiev.ua/ftp/ ftp://gentoo.kiev.ua/"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X aac acl acpi alsa amd64 animate apache2 apng berkdb bluetooth bzip2 cairo chm cli connection-sharing consolekit cracklib crypt cups cxx dbus declarative dhclient dhcp dhcpcd djvu dri dvd dvdr embedded emerald encode extras fbcon fbcondecor ffmpeg flac foomaticdb fortran fts3 fuse g3dvl gd gdbm ghostscript gif gimp glitz gnutls google gpm gstreamer gtk gudev hwdb iconv icotools icq ipv6 jabber java6 jpeg kde kipi laptop libkms mmx mmxext mng modules mp3 mp4 mplayer mppe-mppc mudflap multilib mustek mysql ncurses networkmanager nls nowlistening nptl nptlonly ntfs ntfs-3g nxclient ogg opengl openmp oscar pam pascal pcre pdo php png policykit ppds prison private-headers python3 qt3support qt4 qt5 rar readline reiserfs resolvconf samba scanner semantic-desktop session smb sql sqlite sse sse2 sse3 sse4 ssl ssse3 static-libs suid svg synaptics tcpd themes theora threads tiff truetype udev unicode upcall upnp usb v4l v4l2 vdpau visualization vmware-tools vorbis vpn wavpack webkit wifi winetools wma x264 xcb xcomposite xinerama xml xulrunner zlib" ABI_X86="32 64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access compat socache_shmcb unixd authn_core authz_core" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru" NETBEANS_MODULES="ide php visualweb webcommon" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python3_2" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nv vesa nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mike Gilbert gentoo-dev 2013-05-22 02:23:42 UTC
This isn't a bug; the error message explains the configuration problem. We set PYTHON_SINGLE_TARGET=python2_7 in the default profile for a reason.

Not all python packages are ready for python3. You can override this using package.env or package.use.
Comment 2 Dmitry Isaenko 2013-05-22 02:32:34 UTC
(In reply to comment #1)
> This isn't a bug; the error message explains the configuration problem. We
> set PYTHON_SINGLE_TARGET=python2_7 in the default profile for a reason.
> 
> Not all python packages are ready for python3. You can override this using
> package.env or package.use.

That's explains everything. I didn't know that python2_7 - default for profile, so - my fault. Thank you for your time and explanation, I appreciate that.
Comment 3 Mike Gilbert gentoo-dev 2013-05-22 02:36:04 UTC
So... why did you just reopen this bug?

If you have reason I'm willing to hear it, but I genuinely believe that this cannot be "fixed" without a major change to the python-single-r1 eclass.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-05-28 14:19:20 UTC
*** Bug 471232 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2013-05-28 14:20:15 UTC
*** Bug 471324 has been marked as a duplicate of this bug. ***