Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 470200 - =net-libs/gnome-online-accounts-3.8.2 needs to depend on =dev-libs/json-c-0.11
Summary: =net-libs/gnome-online-accounts-3.8.2 needs to depend on =dev-libs/json-c-0.11
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on: 475954
Blocks: gnome-3.8
  Show dependency tree
 
Reported: 2013-05-17 20:40 UTC by vax456
Modified: 2013-07-07 05:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vax456 2013-05-17 20:40:33 UTC
In Gnome 3.8, when adding a Google account, gnome-control-center segfaults in a shared library belonging to json-c.  This occured when using =dev-libs/json-c-0.9-r1.

After upgrading to =dev-libs/json-c-0.11, the segfault stopped and I was able to add a Google account.  I didn't test if it worked with =dev-libs/json-c-0.10-r1.
Comment 1 Pacho Ramos gentoo-dev 2013-05-18 13:49:54 UTC
+  18 May 2013; Pacho Ramos <pacho@gentoo.org>
+  -gnome-online-accounts-3.8.1.ebuild, gnome-online-accounts-3.8.2.ebuild:
+  >=dev-libs/json-c-0.10-r1 needed (#470200 by vax456), drop old
+
Comment 2 Gilles Dartiguelongue gentoo-dev 2013-07-01 19:42:41 UTC
The problem is that with no trace, it is hard to say why it went to json-c since the library is not linked by gnome-online-accounts...

# qdepends -Q json-c 2> /dev/null
dev-libs/libreport-2.0.13
media-sound/pulseaudio-4.0

I quick grep through NEEDED.ELF.2 also does not raise more results which is normal hence I am reopening this bug report as I will drop json-c from g-o-a dependencies with no further proofs of the problem.
Comment 3 Pacho Ramos gentoo-dev 2013-07-01 20:02:33 UTC
+  01 Jul 2013; Pacho Ramos <pacho@gentoo.org>
+  gnome-online-accounts-3.8.2.ebuild:
+  Drop json-c dep as discussed in #470200 with Gilles, since I can neither
+  reproduce the problem *now* (I was some months ago). Feel free to reopen if
+  you still suffer the problem with latest versions.
+