Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 469992 - net-fs/openafs-kernel-1.6.2 with sys-kernel/gentoo-sources 3.9.2 - .../work/openafs-1.6.2/src/libafs/MODLOAD-3.9.2-gentoo-MP/osi_vnodeops.c:727:56: error: macro "hlist_for_each_entry" passed 4 arguments, but takes just 3
Summary: net-fs/openafs-kernel-1.6.2 with sys-kernel/gentoo-sources 3.9.2 - .../work/o...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Andrej Filipcic
Depends on:
Reported: 2013-05-15 19:50 UTC by Mike Hammill
Modified: 2013-08-27 08:17 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

build log (build.log,99.57 KB, text/plain)
2013-05-15 19:52 UTC, Mike Hammill
Patch to fix openafs-compilation with kernel 3.9 (openafs-1.6.2-kernel-3.9.patch,2.80 KB, patch)
2013-06-29 18:33 UTC, Oliver Freyermuth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Hammill 2013-05-15 19:50:30 UTC
Whereas 1.6.2 compiles with 3.8.10, it does not with 3.9.2.  According to the fellow Gentooer's report at the given URL above, it doesn't compile with 3.9.0 either.  

Reproducible: Always

Steps to Reproduce:
Install new 3.9.2 kernel from gentoo-sources.  Rebuild kernel modules.
Actual Results:  
openafs-kernel fails to build.

Expected Results:  
openafs-kernel module usable with 3.9.2

I will submit the build shortly.
I have not yet tried the solution given at the above URL.
Comment 1 Mike Hammill 2013-05-15 19:52:44 UTC
Created attachment 348426 [details]
build log
Comment 2 Mike Hammill 2013-05-15 19:53:46 UTC
# emerge --info openafs-kernel
Portage (default/linux/amd64/13.0/no-multilib, gcc-4.6.3, glibc-2.15-r3, 3.9.2-gentoo x86_64)
                        System Settings
System uname: Linux-3.9.2-gentoo-x86_64-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-gentoo-2.2
KiB Mem:     3599768 total,    276364 free
KiB Swap:    8393956 total,   8386196 free
Timestamp of tree: Wed, 15 May 2013 11:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.4
dev-util/ccache:          3.1.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo bleeding-edge betagarden sunrise mhammill
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
EMERGE_DEFAULT_OPTS="--autounmask=y --autounmask-write"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/bleeding-edge /var/lib/layman/betagarden /var/lib/layman/sunrise /usr/local/portage"
USE="X aac aalib acl afs alsa amd64 apache2 apng aspell assistant autoipd avahi bash-completion berkdb bidi branding bzip2 cairo caps cdda cddb cdparanoia cdr cgi cli consolekit contrib cracklib crypt curl cvs cxx dbus desktop-integration device-mapper dga dia djvu docbook dot dri dts dv dvd dvi dvi2tty dvipdfm emacs encode exif extensions extra extras fam ffmpeg fftw flac fltk fontconfig fortran fuse g3dvl gallium gcrypt gdbm gdu geoip gif gimp git gnuplot gnutls gpm graphics graphviz gs gstreamer gtk gtk3 hddtemp helpers hpn hwdb hyphenation iconv icu idn imagemagick imlib ipv6 jai java java6 javascript jpeg kerberos keymap kpathsea lame latex latex3 lcms ldap libcaca libnotify libxml2 lightning live lm_sensors lua lxde lyx m17n-lib mad mailwrapper matroska md5sum mmx mng modules mp3 mpeg mpi mpm-worker mudflap nagios-ntp nagios-ssh nano-syntax ncurses network network-cron nls no-old-linux nptl nsplugin nss ogg opencl opengl openmp openssl orc pam pcre pdf perl plotutils png policykit postscript ppds pulseaudio python qt3support qt4 quicktime raw rcs readline realtime rtf ruby sasl schroedinger screenshot secure-delete sensord session skins sound spell sse sse2 ssh ssl startup-notification stats stream subversion svg system-sqlite system-v8 t1lib tcl tcpd templates tex4ht theora threads tiff tk tor tordns truetype twolame udev unicode upnp v4l v4l2 v8 vhosts vlm vorbis webdav webkit wmf wxwidgets x264 xattr xcb xft xinerana xscreensaver xulrunner xv xvmc zlib" ABI_X86="64" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access actions alias asis auth auth_anon auth_dbm auth_digest authz_default authz_host autoindex cache case_filter_in case_filter cern_meta cgi cgid charset_lite dav dav_fs dav_lock deflate dir disk_cache echo env expires ext_filter file_cache filter headers imap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_connect proxy_ftp proxy_http rewrite setenvif so speling status unique_id unique_id userdir usertrack vhost_alias authn_file authz_groupfile authz_user" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="lvm bootchart" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US en_GB sv sv_SE" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

net-fs/openafs-kernel-1.6.2 was built with the following:
Comment 3 Oliver Freyermuth 2013-06-29 18:33:06 UTC
Created attachment 352252 [details, diff]
Patch to fix openafs-compilation with kernel 3.9

Upstream has a patch included to fix this problem:;a=patch;h=d585eb30baf767d50e93ee52db88d73afb76e9cb
For convenience, I have also attached a patchfile to this bug which works for me (compilation succeeds and openafs appears to work fine afterwards with kernel 3.9).
Comment 4 Steffen 2013-07-08 12:19:19 UTC
(In reply to Oliver Freyermuth from comment #3)
> Created attachment 352252 [details, diff] [details, diff]
> Patch to fix openafs-compilation with kernel 3.9
> Upstream has a patch included to fix this problem: 
> h=d585eb30baf767d50e93ee52db88d73afb76e9cb
> For convenience, I have also attached a patchfile to this bug which works
> for me (compilation succeeds and openafs appears to work fine afterwards
> with kernel 3.9).


I had encountered the same bug and your patch fixed it for me. Thank you.

Comment 5 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-08-27 08:17:21 UTC
Fixed in 1.6.5 per bug #478498.