Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 469846 - =net-print/cups-1.6.2-r4 - Unexpanded ${EPREFIX} in installed files.
Summary: =net-print/cups-1.6.2-r4 - Unexpanded ${EPREFIX} in installed files.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
: 469820 (view as bug list)
Depends on:
Blocks: cups-1.6-stable
  Show dependency tree
 
Reported: 2013-05-14 15:38 UTC by Charles G. Waldman
Modified: 2013-05-18 20:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
output of emerge --info (emerge-info,5.03 KB, text/plain)
2013-05-14 15:38 UTC, Charles G. Waldman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charles G. Waldman 2013-05-14 15:38:22 UTC
Created attachment 348320 [details]
output of emerge --info

after installing net-print/cups-1.6.2-r4:0  printing fails with messages like

"/etc/cups/${EPREFIX}/usr/libexec/cups/filter/commandtops" file not found 

the unexpanded string ${EPREFIX} appears in several files:

# grep EPREFIX /usr/bin/cups-config 
cups_serverbin=${EPREFIX}/usr/libexec/cups

# grep EPREFIX /usr/sbin/cups*
Binary file /usr/sbin/cupsd matches
Binary file /usr/sbin/cupsfilter matches

The EPREFIX string should have been replaced at installation time.

A quite ugly but effective workaround is to create a symbolic link:

# ln -s /  '/etc/cups/${EPREFIX}'
Comment 1 Derk W te Bokkel 2013-05-14 16:52:16 UTC
duplicate of 469846
Comment 2 Derk W te Bokkel 2013-05-14 16:54:16 UTC
(In reply to comment #1)
> duplicate of 469846

I meant 468820  ... dislexia? :(
Comment 3 Derk W te Bokkel 2013-05-14 16:55:08 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > duplicate of 469846
> 
> I meant 468820  ... dislexia? :(

blast I can't type today 469820
Comment 4 Andreas K. Hüttel gentoo-dev 2013-05-14 17:30:22 UTC
*** Bug 469820 has been marked as a duplicate of this bug. ***
Comment 5 Andreas K. Hüttel gentoo-dev 2013-05-14 17:31:54 UTC
Meh. That's what happens if you blindly trust other people to test. Give me a moment.
Comment 6 Andreas K. Hüttel gentoo-dev 2013-05-14 18:46:25 UTC
This is fixed in 1.6.2-r5. Please rebuild cups-filters after upgrading to be sure everything is OK.
Comment 7 Frank Hellmuth 2013-05-18 17:35:03 UTC
That doesn't solve the problem for me:

# emerge -pv cups cups-filters

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-print/cups-1.6.2-r5  USE="X acl dbus filters java pam python ssl threads usb zeroconf -debug -gnutls -kerberos -lprng-compat (-selinux) -static-libs -xinetd" LINGUAS="-ca -es -fr -ja -ru" 0 kB
[ebuild   R    ] net-print/cups-filters-1.0.34-r1  USE="jpeg png tiff zeroconf -perl -static-libs" 0 kB

# emerge -1 cups cups-filters
Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Emerging (1 of 2) net-print/cups-1.6.2-r5
>>> Installing (1 of 2) net-print/cups-1.6.2-r5
>>> Emerging (2 of 2) net-print/cups-filters-1.0.34-r1
>>> Installing (2 of 2) net-print/cups-filters-1.0.34-r1
>>> Jobs: 2 of 2 complete                           Load avg: 2.63, 1.49, 0.66
[...]

# /etc/init.d/cupsd restart
 * Caching service dependencies ...
/lib64/rc/bin/eerror
Service `#cups-browsed#' needs non existent service `cups'                [ ok ]
 * Stopping cupsd ...                                                     [ ok ]
 * Starting cupsd ...                                                     [ ok ]

Still the printer has the status

Paused - "Backend /etc/cups/${EPREFIX}/usr/libexec/cups/backend/socket does not exist!"
Comment 8 Frank Hellmuth 2013-05-18 17:37:48 UTC
Removing the backup file /etc/init.d/#cups-browsed#  (don't know where that came from) doesn't help either.
Comment 9 Andreas K. Hüttel gentoo-dev 2013-05-18 17:42:00 UTC
(In reply to comment #7)
> That doesn't solve the problem for me:

> Still the printer has the status
> 
> Paused - "Backend /etc/cups/${EPREFIX}/usr/libexec/cups/backend/socket does
> not exist!"

did you try manually restarting the printer?
Comment 10 Frank Hellmuth 2013-05-18 19:02:34 UTC
(In reply to comment #9)

> did you try manually restarting the printer?

No, I thought restarting cups would do that. Thanks, resuming the printers made them working again. Sorry for complaining and thanks again for the fix and the hint!
Comment 11 Andreas K. Hüttel gentoo-dev 2013-05-18 20:02:17 UTC
(In reply to comment #10)
> (In reply to comment #9)
> 
> > did you try manually restarting the printer?
> 
> No, I thought restarting cups would do that. Thanks, resuming the printers
> made them working again. Sorry for complaining and thanks again for the fix
> and the hint!

Great! Cheers!