Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 469504 - app-accessibility/sphinxbase-0.8 with automake-1.13 - test/regression/Makefile.am:38: error: using '$(srcdir)' in TESTS is currently broken: '$(srcdir)/test-*.sh'
Summary: app-accessibility/sphinxbase-0.8 with automake-1.13 - test/regression/Makefil...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Accessibility Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-05-11 22:47 UTC by Krzysztof Magusiak
Modified: 2014-01-05 04:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
aclocal.out of the build (aclocal.out,211 bytes, text/plain)
2013-05-11 22:48 UTC, Krzysztof Magusiak
Details
emerge --info (emerge.info,6.57 KB, text/plain)
2013-05-11 22:49 UTC, Krzysztof Magusiak
Details
automake.out (automake.out,985 bytes, text/plain)
2013-12-13 03:21 UTC, piruthiviraj natarajan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysztof Magusiak 2013-05-11 22:47:14 UTC
Running automake fails when emerging sphinxbase.

Reproducible: Always

Steps to Reproduce:
1. emerge sphinxbase pocketsphinx
Actual Results:  
 * Running autoconf ...                                                  [ ok ]
 * Running autoheader ...                                                [ ok ]
 * Running automake --add-missing --copy ...                             [ !! ]

 * Failed Running automake !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/app-accessibility/sphinxbase-0.8/temp/automake.out

 * ERROR: app-accessibility/sphinxbase-0.8 failed (prepare phase):
 *   Failed Running automake !
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 4278:  Called autotools-utils_src_prepare
 *   environment, line 1054:  Called eautoreconf
 *   environment, line 1576:  Called eautomake
 *   environment, line 1525:  Called autotools_run_tool 'automake' '--add-missing' '--copy'
 *   environment, line 1163:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
Comment 1 Krzysztof Magusiak 2013-05-11 22:48:03 UTC
Created attachment 348018 [details]
aclocal.out of the build
Comment 2 Krzysztof Magusiak 2013-05-11 22:49:10 UTC
Created attachment 348024 [details]
emerge --info
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2013-05-14 13:26:14 UTC
Comment on attachment 348018 [details]
aclocal.out of the build

 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/app-accessibility/sphinxbase-0.8/temp/automake.out

(grep error:)
test/regression/Makefile.am:38: error: using '$(srcdir)' in TESTS is currently broken: '$(srcdir)/test-*.sh'
test/regression/Makefile.am:36: error: using '$(srcdir)' in TESTS is currently broken: '$(srcdir)/test-cepview.sh'
test/regression/Makefile.am:36: error: using '$(srcdir)' in TESTS is currently broken: '$(srcdir)/test-sphinx_pitch.sh'
Comment 4 Daniel 2013-09-01 10:09:21 UTC
Same for gnome-base/orbit-2.14.19-r2. Looks like automake-1.13 is broken and this has impacts to various ebuilds?
Comment 5 Mark Gomersbach 2013-09-11 10:40:37 UTC
Yes I can confirm this.
After adding "WANT_AUTOMAKE="1.12" to the ebuild it compiles fine.
Comment 6 Chris Brannon (RETIRED) gentoo-dev 2013-10-27 15:53:11 UTC
This is now fixed.  Thanks for the report.
Comment 7 piruthiviraj natarajan 2013-12-13 03:21:18 UTC
Created attachment 365204 [details]
automake.out
Comment 8 piruthiviraj natarajan 2013-12-13 03:22:00 UTC
I am still having this issue.

http://forums.gentoo.org/viewtopic-p-7460110.html
Comment 9 Claudio Roberto França Pereira 2013-12-23 00:49:19 UTC
I have the same problem with lxsession. May I attach my log here?
Comment 10 Nicolas Sahlqvist 2014-01-05 04:15:15 UTC
I had a similar problem as Claudio with lxsession, but with automake 1.14.1.
See bug 497100:
https://bugs.gentoo.org/show_bug.cgi?id=497100