Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 468694 - =media-video/handbrake-0.9.9_pre5441 fails with =sys-devel/automake 1.13 - configure.ac:7: error: 'AM_CONFIG_HEADER': this macro is obsolete.
Summary: =media-video/handbrake-0.9.9_pre5441 fails with =sys-devel/automake 1.13 - co...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tom Wijsman (TomWij) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-05-05 19:02 UTC by jannis
Modified: 2013-05-09 13:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,24.28 KB, text/plain)
2013-05-05 19:02 UTC, jannis
Details
emerge --info (einfo,23.04 KB, text/plain)
2013-05-05 19:02 UTC, jannis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2013-05-05 19:02:09 UTC
see $Summary and attached build.log

Reproducible: Always
Comment 1 jannis 2013-05-05 19:02:34 UTC
Created attachment 347452 [details]
build.log
Comment 2 jannis 2013-05-05 19:02:58 UTC
Created attachment 347454 [details]
emerge --info
Comment 3 Rafał Mużyło 2013-05-05 19:35:57 UTC
This seems to be a combination of:
configure.ac:7: error: 'AM_CONFIG_HEADER': this macro is obsolete.
(so automake 1.13) and the fact, that the upstream autogen script fails to abort upon a failure of an intermediary step.
Comment 4 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-05-05 22:31:51 UTC
Yes, will try to see if I can extract this magic and run it reliably in advance.
Comment 5 Ian Whyman (thev00d00) gentoo-dev 2013-05-07 11:36:22 UTC
Hey Tom, 

I've actually already fixed this (along with the ffmpeg dep) in a Sabayon overlay.

https://github.com/Sabayon/for-gentoo/blob/master/media-video/handbrake/handbrake-0.9.9_pre5441.ebuild

I'm interested in co-maintaining if you like?
Comment 6 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-05-07 15:31:09 UTC
(In reply to comment #5)
> I've actually already fixed this (along with the ffmpeg dep) in a Sabayon
> overlay.
> 
> https://github.com/Sabayon/for-gentoo/blob/master/media-video/handbrake/
> handbrake-0.9.9_pre5441.ebuild
> 
> I'm interested in co-maintaining if you like?

Yes, you're welcome to do so; feel free to add yourself to the metadata.xml.

Please note that I made some small changes as well, so please merge with them if possible. They can be seen at http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-video/handbrake/handbrake-0.9.9_pre5441.ebuild?r1=1.1&r2=1.2

Did you try ffmpeg-1.1.4 and libav-9 whether they work?

I know it works with ffmpeg-1.2 but haven't tried ffmpeg-1.1.4, I didn't consider trying it because I believe we are depending on a feature that was introduced near ffmpeg-1.2. But now that I think of it I'm not sure whether ffmpeg-1.1.4 falls under that or not.

Removing autogen.sh and using eautoreconf is also a very good idea!

You can find me on IRC if needed.
Comment 7 Ian Whyman (thev00d00) gentoo-dev 2013-05-07 17:26:35 UTC
+  07 May 2013; Ian Whyman <thev00d00@gentoo.org> handbrake-0.9.9_pre5441.ebuild,
+  metadata.xml:
+  Fix build with automake 1.13 #468694, call eautoreconf instead of autogen.sh,
+  add myself to maintainers
+

Sync in a couple of hours.
Comment 8 jannis 2013-05-09 13:08:26 UTC
works, thanks for the fix. Using ffmpeg-1.2 here