Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 468516 - dev-db/phpmyadmin-4.0.4.1 - version bump
Summary: dev-db/phpmyadmin-4.0.4.1 - version bump
Status: RESOLVED DUPLICATE of bug 479870
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Alex Legler (RETIRED)
URL: http://sourceforge.net/p/phpmyadmin/n...
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2013-05-03 20:37 UTC by Tianon
Modified: 2013-10-06 15:23 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
phpmyadmin 4.0.0 ebuild patch (phpmyadmin-4.0.0.patch,449 bytes, patch)
2013-05-06 12:38 UTC, Iván Atienza
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tianon 2013-05-03 20:37:55 UTC
I haven't tried doing a manual bump to see if we're free and easy, but 4.0.0 is out now and there wasn't a ticket for the bump yet, so here it is.

Reproducible: Always
Comment 1 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2013-05-03 20:54:10 UTC
(In reply to comment #0)
> and there wasn't a ticket for the bump yet, so here it is.

phpMyAdmin 4.0.0 is released (Fri, 03 May 2013 12:22:50 GMT)
Tianon 2013-05-03 20:37:55 UTC

go figure...
Comment 2 Tianon 2013-05-03 20:57:35 UTC
Just trying to help :)
Comment 3 László Szalma 2013-05-06 07:53:50 UTC
I tried to rename the 3.5.8 ebuild to 4.0.0. I had to change

- dodoc Documentation.txt README RELEASE-DATE-${MY_PV} ChangeLog || die
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die

because Documentation.txt is not included in the package anymore.

This way the emerge succeed, and phpmyadmin works like 3.5.8.

I haven't tried the optional USE flags.

[ebuild   R    ] dev-db/phpmyadmin-4.0.0:4.0.0::x-dblaci-system  USE="-setup -vhosts" 0 kB
Comment 4 Iván Atienza 2013-05-06 12:37:38 UTC
also 4.0.0 includes doc dir not in previous versions, but the documentation is avaliable anyway trough the interface (online doc), so i just remove the doc dir. I attach the ebuild diff.

Salud.
Comment 5 Iván Atienza 2013-05-06 12:38:39 UTC
Created attachment 347514 [details, diff]
phpmyadmin 4.0.0 ebuild patch
Comment 6 ChaosEngine 2013-05-06 14:54:59 UTC
I've prepared everything as usuall and successfully emerged on VPS.

Ebuild link:
https://github.com/ChaosEngine/portage/tree/master/dev-db/phpmyadmin

Works ok for now. Bump?
Comment 7 Iván Atienza 2013-06-09 11:39:27 UTC
4.0.3 out http://sourceforge.net/p/phpmyadmin/news/2013/06/phpmyadmin-403-is-released/

Salud.
Comment 8 ChaosEngine 2013-06-26 21:17:57 UTC
Version 4.0.4 came out and works flawlessly with current ebuild with modified name -> phpmyadmin-4.0.4.ebuild
Comment 9 Denis M. (Phr33d0m) 2013-07-25 13:44:46 UTC
Tested and working ebuild for 4.0.4.1 at comment 6.
Comment 10 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2013-08-17 23:56:56 UTC

*** This bug has been marked as a duplicate of bug 479870 ***