Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 46800 - Cannot initialize the Ximian Evolution shell
Summary: Cannot initialize the Ximian Evolution shell
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2004-04-04 15:26 UTC by Sveinung Kvilhaugsvik
Modified: 2004-07-26 04:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sveinung Kvilhaugsvik 2004-04-04 15:26:35 UTC
Have just installed Gentoo on a new computer. When I tryed to start evolution it refuses to start, giving me the message "Cannot initialize the Ximian Evolution shell" It works fine on other mashines I have, so I guess it must be unfofilled dependencyes.
I have already tryen to emerge oaf (some pages on the internet suggested it)

Reproducible: Always
Steps to Reproduce:
1.emerge evolution
2.log in as normal user
Comment 1 Alastair Tse (RETIRED) gentoo-dev 2004-04-05 03:11:11 UTC
try starting it from a terminal and see if there are any messages. also include the output of "emerge info"
Comment 2 Sveinung Kvilhaugsvik 2004-04-05 10:24:55 UTC
Sorry I did not include that at once... 

$ evolution

(evolution:4145): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
file /home/sveinung/evolution/vfolders.xml contains nothing to upgrade
file /home/sveinung/evolution/vfolders.xml contains nothing to upgrade
evolution-shell-Message: Evolution configuration upgraded to version: 1.4.0
(Killing old version of Wombat...)

From emerge info:
Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.22-gentoo-r7)
System uname: 2.4.22-gentoo-r7 i686 AMD Athlon(tm) XP 1800+
Gentoo Base System version
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.3
CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X aim alsa apm arts avi berkdb cdr crypt cups doc dvb dvd encode esd evo flac flash foomaticdb gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2 icq imagemagic imlib jabber java jpeg kde lcms ldap libg++ libwww linguas_en linguas_nb linguas_nn linguas_no mad maildir memlimit mikmod mmx motif mozilla mpeg msn ncurses nls oggvorbis opengl oscar oss pam pdflib perl png ppds python qt quicktime readline samba scanner sdl slang slp speex spell sse ssl svga tcltk tcpd theora tiff truetype trutype unicode usb videos wmf wxwindows x86 xinema xml xml2 xmms xv yahoo zlib"
Comment 3 Sveinung Kvilhaugsvik 2004-04-09 13:37:27 UTC
I should also mention that I dont have Gnome installed. (portage did'nt install it)
Comment 4 Alastair Tse (RETIRED) gentoo-dev 2004-07-25 11:53:39 UTC
wondering if this bug is still around? have you tried using a different LANG environment? 
Comment 5 Sveinung Kvilhaugsvik 2004-07-25 12:28:53 UTC
Well, the bug was arond, even after many rebuilds and new versions... Hoever, I just viped the disk and started to install all over again. As soon as i had X working, I was planning to close this bug if it then worked... Never tryed different LANG settings. That might be it...
Comment 6 Sveinung Kvilhaugsvik 2004-07-26 04:12:47 UTC
Works fine now. :)