Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 467784 - media-libs/plotutils fails to build with =sys-devel/automake-1.13.1 - configure.ac:9: error: 'AM_CONFIG_HEADER': this macro is obsolete.
Summary: media-libs/plotutils fails to build with =sys-devel/automake-1.13.1 - configu...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-04-28 19:47 UTC by 白川間瀬流
Modified: 2013-05-03 17:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild for workaround (plotutils-2.6-r1.ebuild,2.07 KB, text/plain)
2013-04-28 19:57 UTC, 白川間瀬流
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 白川間瀬流 2013-04-28 19:47:02 UTC
* Messages for package media-libs/plotutils-2.6:

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/media-libs/plotutils-2.6/temp/aclocal.out
 * ERROR: media-libs/plotutils-2.6 failed (prepare phase):
 *   Failed Running aclocal !
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 2902:  Called eautoreconf
 *   environment, line  822:  Called eaclocal
 *   environment, line  725:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  595:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 * 
 * If you need support, post the output of `emerge --info '=media-libs/plotutils-2.6'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/plotutils-2.6'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/plotutils-2.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/plotutils-2.6/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/plotutils-2.6/work/plotutils-2.6'
 * S: '/var/tmp/portage/media-libs/plotutils-2.6/work/plotutils-2.6'

 * Regenerating GNU info directory index...
 * Processed 165 info files.
VampPC zthread # cat /var/tmp/portage/media-libs/plotutils-2.6/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/media-libs/plotutils-2.6/work/plotutils-2.6
***** aclocal

configure.ac:9: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.ac:9: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Reproducible: Always
Comment 1 白川間瀬流 2013-04-28 19:57:08 UTC
Created attachment 346812 [details]
Ebuild for workaround
Comment 2 Andreas K. Hüttel gentoo-dev 2013-05-03 17:01:59 UTC
Fixed, thanks