Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 467774 - Unable to explicitely downgrade a library due to problems with subslots
Summary: Unable to explicitely downgrade a library due to problems with subslots
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
: 500884 (view as bug list)
Depends on:
Blocks: 300071
  Show dependency tree
Reported: 2013-04-28 18:47 UTC by Markos Chandras (RETIRED)
Modified: 2019-06-06 13:18 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras (RETIRED) gentoo-dev 2013-04-28 18:47:25 UTC
so i emerged x11-libs/libfm-9999, then x11-misc/pcmanfm-1.1.0-r1 and then I try to downgrade x11-libs/libfm-1.1.0-r1 and I get this

helix ~ # emerge -1av =x11-libs/libfm-1.1.0-r1                                                                                                                                                                                                

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] x11-libs/libfm-1.1.0-r1:0/4.1.1 [9999:0/4.0.0] USE="-debug -doc -examples -vala" 0 kB

Total: 1 package (1 downgrade), Size of downloads: 0 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  (x11-libs/libfm-9999::gentoo, installed) pulled in by
    >=x11-libs/libfm-1.1.0:0/4.0.0= required by (x11-misc/pcmanfm-1.1.0-r1::gentoo, installed)

  (x11-libs/libfm-1.1.0-r1::gentoo, ebuild scheduled for merge) pulled in by

I believe portage should allowed me to explicitly downgrade the library without marking the newest version first.
Comment 1 Zac Medico gentoo-dev 2013-04-28 19:39:29 UTC
If we translate the argument into an implicit mask for the higher unmatching versions in the same slot, then that should solve it.
Comment 2 Ben Kohler gentoo-dev 2014-03-20 18:27:01 UTC
*** Bug 500884 has been marked as a duplicate of this bug. ***
Comment 3 dE 2014-07-17 05:53:33 UTC
I would too like this behavior to be fixed.