Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 467290 - app-crypt/gpgme-1.4.0 hangs in tests
Summary: app-crypt/gpgme-1.4.0 hangs in tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Crypto team [DISABLED]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-26 04:07 UTC by Patrick Lauer
Modified: 2014-02-16 00:25 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2013-04-26 04:07:30 UTC
===================
All 21 tests passed
===================
make[3]: Leaving directory `/var/tmp/portage/app-crypt/gpgme-1.4.0/work/gpgme-1.4.0/tests/gpg'
make[2]: Leaving directory `/var/tmp/portage/app-crypt/gpgme-1.4.0/work/gpgme-1.4.0/tests/gpg'
Making check in gpgsm
make[2]: Entering directory `/var/tmp/portage/app-crypt/gpgme-1.4.0/work/gpgme-1.4.0/tests/gpgsm'
make  check-TESTS
make[3]: Entering directory `/var/tmp/portage/app-crypt/gpgme-1.4.0/work/gpgme-1.4.0/tests/gpgsm'
PASS: t-import
Warning: Skipping unknown key 135CEC36F49CB8E93B1AB270CD80884676CE8F33
Warning: Skipping unknown key EA8D99DD36AA2D071A3C7B69009E51B94A2EE760
Warning: Skipping unknown key 31C9D2E6314D0BCC2C1A4500A66B979827188ECD
Warning: Skipping unknown key 759A4ACE7CDA7E891BB2724BE376EA473A969724
Warning: Skipping unknown key A08BDF3BAAEE3F9D646C47812321D4A61881671D
Warning: Skipping unknown key 447ED4E39AD792E207FA531A2EF5B8025B4757B0
Warning: Skipping unknown key ACA7BE451FA6BF09F2D13F087BBCEB7F46A2CC8A
Warning: Skipping unknown key 426AF67830E9CE245BEF41A2C1A851DAC50A6DF5
Warning: Skipping unknown key DB453D1BB01AF323106BDED0096157AAF425E05B
Warning: Skipping unknown key E0BF1B91916B88E4F1159222CE372396B14A2E5C
Warning: Skipping unknown key 982A75670FF8284A94E09D23D8E762C8BDA45404
Warning: Skipping unknown key 7DDC761CFDAF4CE03AB53ADDC9FA133519A3DEC9
Warning: Skipping unknown key 7A3C1B602EBDA4A1E0EBAD7ABA4FD14369A939FC
Warning: Skipping unknown key C92FE650DB3259E0CE6555F38C76E0B8A8FEA3CA
Warning: Skipping unknown key D5C750F2FE4EEED7C7B1E4137BFB54843A7D979B
Checking key 3CF405464F66ED4A7DF45BBDD1E4282E33BDB76E
Checking key DFA56FB5FC41E3A8921F77AD1622EEFD9152A5AD
Checking key 2C8F3C356AB761CB3674835B792CDA52937F9285
PASS: t-keylist
-----BEGIN ENCRYPTED MESSAGE-----
MIAGCSqGSIb3DQEHA6CAMIACAQAxggELMIIBBwIBADBwMGsxCzAJBgNVBAYTAkRF
MRMwEQYDVQQHFApE/HNzZWxkb3JmMRYwFAYDVQQKEw1nMTAgQ29kZSBHbWJIMRkw
FwYDVQQLExBBZWd5cHRlbiBQcm9qZWN0MRQwEgYDVQQDEwt0ZXN0IGNlcnQgMQIB
ADANBgkqhkiG9w0BAQEFAASBgGEAmcScbxE52XwnW4s7krb3+4nVbeRNJ8GDEBur
wmaLDW8NNyI3mCJJv9pz0Qbi6uJK9MuhsPqq0CO+gDsHwbbTQZXF3tBfxPdarthD
gqjSpBL1xejPgfWl/xLgOq+GsmJt2YnoO/bqpTV2JWpKMxUCRBVev8ZLdHxfrXXf
AAiLMIAGCSqGSIb3DQEHATAUBggqhkiG9w0DBwQIS6u3BRN86TmggAQIEGqaJkza
O3kECIcF4az1l6+kAAAAAAAAAAAAAA==
-----END ENCRYPTED MESSAGE-----
PASS: t-encrypt
^C

Exiting on signal 2

Portage 2.1.11.62 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.2, glibc-2.17, 3.8.5-gentoo x86_64)
=================================================================
System uname: Linux-3.8.5-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:     7921068 total,   4389236 free
KiB Swap:   25165812 total,  23525476 free
Timestamp of tree: Unknown
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.11_rc2-r1::kde
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo kde
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli compat consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fontconfig fortran gdbm gif gpm gtk gudev iconv ipv6 java jpeg kde kipi lcms ldap libnotify mad minizip mmx mng modules mp3 mp4 mpeg mssql mudflap multilib mysql ncurses nls nptl odbc ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds python qt3support qt4 readline script sdl semantic-desktop session spell sqlite sse sse2 ssl startup-notification svg tcpd threads tiff tk truetype udev udisks unicode upower usb vlc vorbis webkit wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vesa radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Alon Bar-Lev gentoo-dev 2013-05-04 21:58:18 UTC
Reproduced. Not sure what I can do about this... will open upstream bug.
Comment 2 Alon Bar-Lev gentoo-dev 2013-05-04 22:06:58 UTC
https://bugs.g10code.com/gnupg/issue1493
Comment 3 Alon Bar-Lev gentoo-dev 2013-05-22 15:30:21 UTC
Hello,

Can you please cooperate in upstream issue tracker (comment#2) to resolve this? Need someone without hardened kernel.

Thanks!
Comment 4 eroen 2013-07-02 17:30:39 UTC
Still affects app-crypt/gpgme-1.4.2 . Tests hang after "PASS: t-encrypt".
Comment 5 Alon Bar-Lev gentoo-dev 2013-07-02 17:44:36 UTC
(In reply to eroen from comment #4)
> Still affects app-crypt/gpgme-1.4.2 . Tests hang after "PASS: t-encrypt".

Please work with upstream[1] to resolve this, they are waiting for more info.

[1] https://bugs.g10code.com/gnupg/issue1493
Comment 6 Alon Bar-Lev gentoo-dev 2014-02-16 00:24:01 UTC
Works for me with gpgme-1.4.3, please reopen if fails for you.
Comment 7 Alon Bar-Lev gentoo-dev 2014-02-16 00:25:40 UTC
Fix was actually in gnupg-2.0.21