Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 467058 - dev-libs/libmcrypt-2.5.8-r2 uses obsolete autoconf macro AM_CONFIG_HEADER
Summary: dev-libs/libmcrypt-2.5.8-r2 uses obsolete autoconf macro AM_CONFIG_HEADER
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Crypto team
URL:
Whiteboard:
Keywords:
: 467662 468632 468856 (view as bug list)
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-04-24 08:36 UTC by Tobias Klausmann
Modified: 2013-05-07 21:22 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Klausmann gentoo-dev 2013-04-24 08:36:10 UTC
# emerge libmcrypt
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-libs/libmcrypt-2.5.8-r2
>>> Downloading 'http://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/libmcrypt-2.5.8.tar.gz'
--2013-04-24 10:33:07--  http://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/libmcrypt-2.5.8.tar.gz
Resolving ftp.snt.utwente.nl (ftp.snt.utwente.nl)... 2001:67c:2564:a120::20, 130.89.149.20
Connecting to ftp.snt.utwente.nl (ftp.snt.utwente.nl)|2001:67c:2564:a120::20|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1335178 (1.3M) [application/x-gzip]
Saving to: ‘/usr/portage/distfiles/libmcrypt-2.5.8.tar.gz’

100%[======================================>] 1,335,178   1.74MB/s   in 0.7s   

2013-04-24 10:33:07 (1.74 MB/s) - ‘/usr/portage/distfiles/libmcrypt-2.5.8.tar.gz’ saved [1335178/1335178]

 * libmcrypt-2.5.8.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...           [ ok ]
>>> Unpacking source...
>>> Unpacking libmcrypt-2.5.8.tar.gz to /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/work
>>> Source unpacked in /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/work
>>> Preparing source in /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/work/libmcrypt-2.5.8 ...
 * Applying libmcrypt-2.5.8-rotate-mask.patch ...                        [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/work/libmcrypt-2.5.8' ...
 * Running eautoreconf in '/var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/work/libmcrypt-2.5.8/libltdl' ...
 * Running libtoolize --install --copy --force --automake ...            [ ok ]
 * Running aclocal ...
 * Running libtoolize --copy --force --automake ...                      [ ok ]
 * Running aclocal ...                                                   [ !! ]

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/temp/aclocal-1.out
# cat /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/temp/aclocal-1.out
***** aclocal *****
***** PWD: /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/work/libmcrypt-2.5.8/libltdl
***** aclocal

aclocal-1.13: warning: autoconf input should be named 'configure.ac', not 'configure.in'
acinclude.m4:3740: warning: the serial number must appear before any macro definition
configure.in:25: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...configure.in:25: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1
# emerge --info
Portage 2.1.11.62 (default/linux/amd64/13.0, gcc-4.7.2, glibc-2.17, 3.8.8+ x86_64)
=================================================================
System uname: Linux-3.8.8+-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    32662456 total,   7475528 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Wed, 24 Apr 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=corei7"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=corei7"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.tiscali.nl/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync5.de.gentoo.org/gentoo-portage"
USE="3dnow acl acpi amd64 apache2 bash-completion bcmath berkdb bzip2 calendar caps clamav cli cracklib crypt cscope curl cxx dri ethereal exif fortran ftp gd gdbm gif gmp gnutls gpm iconv idn imagemagick imap imlib ipv6 jabber jpeg kdeenablefinal libwww maildir mbox mmap mmx mng modules mp3 mpeg mpi mudflap multilib mysql mysqli ncurses nls nptl nptlonly ogg oggvorbis openmp pam pcre perl php png posix python readline recode sasl session sockets spell sse sse2 ssl svg tcpd truetype unicode vhosts vim vim-pager vim-syntax vorbis xattr xetex zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias reqtimeout" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="mdraid net" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 is 2013-04-24 14:39:59 UTC
Similar failures occur in media-libs/gd (466996) media-libs/jbig2dec (466998), app-text/ghostscript-gpl and media-libs/libwmf (no bug reports yet) also fail. All with errors about obsolete macros in configure.ac!

I'm reporting this here, since the problems seem related. Sorry if this is the worng place.
Comment 2 Tobias Klausmann gentoo-dev 2013-04-24 15:09:10 UTC
(In reply to comment #1)
> Similar failures occur in media-libs/gd (466996) media-libs/jbig2dec
> (466998), app-text/ghostscript-gpl and media-libs/libwmf (no bug reports
> yet) also fail. All with errors about obsolete macros in configure.ac!
> 
> I'm reporting this here, since the problems seem related. Sorry if this is
> the worng place.

It's the right place in principle, but for new packages, a new bug should be opened and linked to (as blocking) bug 451744. Be sure to check whether it's a known bug, first.
Comment 3 Jason Mours 2013-04-25 19:49:42 UTC
dev-libs/libmcrypt-2.5.8-r2  is failing on my end. Here is my aclocal.out

***** aclocal *****
***** PWD: /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r2/work/libmcrypt-2.5.8
***** aclocal

aclocal-1.13: warning: autoconf input should be named 'configure.ac', not 'configure.in'
configure.in:16: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:16: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

I can also report failed aclocal with app-text/ghostscript-gpl-9.06.
Comment 4 Jason Mours 2013-04-25 20:25:42 UTC
Not sure if this is pertinent; but not recorded in the build logs is emerge failing with an orphaned PID :

/usr/lib64/portage/bin/isolated-functions.sh : line 215: wait: 'Failed Running aclocal !': not a pid or valid job spec

&

/usr/lib64/portage/bin/isolated-functions.sh : line 246: kill: (10632) - No such process
Comment 5 Alon Bar-Lev gentoo-dev 2013-05-04 21:15:46 UTC
Fixed in libmcrypt-2.5.8-r3
Comment 6 Alon Bar-Lev gentoo-dev 2013-05-05 07:10:23 UTC
*** Bug 468632 has been marked as a duplicate of this bug. ***
Comment 7 Ulrich Müller gentoo-dev 2013-05-05 08:25:04 UTC
Not fixed. It still fails for AM_CONFIG_HEADER in libltdl/configure.in:

>>> Preparing source in /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r3/work/libmcrypt-2.5.8 ...
 * Applying libmcrypt-2.5.8-rotate-mask.patch ...                        [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-libs/libmcrypt-2.5.8-r3/work/libmcrypt-2.5.8' ...
 * Running eautoreconf in '/var/tmp/portage/dev-libs/libmcrypt-2.5.8-r3/work/libmcrypt-2.5.8/libltdl' ...
 * Running libtoolize --install --copy --force --automake ...            [ ok ]
 * Running aclocal ...
 * Running libtoolize --copy --force --automake ...                      [ ok ]
 * Running aclocal ...                                                   [ !! ]

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r3/temp/aclocal-1.out


***** aclocal *****
***** PWD: /var/tmp/portage/dev-libs/libmcrypt-2.5.8-r3/work/libmcrypt-2.5.8/libltdl
***** aclocal

aclocal-1.13: warning: autoconf input should be named 'configure.ac', not 'configure.in'
acinclude.m4:3740: warning: the serial number must appear before any macro definition
configure.in:25: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:25: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1
Comment 8 Alon Bar-Lev gentoo-dev 2013-05-05 08:28:25 UTC
(In reply to comment #7)
> Not fixed. It still fails for AM_CONFIG_HEADER in libltdl/configure.in:

Strange... not happening for me... will fix.
Comment 9 Alon Bar-Lev gentoo-dev 2013-05-05 08:33:52 UTC
Thanks!
Comment 10 Ulrich Müller gentoo-dev 2013-05-05 11:24:01 UTC
*** Bug 467662 has been marked as a duplicate of this bug. ***
Comment 11 Alon Bar-Lev gentoo-dev 2013-05-07 21:22:52 UTC
*** Bug 468856 has been marked as a duplicate of this bug. ***