Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 466960 - dev-libs/json-c-0.10-r1 with automake-1.13 - error: 'AM_CONFIG_HEADER': this macro is obsolete
Summary: dev-libs/json-c-0.10-r1 with automake-1.13 - error: 'AM_CONFIG_HEADER': this ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Low normal (vote)
Assignee: Markos Chandras (RETIRED)
Depends on: 464616
Blocks: automake-1.13
  Show dependency tree
Reported: 2013-04-24 01:19 UTC by iGentoo
Modified: 2013-04-30 07:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Possible patch (json-c-0.10-ac_config_headers.patch,549 bytes, patch)
2013-04-24 21:37 UTC, chris salch
Details | Diff
Modified ebuild to load the patch (json-c-0.10-r1.ebuild,1.02 KB, text/plain)
2013-04-24 21:38 UTC, chris salch

Note You need to log in before you can comment on or make changes to this bug.
Description iGentoo 2013-04-24 01:19:19 UTC
>>> Source unpacked in /var/tmp/portage/dev-libs/json-c-0.10-r1/work
>>> Preparing source in /var/tmp/portage/dev-libs/json-c-0.10-r1/work/json-c-0.10 ...
 * Applying json-c-0.10-flags.patch ...
 [ ok ]
 * Applying json-c-0.10-headers.patch ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-libs/json-c-0.10-r1/work/json-c-0.10' ...
 * Running libtoolize --install --copy --force --automake ...
 [ ok ]
 * Running aclocal ...
 [ !! ]

 * Failed Running aclocal !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/dev-libs/json-c-0.10-r1/temp/aclocal.out

# cat /var/tmp/portage/dev-libs/json-c-0.10-r1/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/dev-libs/json-c-0.10-r1/work/json-c-0.10
***** aclocal

aclocal-1.13: warning: autoconf input should be named '', not '' error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from... the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Portage 2.2.0_alpha173 (hardened/linux/amd64/selinux, gcc-4.8.0, glibc-2.17, 3.8.8-pax.x86_64 x86_64)
                         System Settings
System uname: Linux-3.8.8-pax.x86_64-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-gentoo-2.2
KiB Mem:     6114284 total,   1290420 free
KiB Swap:   10484724 total,  10273444 free
Timestamp of tree: Wed, 24 Apr 2013 00:15:01 +0000
ld GNU gold (GNU Binutils 2.23.2) 1.11
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.5.4-r5, 2.6.8-r1, 2.7.4::custom, 3.1.5-r1, 3.2.3-r2, 3.3.0-r1
dev-util/ccache:          3.1.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.12.6, 1.13.1
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.7.2-r1, 4.8.0
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo systemd hardened-dev gnome custom
Installed sets: @local
ACCEPT_KEYWORDS="amd64 x86 ~amd64 ~x86"
CFLAGS="-Wall -Wextra -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-Wall -Wextra -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
FCFLAGS="-Wall -Wextra -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms split-elog split-log splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-Wall -Wextra -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--icf=safe"
MAKEOPTS="V=1 -j10"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/systemd /var/lib/layman/hardened-development /var/lib/layman/gnome /usr/local/portage"
USE="X acl alsa amd64 audit bash-completion berkdb bzip2 c++0x cairo caps cli cracklib crypt custom-cflags cxx dbus dri ffmpeg gdbm gmp gnome gpm gtk gtk3 hardened iconv icu ipv6 jit jpeg jpeg2k justify lzma mmx modules mudflap multilib ncurses nls nptl open_perms opengl openmp orc pam pax_kernel pcre png pulseaudio qt4 readline selinux session sse sse2 ssl svg systemd tcpd threads tiff udev unicode urandom vim-syntax xattr xinetd zlib" ABI_X86="x32 32 64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="btrfs caps dmsquash-live gensplash livenet lvm nfs ssh-client syslog systemd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US zh zh_CN" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="pypy1_9 pypy2_0 python3_1 python3_2 python3_3 python2_5 python2_6 python2_7" QEMU_SOFTMMU_TARGETS="x86_64 arm mips64el ppc64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7-pypy-1.9 2.7-pypy-2.0 3.1 3.2 3.3 2.5 2.6 2.7"

                        Package Settings

dev-libs/json-c-0.10-r1 was built with the following:
USE="-doc -static-libs"
Comment 1 chris salch 2013-04-24 21:37:08 UTC
Created attachment 346538 [details, diff]
Possible patch

This appears to have fixed the build for me.
Comment 2 chris salch 2013-04-24 21:38:57 UTC
Created attachment 346540 [details]
Modified ebuild to load the patch
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2013-04-25 19:00:24 UTC
(In reply to comment #1)
> Created attachment 346538 [details, diff] [details, diff]
> Possible patch
> This appears to have fixed the build for me.

upstream fixed it differently
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2013-04-25 19:47:05 UTC
+*json-c-0.11 (25 Apr 2013)
+  25 Apr 2013; Markos Chandras <> +json-c-0.11.ebuild:
+  Version bump. Fixes #464616 and #466960
Comment 5 Kamen Dokov 2013-04-29 06:12:41 UTC
Today the downgrade from dev-libs/json-c-0.11 to to dev-libs/json-c-0.10-r1 led to same error!
Are you going to reopen this bug?
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2013-04-29 08:17:11 UTC
(In reply to comment #5)
> Today the downgrade from dev-libs/json-c-0.11 to to dev-libs/json-c-0.10-r1
> led to same error!
> Are you going to reopen this bug?

i really see no reason to backport this patch to the old version. but anyway i might do it
Comment 7 Uros 2013-04-29 12:22:34 UTC
(In reply to comment #6)
> i really see no reason to backport this patch to the old version. but anyway
> i might do it

Well, at least updated virtualbox-bin ebuild(s) rdepend on <dev-libs/json-c-0.11, so it might be wise to patch old version(s) as well.
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2013-04-29 12:24:32 UTC
correct, this is the only ebuild that needs an old json-c.
Comment 9 Markos Chandras (RETIRED) gentoo-dev 2013-04-29 18:51:08 UTC
+  29 Apr 2013; Markos Chandras <>
+  +files/json-c-0.10-automake-1.13.patch, json-c-0.10-r1.ebuild:
+  Backport upstream patch for automake-1.13 to json-c-0.10. Bug #466960
Comment 10 Uros 2013-04-30 07:35:58 UTC
Thank you.