Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 466794 - x11-libs/gtk+-3.8.1 - segmentation fault in gtk_builder_connect_signals_full in multiple apps
Summary: x11-libs/gtk+-3.8.1 - segmentation fault in gtk_builder_connect_signals_full ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Blocks: gnome-3.8
  Show dependency tree
Reported: 2013-04-22 12:32 UTC by Martin Kletzander
Modified: 2013-06-30 13:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Output of emerge --info (emerge-info.txt,16.52 KB, text/plain)
2013-04-22 12:32 UTC, Martin Kletzander
virt-manager backtrace (virt-manager-bt.txt,81.02 KB, text/plain)
2013-04-22 12:33 UTC, Martin Kletzander
virt-manager python backtrace (virt-manager-py-bt.txt,8.82 KB, text/plain)
2013-04-22 12:33 UTC, Martin Kletzander
d-feet-0.3.3 backtrace (d-feet-bt.txt,53.80 KB, text/plain)
2013-04-22 12:41 UTC, Martin Kletzander
d-feet-0.3.3 python backtrace (d-feet-py-bt.txt,3.27 KB, text/plain)
2013-04-22 12:41 UTC, Martin Kletzander

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Kletzander 2013-04-22 12:32:20 UTC
Created attachment 346276 [details]
Output of emerge --info

When running some gtk3 applications, it ends with segmentation fault in gtk_builder_connect_signals_full when trying to call unknown function (probably).

Applications that end with segfault:
d-feet (versions 0.3.1 and 0.3.3, version 0.1.15 doesn't fail)
virt-manager (current HEAD of git repo, which uses gtk3)

Versions of some related packages (I reproduced this bug with numerous other versions, also with stable ones, but these are the last ones i emerged):

Additional info:
I tried running python-updater, stable versions, various version combinations allowed by portage and the ebuilds, but the segfault is still waiting somewhere in there, haunting me.
Comment 1 Martin Kletzander 2013-04-22 12:33:01 UTC
Created attachment 346278 [details]
virt-manager backtrace
Comment 2 Martin Kletzander 2013-04-22 12:33:18 UTC
Created attachment 346280 [details]
virt-manager python backtrace
Comment 3 Martin Kletzander 2013-04-22 12:41:18 UTC
Created attachment 346284 [details]
d-feet-0.3.3 backtrace
Comment 4 Martin Kletzander 2013-04-22 12:41:44 UTC
Created attachment 346286 [details]
d-feet-0.3.3 python backtrace
Comment 5 Pacho Ramos gentoo-dev 2013-04-23 17:01:31 UTC
Please report this (and traces) to upstream and post the link here ->

Comment 6 Martin Kletzander 2013-04-23 17:23:35 UTC
Done as requested:
Comment 7 Pacho Ramos gentoo-dev 2013-04-23 18:54:45 UTC
Lets see what upstream thinks, thanks
Comment 8 Tolga Dalman 2013-05-02 15:12:09 UTC
I can't reproduce - gtk3 is running fine here. d-feet shows no problems.

Portage (default/linux/amd64/13.0, gcc-4.8.0, glibc-2.17, 3.8.9 x86_64)
System uname: Linux-3.8.9-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16421012 total,   6618376 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Thu, 02 May 2013 15:00:01 +0000
ld GNU gold (GNU Binutils 2.23.2) 1.11
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.4, 3.2.4
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.7.2-r1, 4.8.0
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -mtune=native -O2 -flto=8 -momit-leaf-frame-pointer -pipe -w         -fgcse-las -fgcse-after-reload -freorder-blocks-and-partition         -floop-block -floop-interchange -floop-strip-mine -ftree-vectorize         -ftree-slp-vectorize -fvect-cost-model -fpredictive-commoning         "
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -flto=8 -momit-leaf-frame-pointer -pipe -w         -fgcse-las -fgcse-after-reload -freorder-blocks-and-partition         -floop-block -floop-interchange -floop-strip-mine -ftree-vectorize         -ftree-slp-vectorize -fvect-cost-model -fpredictive-commoning         "
EMERGE_DEFAULT_OPTS="--quiet-build=n --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--hash-style=both -Wl,--as-needed -flto=8"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl alsa amd64 bash-completion berkdb bluetooth bzip2 cli cracklib crypt cxx dbus dri fortran gdbm gmp gnome gnome-keyring gpm iconv introspection ipv6 libffi libnotify mmx modules mudflap multilib ncurses nptl openmp pam pcre pdf policykit pulseaudio readline session sse sse2 ssl tcpd truetype udev unicode vim-syntax xattr xcb zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport harness ide java nb websvccommon enterprise profiler webcommon" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 9 Martin Kletzander 2013-05-07 17:28:59 UTC
(In reply to comment #8)
> I can't reproduce - gtk3 is running fine here. d-feet shows no problems.

What's your version of *gobject* packages?  I can try to match your system as much as possible wrt to the packages installed and hope it'll be fixed.  I have really no idea where to look next.  Upstream suggested it might be a pygobject binding problem, so that's why I'm asking.  Thanks for any info.
Comment 10 Mads 2013-05-07 19:53:45 UTC
Sorry for coming with fleecy input, but I had issues with firefox recently on my ~amd64 userland. I found out that if I compiled gtk+ >=3.6.3 (tried that and 3.8.1), glib >=2.36.0 (tried that and -9999 two days ago) and firefox 20 with gcc-4.8.0, I would get random segmentation faults with corrupted stack traces pointing fingers at and The segmentation faults came if I ever visited some javascript heavy sites, or sites with a lot of ads.

All these troubles disappeared if I compiled gtk+, glib and firefox with gcc 4.7.2-r1...
Comment 11 Martin Kletzander 2013-05-08 16:54:14 UTC
(In reply to comment #10)
> All these troubles disappeared if I compiled gtk+, glib and firefox with gcc
> 4.7.2-r1...

That's likely irrelevant as, according to my logs, gcc-4.7.2-r1 is my only gcc and active compiler since March 3rd.

Just out of curiosity (and thanks to the fact that I have no idea where to continue my search), I tried recompiling whole toolchain and all relevant libraries with 4.8.0 and nothing has changed.
Comment 12 Martin Kletzander 2013-05-09 11:48:19 UTC
I also tried to see whether the hardened gcc settings have any effect on this and whether the toolchain and all libraries were compiled with vanilla gcc or not, it had no effect on the issue.
Comment 13 Martin Kletzander 2013-05-21 15:41:39 UTC
I did a full clean install in a guest and it runs OK.  I can't match the versions on my machine, but I'll try to upgrade the guest and see what got updated and when it started doing this.
Comment 14 Martin Kletzander 2013-06-11 08:15:29 UTC
I managed to fix this problem with recompilation of all the programs in newest versions with new gcc etc.  I'm not sure how to close this BZ, so feel free to resolve it with any resolution that suits your needs.  Sorry for wasting your time.
Comment 15 Tolga Dalman 2013-06-30 12:47:16 UTC