Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 466628 - sci-geosciences/grass-6.4.2 - error: declaration of ‘void* operator new [](size_t)’ has a different exception specifier
Summary: sci-geosciences/grass-6.4.2 - error: declaration of ‘void* oper...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sam Jorna (wraeth)
Depends on:
Reported: 2013-04-21 09:23 UTC by Juergen Rose
Modified: 2015-10-19 11:23 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

bzip2ed /var/tmp/portage/sci-geosciences/grass-6.4.2/temp/build.log (build.log.bz2,121.39 KB, application/x-bzip2)
2013-04-21 09:26 UTC, Juergen Rose
Debian's backported patch (untested) (iostream_cpp470,3.15 KB, patch)
2013-05-05 19:37 UTC, Victor Mataré
Details | Diff
grass-6.4.2.ebuild which uses the patch (grass-6.4.2.ebuild,7.43 KB, text/plain)
2013-05-28 07:21 UTC, Juergen Rose
grass-7.0.0.ebuild (grass-7.0.0.ebuild,7.21 KB, text/plain)
2015-03-07 17:32 UTC, Juergen Rose

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2013-04-21 09:23:45 UTC
'emerge -uvDN grass' fails with:
cp -f /var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/bin.x86_64-pc-linux-gnu/grass64 /var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/grass64.tmp
/usr/bin/install -c  tools/ /var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/tools/ 2>/dev/null
/usr/bin/install -c  tools/g.html2man/g.html2man /var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/tools/g.html2man/ 2>/dev/null
Generating HTML manual pages index (help system)...
Generated HTML docs in ../dist.x86_64-pc-linux-gnu/docs/html/index.html
Following modules are missing the 'description.html' file in src code:
GRASS GIS compilation log
Started compilation: Sun Apr 21 10:48:06 CEST 2013
Errors in:

Reproducible: Always

root@lynx2:/root(29)# emerge --info '=sci-geosciences/grass-6.4.2'
Portage (default/linux/amd64/13.0/desktop, gcc-4.7.2, glibc-2.17, 3.8.8-gentoo x86_64)
                        System Settings
System uname: Linux-3.8.8-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7500_@_2.20GHz-with-gentoo-2.2
KiB Mem:     3972832 total,    745128 free
KiB Swap:    8008364 total,   8008364 free
Timestamp of tree: Sun, 21 Apr 2013 06:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo sunrise science sabayon x-portage x-cpan x-g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype- googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-march=native -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/science /var/lib/layman/sabayon /usr/local/portage /var/lib/cpan /var/lib/g-octave"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive armadillo arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fts3 fuse g3dvl garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jabber jadetex java jbig john jpeg jpeg2k kate kde kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack laptop latex lcms ldap lensfun libffi libkms libnotify libsamplerate lirc live lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pae pam pango pcre pda pdf perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rhythmbox rle romio rpc rrdcgi rrdtool samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 ssl ssse3 startup-notification stlport subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus thinkpad threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb userlocales utempter v4l vaapi vala vdpau video virt-network virtualbox visio vorbis vpx wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ABI_X86="64" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DVB_CARDS="usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

sci-geosciences/grass-6.4.2 was built with the following:
USE="X cairo cxx ffmpeg fftw jpeg (multilib) mysql nls odbc opengl png postgres python readline sqlite tiff truetype wxwidgets -debug -gmath -motif" ABI_X86="64"

root@lynx2:/root(30)# emerge -pqv '=sci-geosciences/grass-6.4.2'
[ebuild   R   ] sci-geosciences/grass-6.4.2  USE="X cairo cxx ffmpeg fftw jpeg mysql nls odbc opengl png postgres python readline sqlite tiff truetype wxwidgets -debug -gmath -motif"
Comment 1 Juergen Rose 2013-04-21 09:26:31 UTC
Created attachment 346162 [details]
bzip2ed /var/tmp/portage/sci-geosciences/grass-6.4.2/temp/build.log
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2013-04-24 15:45:38 UTC
It fails a lot earlier than that, it seems.
Comment 3 Juergen Rose 2013-05-01 17:41:41 UTC
Any news, how to fix?
Comment 4 Victor Mataré 2013-05-05 19:29:09 UTC
This is the actual error (the first one):

/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/lib/iostream # make
make OBJ.x86_64-pc-linux-gnu
make[1]: Entering directory `/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/lib/iostream'
make[1]: `OBJ.x86_64-pc-linux-gnu' is up to date.
make[1]: Leaving directory `/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/lib/iostream'
c++ -I/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/include  -O2 -pipe -march=core2 -msse4.1 -mssse3 -msse3 -msse2 -msse -mmmx   -D_FILE_OFFSET_BITS=64   -DPACKAGE=\""grasslibs"\"  -I/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/include -o OBJ.x86_64-pc-linux-gnu/mm.o -c In function 'void* operator new [](size_t)': error: declaration of 'void* operator new [](size_t)' has a different exception specifier
In file included from
/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/include/grass/iostream/mm.h:114:17: error: from previous declaration 'void* operator new [](std::size_t) throw (std::bad_alloc)' In function 'void* operator new(size_t)': error: declaration of 'void* operator new(size_t)' has a different exception specifier
In file included from
/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/include/grass/iostream/mm.h:113:17: error: from previous declaration 'void* operator new(std::size_t) throw (std::bad_alloc)' In function 'void operator delete(void*)': error: declaration of 'void operator delete(void*)' has a different exception specifier
In file included from
/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/include/grass/iostream/mm.h:115:15: error: from previous declaration 'void operator delete(void*) throw ()' In function 'void operator delete [](void*)': error: declaration of 'void operator delete [](void*)' has a different exception specifier
In file included from
/var/tmp/portage/sci-geosciences/grass-6.4.2/work/grass-6.4.2/dist.x86_64-pc-linux-gnu/include/grass/iostream/mm.h:116:15: error: from previous declaration 'void operator delete [](void*) throw ()'
make: *** [OBJ.x86_64-pc-linux-gnu/mm.o] Error 1

Upstream bug:
Although I find the bugreport somewhat confusing since it seems to claim that the fix has been backported to 6.4.2, which is obviously not the case (cf.
Comment 5 Victor Mataré 2013-05-05 19:37:39 UTC
Created attachment 347462 [details, diff]
Debian's backported patch (untested)
Comment 6 Victor Mataré 2013-05-05 23:08:36 UTC
Okay, just compiled successfully after manually injecting the attached patch into the unpacked source tree. Seems the second build error was just a consequence of the first.
Comment 7 Victor Mataré 2013-05-05 23:16:20 UTC
...however on qmerge I get collisions:

 * Detected file collision(s):
 *      /usr/share/man/man1/display.1.bz2
 *      /usr/share/man/man1/index.1.bz2
 * Searching all installed packages for file collisions...
 * Press Ctrl-C to Stop
 * media-gfx/imagemagick-
 *      /usr/share/man/man1/display.1.bz2
 * media-libs/netpbm-10.61.00:0::gentoo
 *      /usr/share/man/man1/index.1.bz2

Not sure how to deal with those in an orderly fashion.
Comment 8 Juergen Rose 2013-05-28 07:20:36 UTC
The patch worked for me with the attached ebuild.
Comment 9 Juergen Rose 2013-05-28 07:21:35 UTC
Created attachment 349420 [details]
grass-6.4.2.ebuild which uses the patch
Comment 10 Juergen Rose 2013-07-21 10:57:17 UTC
I just hit the issue at the next system. Is there any reason that the patch is not transfered to the main portage tree?
Comment 11 Juergen Rose 2013-07-22 14:15:49 UTC
BTW., at all my systems I find now a /usr/portage/sci-geosciences/grass/grass-6.4.2.ebuild, which is from Jul 4th, which has again theo old iostream problem.
Comment 12 Martin von Gagern 2013-07-30 07:00:51 UTC
(In reply to Victor Mataré from comment #5)
> Created attachment 347462 [details, diff]: Debian's backported patch (untested)

Dropping that into /etc/portage/patches/sci-geosciences/grass-6.4.2/ to be picked up by epatch_user did the trick. Thanks a lot!
Comment 13 Kalin KOZHUHAROV 2013-10-07 09:55:45 UTC
(In reply to Martin von Gagern from comment #12)
> (In reply to Victor Mataré from comment #5)
> > Created attachment 347462 [details, diff] [details, diff]: Debian's backported patch (untested)
> Dropping that into /etc/portage/patches/sci-geosciences/grass-6.4.2/ to be
> picked up by epatch_user did the trick. Thanks a lot!

Yep that worked for me too!
Comment 14 Egor Y. Egorov 2014-01-09 02:25:51 UTC
Patch works for me. Thanks!
Comment 15 Juergen Rose 2014-12-31 14:36:30 UTC
I hit the error again. There is a new grass-6.4.2.ebuild in the tree. This new ebuild takes the new postgresql (without -base) into account. But the  iostream patch is again not included.
Comment 16 cmuelle8 2015-01-06 20:03:44 UTC
(In reply to Juergen Rose from comment #15)
> I hit the error again. There is a new grass-6.4.2.ebuild in the tree. This
> new ebuild takes the new postgresql (without -base) into account. But the 
> iostream patch is again not included.

Fun isn't it?  Neither are 6.4.3 nor 6.4.4 ebuilds, although former ones have been available in this tracker for long..  I tried to link to all relevant version bump requests in #466388 for reference.
Comment 17 Juergen Rose 2015-03-07 17:31:30 UTC
grass-7.0.0 is out and it can emerged with the attached ebuild.
Comment 18 Juergen Rose 2015-03-07 17:32:04 UTC
Created attachment 398314 [details]
Comment 19 Sam Jorna (wraeth) gentoo-dev 2015-10-19 11:23:39 UTC
Closing as OBSOLETE - sci-geosciences/grass-7.0.1 has been added to the tree as per bug 514514 and subsequently revbumped. Note that sci-geosciences/grass:6 has been masked and will be removed from the tree in the coming weeks.