Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 466176 - <sys-libs/glibc-2.25-r10[systemtap] is missing dependency on dev-util/systemtap
Summary: <sys-libs/glibc-2.25-r10[systemtap] is missing dependency on dev-util/systemtap
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor with 1 vote (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 468956 (view as bug list)
Depends on: 647062
Blocks:
  Show dependency tree
 
Reported: 2013-04-16 23:56 UTC by Naohiro Aota
Modified: 2018-04-21 21:29 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.22 KB, text/plain)
2013-04-19 06:44 UTC, Naohiro Aota
Details
config.log (config.log,18.85 KB, text/plain)
2013-04-19 06:44 UTC, Naohiro Aota
Details
/var/log/portage/cross-armv6j-hardfloat-linux-gnueabi-info.log (cross-armv6j-hardfloat-linux-gnueabi-info.log,38.43 KB, text/plain)
2014-03-03 07:11 UTC, Jesse Adelman
Details
/var/log/portage/cross-armv6j-hardfloat-linux-gnueabi-glibc.log.xz (cross-armv6j-hardfloat-linux-gnueabi-glibc.log.xz,2.58 KB, application/x-xz)
2014-03-03 07:11 UTC, Jesse Adelman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Naohiro Aota gentoo-dev 2013-04-16 23:56:51 UTC
Without systemtap installed, USE=systemtap emerge -1 glibc failed with:

checking for systemtap static probe support... no
configure: error: in `/dev/shm/portage/sys-libs/glibc-2.17/work/build-x86-x86_64-pc-linux-gnu-nptl':
configure: error: systemtap support needs sys/sdt.h with asm support
See `config.log' for more details
 * ERROR: sys-libs/glibc-2.17 failed (compile phase):
 *   failed to configure glibc

/usr/include/sys/sdt.h is provided from dev-util/systemtap.
Comment 1 Jeroen Roovers gentoo-dev 2013-04-18 11:46:22 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log to this bug report.
3) Please attach the relevant config.log to this bug report.
Comment 2 Naohiro Aota gentoo-dev 2013-04-19 06:34:14 UTC
Portage 2.1.11.62 (default/linux/amd64/13.0, gcc-4.6.3, glibc-2.17, 3.8.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.8.0-gentoo-x86_64-Intel-R-_Core-TM-_i5-3317U_CPU_@_1.70GHz-with-gentoo-2.2
KiB Mem:     3884132 total,    196436 free
KiB Swap:    5000188 total,   3583744 free
Timestamp of tree: Sat, 13 Apr 2013 22:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.3-r2, 4.6.3, 4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x-gentoo-x86 gentoo-haskell sunrise betagarden neurogeek
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA EULA skype-eula Broadcom PUEL AdobeFlash-10.1 dlj-1.1 Oracle-BCLA-JavaSE google-chrome AdobeFlash-10.3 skype-4.0.0.7-copyright google-talkplugin AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer -march=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mavx -msse4.2 -msse4.1 -mrdrnd -mf16c -mfsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=generic -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer -march=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mavx -msse4.2 -msse4.1 -mrdrnd -mf16c -mfsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=generic -frecord-gcc-switches"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe -fomit-frame-pointer -march=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mavx -msse4.2 -msse4.1 -mrdrnd -mf16c -mfsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=generic -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms sign strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe -fomit-frame-pointer -march=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mavx -msse4.2 -msse4.1 -mrdrnd -mf16c -mfsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=generic -frecord-gcc-switches"
GENTOO_MIRRORS="http://gentoo.channelx.biz/ http://gentoo.gg3.net/ http://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3 -l6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/naota/gentoo-x86 /var/lib/layman/haskell /var/lib/layman/sunrise /var/lib/layman/betagarden /var/lib/layman/neurogeek"
SYNC="rsync://rsync.jp.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 avahi bash-completion berkdb bluetooth bzip2 cdda cjk cli cracklib crypt cxx dbus dga dri emacs fbcon fortran gdbm gpm gtk3 hddtemp iconv infinality ipv6 llvm m17n-lib midi mmx modules mudflap multilib ncurses nls nptl nsplugin openmp pam pcre perl policykit pulseaudio python qt3support readline session sse sse2 sse3 ssl ssse3 systemtap tcpd threads tiff unicode use_ruby_ruby18 v4l v4l2 vaapi vdpau wifi xattr xcomposite xft xinerama zlib zsh-completion" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="btrfs syslog ssh" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="mouse keyboard evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ja" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="vesa intel i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================
USE="(multilib) -debug -gd (-hardened) -nscd -profile (-selinux) -suid -systemtap -vanilla" ABI_X86="64"

sys-libs/glibc-2.17 was built with the following:
CFLAGS="-pipe -march=corei7-avx -mno-movbe -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mtune=generic -O2 -fno-strict-aliasing"
CXXFLAGS="-pipe -march=corei7-avx -mno-movbe -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mtune=generic -O2 -fno-strict-aliasing"
Comment 3 Naohiro Aota gentoo-dev 2013-04-19 06:44:21 UTC
Created attachment 345978 [details]
build.log
Comment 4 Naohiro Aota gentoo-dev 2013-04-19 06:44:45 UTC
Created attachment 345980 [details]
config.log
Comment 5 SpanKY gentoo-dev 2013-04-19 20:14:39 UTC
no idea what that header is.  maybe dev-util/systemtap installs it ?
Comment 6 Naohiro Aota gentoo-dev 2013-04-20 04:10:03 UTC
(In reply to comment #5)
> no idea what that header is.  maybe dev-util/systemtap installs it ?

As I wrote in comment 0, /usr/include/sys/sdt.h is provided from dev-util/systemtap.
Comment 7 SpanKY gentoo-dev 2013-04-23 01:42:21 UTC
i won't add the dependency until dev-util/systemtap is stable on all the relevant architectures.  it's not really that big of a deal as anyone who is serious about using systemtap is going to `emerge systemtap` on their system first.
Comment 8 Jesse Adelman 2014-03-03 07:11:11 UTC
Created attachment 371620 [details]
/var/log/portage/cross-armv6j-hardfloat-linux-gnueabi-info.log
Comment 9 Jesse Adelman 2014-03-03 07:11:36 UTC
Created attachment 371622 [details]
/var/log/portage/cross-armv6j-hardfloat-linux-gnueabi-glibc.log.xz
Comment 10 Jesse Adelman 2014-03-03 07:14:42 UTC
Howdy. This seems to break crossdev's bootstrapping, at least with arm.

crossdev -v -t armv6j-hardfloat-linux-gnueabi

and

crossdev -S -v -t armv6j-hardfloat-linux-gnueabi

produce the same error'd result.

Let me know if more info is needed. Thanks.
Comment 11 Jesse Adelman 2014-03-04 06:32:00 UTC
Hrm. I just realized I'm the only one subscribed to this bug. Should I have created a new bug instead of appending to this one? :/
Comment 12 Andreas K. Hüttel gentoo-dev 2017-08-23 20:46:05 UTC
(In reply to SpanKY from comment #7)
> i won't add the dependency until dev-util/systemtap is stable on all the
> relevant architectures.  it's not really that big of a deal as anyone who is
> serious about using systemtap is going to `emerge systemtap` on their system
> first.

This is doable now, since systemtap is stable on all arches except hppa. 
(And on hppa we can package.use.mask the use flag for glibc.)
Comment 13 Andreas K. Hüttel gentoo-dev 2017-09-11 10:21:00 UTC
(In reply to Andreas K. Hüttel from comment #12)
> (In reply to SpanKY from comment #7)
> > i won't add the dependency until dev-util/systemtap is stable on all the
> > relevant architectures.  it's not really that big of a deal as anyone who is
> > serious about using systemtap is going to `emerge systemtap` on their system
> > first.
> 
> This is doable now, since systemtap is stable on all arches except hppa. 
> (And on hppa we can package.use.mask the use flag for glibc.)

Added in 2.26-r1 (and later)
Comment 14 Larry the Git Cow gentoo-dev 2017-11-12 14:16:28 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=02056778ea5961e77a59a7a246b355c1225c7404

commit 02056778ea5961e77a59a7a246b355c1225c7404
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2017-11-12 12:28:38 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2017-11-12 14:15:28 +0000

    sys-libs/glibc: Re-add keywords to glibc 2.26
    
    Bug: https://bugs.gentoo.org/492814
    Bug: https://bugs.gentoo.org/622694
    Bug: https://bugs.gentoo.org/617938
    Bug: https://bugs.gentoo.org/466176
    Bug: https://bugs.gentoo.org/628768
    Bug: https://bugs.gentoo.org/637016
    Bug: https://bugs.gentoo.org/636934
    Bug: https://bugs.gentoo.org/381391
    Bug: https://bugs.gentoo.org/636158
    Package-Manager: Portage-2.3.13, Repoman-2.3.4

 sys-libs/glibc/glibc-2.26-r3.ebuild | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)}
Comment 15 Jeroen Roovers gentoo-dev 2017-12-16 12:50:24 UTC
*** Bug 468956 has been marked as a duplicate of this bug. ***
Comment 16 Jeroen Roovers gentoo-dev 2017-12-16 12:53:14 UTC
(In reply to Andreas K. Hüttel from comment #12)
> (And on hppa we can package.use.mask the use flag for glibc.)

/usr/src/linux/Documentation/features/debug/kprobes/arch-support.txt
Comment 17 Andreas K. Hüttel gentoo-dev 2018-01-17 23:07:12 UTC
Also fixed in 2.25-r10
Comment 18 Andreas K. Hüttel gentoo-dev 2018-04-21 21:29:48 UTC
(In reply to Andreas K. Hüttel from comment #17)
> Also fixed in 2.25-r10

Is now stable everywhere