Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 465638 - upgrade of media-libs/libpng-1.5:0 to libpng-1.6:0 blocked by libpng-1.5:1.5 being pulled in as well
Summary: upgrade of media-libs/libpng-1.5:0 to libpng-1.6:0 blocked by libpng-1.5:1.5 ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 465356 (view as bug list)
Depends on:
Blocks: 300071 462382
  Show dependency tree
 
Reported: 2013-04-12 08:21 UTC by Cédric Jeanneret
Modified: 2013-04-15 06:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Jeanneret 2013-04-12 08:21:13 UTC
Hello,

emerge -aNuD @world @system
----8<----
[ebuild     U ] media-libs/libpng-1.6.1 [1.5.15] USE="apng (-neon) -static-libs" 
[ebuild  NS   ] media-libs/libpng-1.5.15-r15 [1.2.50, 1.5.15] USE="apng (-neon)" 
----8<----
[blocks B     ] =media-libs/libpng-1.5*:0 ("=media-libs/libpng-1.5*:0" is blocking media-libs/libpng-1.5.15-r15)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (x11-misc/slim-1.3.5-r2::gentoo, installed)

  (media-libs/libpng-1.6.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


Reproducible: Always

Steps to Reproduce:
1. install slim
2. try to update libpng

Actual Results:  
portage doesn't like it and refuse to proceed, I have to run this command in order to get my updates:
emerge -aNuD --exclude media-libs/libpng  @world @system

Expected Results:  
should accept to update libpng-1.5.15 to libpng-1.5.15-r15

Most probably caused by RDEPEND in slim-1.3.5-r2.ebuild :

RDEPEND="x11-libs/libXmu
	x11-libs/libX11
	x11-libs/libXpm
	x11-libs/libXft
---->	media-libs/libpng:0=
	virtual/jpeg
	x11-apps/sessreg
	consolekit? ( sys-auth/consolekit
		sys-apps/dbus )
	pam? ( virtual/pam )"
Comment 1 Julian Ospald 2013-04-12 14:31:27 UTC
install libpng-1.6 with "--nodeps" first, then the blocker will go away

seems like portage can't handle this situation, although there is no logical reason for the blocker
Comment 2 Zac Medico gentoo-dev 2013-04-12 14:37:25 UTC
This is the same issue that was reported in bug 465356, comment #15. It's fixed in 2.1.11.61 and 2.2.0_alpha172 by this commit:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=62dbcaa4d873784f1082c184668fcdc34392925b
Comment 3 Zac Medico gentoo-dev 2013-04-12 14:38:51 UTC
*** Bug 465356 has been marked as a duplicate of this bug. ***
Comment 4 Zac Medico gentoo-dev 2013-04-12 14:47:01 UTC
(In reply to comment #1)
> install libpng-1.6 with "--nodeps" first, then the blocker will go away
> 
> seems like portage can't handle this situation, although there is no logical
> reason for the blocker

Please don't use --nodeps. Just use `emerge -1 portage` to update portage to at least 2.1.11.61 or 2.2.0_alpha172, and it will solve the blockers automatically.
Comment 5 Cédric Jeanneret 2013-04-15 06:04:28 UTC
I confirm portage-2.1.11.62 solves this issue - thank you!