Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 465356 - sys-apps/portage: Improve dependency resolution (was: =media-libs/libpng-1.5.15/1.6.1 - Block between both versions in `emerge -uvND world`)
Summary: sys-apps/portage: Improve dependency resolution (was: =media-libs/libpng-1.5....
Status: RESOLVED DUPLICATE of bug 465638
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-10 07:15 UTC by Juergen Rose
Modified: 2013-04-12 14:38 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge -auDNV --debug world output (emerge-465356-debug.txt.gz,515.58 KB, application/octet-stream)
2013-04-11 15:31 UTC, Paul Varner (RETIRED)
Details
vdb.tar.xz (vdb.tar.xz,904.84 KB, application/octet-stream)
2013-04-11 21:53 UTC, Paul Varner (RETIRED)
Details
world file (world,1.97 KB, text/plain)
2013-04-11 22:21 UTC, Paul Varner (RETIRED)
Details
/etc/portage (etc-portage.tar.xz,18.82 KB, application/octet-stream)
2013-04-11 22:28 UTC, Paul Varner (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2013-04-10 07:15:36 UTC
'emerge -uvND world' fails with:

root@caiman:/root(13)# emerge -uvND world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] media-libs/libpng-1.5.15:0/0 [1.6.1:0/16] USE="apng (-neon) -static-libs" 0 kB
[ebuild     U  ] app-misc/pax-utils-0.7 [0.5] USE="python%* -caps" 89 kB
[ebuild     UD ] dev-lisp/sbcl-1.0.55-r1::gentoo [1.0.58::lisp] USE="asdf doc threads unicode -debug -ldb -pax_kernel% -source (-cobalt%)" 0 kB
[ebuild     U  ] net-fs/autofs-5.0.7 [5.0.6-r5] USE="ldap sasl -hesiod -mount-locking%" 0 kB
[ebuild     U  ] sci-libs/mathgl-2.1.2 [2.0.3] USE="doc fltk gif gsl hdf hdf5 jpeg mpi opengl pdf png python qt4 threads wxwidgets zlib -glut (-octave) -static-libs (-double-precision%)" LINGUAS="ru" 0 kB
[ebuild     U  ] dev-python/traits-4.3.0 [4.2.0] USE="doc examples {-test}" 0 kB
[ebuild     U  ] sci-libs/netcdf-4.2.1.1::gentoo [4.1.3::x-portage] USE="dap* doc examples%* hdf%* hdf5 mpi%* szip%* tools%* -static-libs {-test%} (-cxx%*) (-fortran%*)" 4,411 kB
[ebuild  N     ] sci-libs/netcdf-cxx-4.2-r1  USE="examples -static-libs" 386 kB
[ebuild   R    ] sci-mathematics/wxmaxima-12.09.0  USE="(-unicode%*)" 0 kB

Total: 9 packages (5 upgrades, 2 downgrades, 1 new, 1 reinstall), Size of downloads: 4,884 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.6.1::gentoo, installed) pulled in by
    >=media-libs/libpng-1.4:0/16= required by (x11-libs/gdk-pixbuf-2.26.5::gentoo, installed)
    media-libs/libpng:0/16= required by (media-video/mjpegtools-2.0.1_rc1-r1::gentoo, installed)
    (and 1 more with the same problems)

  (media-libs/libpng-1.5.15::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.2::gentoo, installed)
    media-libs/libpng:0/0= required by (dev-lang/php-5.5.0_beta2-r4::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/gthumb-3.0.2::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (net-libs/webkit-gtk-1.10.2-r300::gentoo, installed)
    media-libs/libpng:0/0= required by (media-gfx/digikam-3.1.0::gentoo, installed)

app-misc/pax-utils:0

  (app-misc/pax-utils-0.5::gentoo, installed) pulled in by
    <app-misc/pax-utils-0.6 required by (sys-kernel/genkernel-3.4.45::gentoo, installed)

  (app-misc/pax-utils-0.7::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sci-libs/netcdf:0

  (sci-libs/netcdf-4.1.3::x-portage, installed) pulled in by
    ~sci-libs/netcdf-4.1.3[cxx,hdf5] required by (sci-visualization/paraview-3.98.0::gentoo, installed)

  (sci-libs/netcdf-4.2.1.1::gentoo, ebuild scheduled for merge) pulled in by
    >=sci-libs/netcdf-4.2 required by (sci-libs/netcdf-cxx-4.2-r1::gentoo, ebuild scheduled for merge)



Reproducible: Always




root@caiman:/root(14)# emerge --info
Portage 2.1.11.60 (default/linux/amd64/13.0, gcc-4.7.2, glibc-2.17, 3.8.6-gentoo x86_64)
=================================================================
System uname: Linux-3.8.6-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.2
KiB Mem:    16178868 total,  11317268 free
KiB Swap:  100663280 total, 100663280 free
Timestamp of tree: Wed, 10 Apr 2013 06:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x11 science sunrise sabayon x-portage x-cpan x-g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/sabayon /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive armadillo arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fts3 fuse g3dvl gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack latex lcms ldap lensfun libffi libkms libnotify libsamplerate live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking networkmanager nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pam pcre pda pdf perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rhythmbox rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 sse4a ssl stlport subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus threads thunderbird tidy tiff tk toolbar tools truetype udev udisks unicode usb userlocales utempter v4l vaapi vala vdpau video virt-network virtualbox visio vorbis vpx wav webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Samuli Suominen gentoo-dev 2013-04-10 07:33:59 UTC
(In reply to comment #0)
> [ebuild     UD ] media-libs/libpng-1.5.15:0/0 [1.6.1:0/16] USE="apng (-neon)
> -static-libs" 0 kB

Why are you trying to downgrade libpng? There is no conflict if properly keyworded:

$ sudo emerge -pv libpng:0 libpng:1.5 libpng:1.2

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  NS    ] media-libs/libpng-1.2.50:1.2 [1.5.15-r15:1.5, 1.6.1:0/16] 527 kB
[ebuild   R    ] media-libs/libpng-1.5.15-r15:1.5  USE="apng (-neon)" 0 kB
[ebuild   R    ] media-libs/libpng-1.6.1:0/16  USE="apng (-neon) -static-libs" 0 kB
Comment 2 Patrick Holthaus 2013-04-10 08:07:11 UTC
Seems libpng-1.5 moved slot from :0 to :1.5
emerge -aC libpng:0 helped for me, removing libpng-1.5.15 (and only this version) from my system. A world upgrade pulled it back into the new slot.
Comment 3 Samuli Suominen gentoo-dev 2013-04-10 08:35:56 UTC
It's normal for libpng 1.5 from SLOT="0" to block libpng 1.5 from SLOT="1.5"

The difference is that SLOT="1.5" only installs 1 file, libpng15.so.15, for compability with binary-only applications that can't be rebuilt against libpng 1.6
The SLOT="1.5" can be co-installed with libpng 1.6 from SLOT="0"

Just like it's possible to install SLOT="1.2" alongside SLOT="0"

If user mistakenly has masked >=media-libs/libpng-1.6, or only keyworded the libpng 1.5 from SLOT="1.5" without also keywording libpng 1.6, thesetype of unclear dependency conflicts will surely happen

The correct package.keywords entry to get new libpng:

<media-libs/libpng-1.6.9999

The correct package.mask entries to avoid new libpng:

media-libs/libpng:1.5
>=media-libs/libpng-1.6
Comment 4 Juergen Rose 2013-04-10 09:28:00 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > [ebuild     UD ] media-libs/libpng-1.5.15:0/0 [1.6.1:0/16] USE="apng (-neon)
> > -static-libs" 0 kB
> 
> Why are you trying to downgrade libpng? There is no conflict if properly
> keyworded:
> 
> $ sudo emerge -pv libpng:0 libpng:1.5 libpng:1.2
> 
> These are the packages that would be merged, in reverse order:
> 
> Calculating dependencies... done!
> [ebuild  NS    ] media-libs/libpng-1.2.50:1.2 [1.5.15-r15:1.5, 1.6.1:0/16]
> 527 kB
> [ebuild   R    ] media-libs/libpng-1.5.15-r15:1.5  USE="apng (-neon)" 0 kB
> [ebuild   R    ] media-libs/libpng-1.6.1:0/16  USE="apng (-neon)
> -static-libs" 0 kB

I did not try to downgrade, 'emerge -uvND world' did it.
Comment 5 Juergen Rose 2013-04-10 10:36:19 UTC
'emerge  --sync' and 'revdep-rebuild' did not resolve the problem, but 'emerge -v1 kdelibs =php-5.5.0_beta2-r4 gthumb =webkit-gtk-1.10.2-r300 digikam' removed it.
Comment 6 Patrick Holthaus 2013-04-10 11:18:03 UTC
(In reply to comment #3)
> It's normal for libpng 1.5 from SLOT="0" to block libpng 1.5 from SLOT="1.5"
> 
> The difference is that SLOT="1.5" only installs 1 file, libpng15.so.15, for
> compability with binary-only applications that can't be rebuilt against
> libpng 1.6
> The SLOT="1.5" can be co-installed with libpng 1.6 from SLOT="0"
> 
> Just like it's possible to install SLOT="1.2" alongside SLOT="0"

Okay, so wouldn't portage be able to figure out that an upgrade from libpng-1.5.15 to libpng-1.5.15-r15 would resolve the blocker because version 1.5.15 in slot 0 would be removed?

> If user mistakenly has masked >=media-libs/libpng-1.6, or only keyworded the
> libpng 1.5 from SLOT="1.5" without also keywording libpng 1.6, thesetype of
> unclear dependency conflicts will surely happen
> 
> The correct package.keywords entry to get new libpng:
> 
> <media-libs/libpng-1.6.9999
> 
> The correct package.mask entries to avoid new libpng:
> 
> media-libs/libpng:1.5
> >=media-libs/libpng-1.6

Just to get it straight for me: I'm on ~amd64 and don't have anything in package.mask/keywords/unmask except =app-emulation/emul-linux-x86-xlibs-20130224-r1

Nonetheless this blocker happened to me. Could it be a dependency from the emulation package that caused this?
Comment 7 Oleh 2013-04-10 11:37:22 UTC
what if user didn't masked/keyworded, just using ~arch. There are several reports about another png crazyness. When Gentoo stop to break things every libpng bump? If it's cannot be solved via current slot/subslot portage implementation, just do not bump package for Christ sake! What a nasty addiction to rolling release.
Comment 8 Derk W te Bokkel 2013-04-10 12:53:39 UTC
looks like https://bugs.gentoo.org/show_bug.cgi?id=465356#c2 offers the best clue .. it worked for me

only two files gdk-pixbuf and slim caused the block but were auto rebuilt when doing:

emerge -C libpng:0 && emerge -auDvN world  

w/   FEATURES="preserve-libs"

perhaps an intermediate pseudo upgrade is needed to set proper slot preparation?

this was on ~amd64  w/ no masking or unmasking
  (In reply to comment #2)
> Seems libpng-1.5 moved slot from :0 to :1.5
> emerge -aC libpng:0 helped for me, removing libpng-1.5.15 (and only this
> version) from my system. A world upgrade pulled it back into the new slot.
Comment 9 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-04-10 15:52:13 UTC
(In reply to comment #7)
> what if user didn't masked/keyworded, just using ~arch.

ACCEPT_KEYWORDS="amd64 ~amd64" is listed on this page, we know that...

> There are several reports about another png crazyness. When Gentoo stop to break things every libpng bump?

It's not crazy, it's normal. Never, things are expected to break...

> If it's cannot be solved via current slot/subslot portage implementation, just do not bump package for Christ sake! What a nasty addiction to rolling release.

This in not Funtoo, we rather not have a nasty addiction to lag long ways behind.
Comment 10 Oleh 2013-04-10 15:57:44 UTC
sure, breaks are expected but with libpng it looks like salting a bleeding wound, lets commit, break heck amount of a users boxes, then fix slot, subslot, deps, whatever else. Nothing personal.
Comment 11 Samuli Suominen gentoo-dev 2013-04-10 16:03:34 UTC
the ebuilds are as they should in portage, but perhaps portage developers have more insight, perhaps the package manager itself could use improvement for this
Comment 12 Zac Medico gentoo-dev 2013-04-10 17:53:04 UTC
(In reply to comment #0)
> app-misc/pax-utils:0
> 
>   (app-misc/pax-utils-0.5::gentoo, installed) pulled in by
>     <app-misc/pax-utils-0.6 required by
> (sys-kernel/genkernel-3.4.45::gentoo, installed)
> 
>   (app-misc/pax-utils-0.7::gentoo, ebuild scheduled for merge) pulled in by
>     (no parents that aren't satisfied by other packages in this slot)
> 
> sci-libs/netcdf:0
> 
>   (sci-libs/netcdf-4.1.3::x-portage, installed) pulled in by
>     ~sci-libs/netcdf-4.1.3[cxx,hdf5] required by
> (sci-visualization/paraview-3.98.0::gentoo, installed)
> 
>   (sci-libs/netcdf-4.2.1.1::gentoo, ebuild scheduled for merge) pulled in by
>     >=sci-libs/netcdf-4.2 required by (sci-libs/netcdf-cxx-4.2-r1::gentoo,
> ebuild scheduled for merge)

It may be that if you solve these app-misc/pax-utils:0 and sci-libs/netcdf:0 conflicts, then the media-libs/libpng:0 conflict will solve automatically. When emerge bails out due to conflicts like these, it simply displays all conflicts that it was trying to solve, even though some of them may really be solvable without user intervention. If that's the only problem here, then we can resolve this bug as a duplicate of bug 460816.
Comment 13 Juergen Rose 2013-04-10 18:17:22 UTC
(In reply to comment #12)
> (In reply to comment #0)
> > app-misc/pax-utils:0
> > 
> >   (app-misc/pax-utils-0.5::gentoo, installed) pulled in by
> >     <app-misc/pax-utils-0.6 required by
> > (sys-kernel/genkernel-3.4.45::gentoo, installed)
> > 
> >   (app-misc/pax-utils-0.7::gentoo, ebuild scheduled for merge) pulled in by
> >     (no parents that aren't satisfied by other packages in this slot)
> > 
> > sci-libs/netcdf:0
> > 
> >   (sci-libs/netcdf-4.1.3::x-portage, installed) pulled in by
> >     ~sci-libs/netcdf-4.1.3[cxx,hdf5] required by
> > (sci-visualization/paraview-3.98.0::gentoo, installed)
> > 
> >   (sci-libs/netcdf-4.2.1.1::gentoo, ebuild scheduled for merge) pulled in by
> >     >=sci-libs/netcdf-4.2 required by (sci-libs/netcdf-cxx-4.2-r1::gentoo,
> > ebuild scheduled for merge)
> 
> It may be that if you solve these app-misc/pax-utils:0 and sci-libs/netcdf:0
> conflicts, then the media-libs/libpng:0 conflict will solve automatically.
> When emerge bails out due to conflicts like these, it simply displays all
> conflicts that it was trying to solve, even though some of them may really
> be solvable without user intervention. If that's the only problem here, then
> we can resolve this bug as a duplicate of bug 460816.


I do not know, how can I solve these conflicts, at an other way than to wait for a paraview version, which works with current netcdf and to wait for genkernel version, which works with current pax-utils.
Comment 14 Zac Medico gentoo-dev 2013-04-10 18:38:12 UTC
(In reply to comment #13)
> I do not know, how can I solve these conflicts, at an other way than to wait
> for a paraview version, which works with current netcdf and to wait for
> genkernel version, which works with current pax-utils.

This should solve those conflicts:

  echo '>=app-misc/pax-utils-0.6' >> /etc/portage/package.mask
  echo '>=sci-libs/netcdf-4.2' >> /etc/portage/package.mask
Comment 15 Paul Varner (RETIRED) gentoo-dev 2013-04-10 22:30:28 UTC
I have the same issue.  My system is completely updated except for libpng (which I temporarily masked to update everything else).  I get the following when I run emerge -auDNv world:

# emerge -auDNv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libpng-1.6.1:0/16 [1.5.15:0/0] USE="apng (-neon) -static-libs" 826 kB
[ebuild  NS    ] media-libs/libpng-1.5.15-r15:1.5 [1.5.15:0] USE="apng (-neon)" 0 kB
[blocks B      ] =media-libs/libpng-1.5*:0 ("=media-libs/libpng-1.5*:0" is blocking media-libs/libpng-1.5.15-r15)

Total: 2 packages (1 upgrade, 1 in new slot), Size of downloads: 826 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.2::gentoo, installed)
    media-libs/libpng:0/0= required by (www-client/chromium-27.0.1453.12::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/ksplash-4.10.2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/libwebp-0.3.0::gentoo, installed)
    >=media-libs/libpng-1.4:0/0= required by (x11-libs/gdk-pixbuf-2.26.5::gentoo, installed)

  (media-libs/libpng-1.6.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Comment 16 Zac Medico gentoo-dev 2013-04-11 01:02:11 UTC
(In reply to comment #15)
You may be triggering bug 461464. You need to verify whether or not each of those installed packages with slot-operator deps is available and unmasked so that it can be rebuilt, like this:

emerge -pv1 kde-base/kdelibs kde-base/ksplash media-libs/libwebp x11-libs/gdk-pixbuf
Comment 17 Samuli Suominen gentoo-dev 2013-04-11 02:32:37 UTC
(In reply to comment #15)
> I have the same issue.  My system is completely updated except for libpng
> (which I temporarily masked to update everything else).  I get the following
> when I run emerge -auDNv world:

Masked how? Correct package.mask entries:

media-libs/libpng:1.5
>=media-libs/libpng-1.6

As in, you can't simply mask >=media-libs/libpng-1.6 alone, as 1.5.15-r15:1.5 is designed to be co-installable with 1.6, it's a special SLOT in that sense.

(Sorry for bugspam, but needed to verify the obvious.)
Comment 18 LeonBernieniv 2013-04-11 02:56:27 UTC
The another way for me:

MOD to 'media-libs/libpng:1.5' in icedtea-bin-7.2.3.8.ebuild, digest it to own overlay

Do not uDN world first, may make blocking.

sudo emerge -C icedtea-bin libpng && sudo emerge icedtea-bin libpng -1

libpng-1.5.15-r15 icedtea-bin libpng-1.6.1 well be installed.

Then 
sudo emerge @preserved-rebuild -pv
Comment 19 Paul Varner (RETIRED) gentoo-dev 2013-04-11 15:15:22 UTC
(In reply to comment #17)
> Masked how? Correct package.mask entries:

It was masked correctly.  I can fix this manually, by unmerging =media-libs/libpng-1.5*:0

This tells me that something is preventing portage from being able to recognize that it can replace media-libs/libpng-1.5*:0 with media-libs/libpng:1.5  

My next step is to go through with Zac's suggestion in comment 16
Comment 20 Paul Varner (RETIRED) gentoo-dev 2013-04-11 15:24:21 UTC
(In reply to comment #16)
> (In reply to comment #15)
> You may be triggering bug 461464. You need to verify whether or not each of
> those installed packages with slot-operator deps is available and unmasked
> so that it can be rebuilt

I don't appear to be hitting that bug:

# emerge -auDNv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libpng-1.6.1:0/16 [1.5.15:0/0] USE="apng (-neon) -static-libs" 826 kB
[ebuild  NS    ] media-libs/libpng-1.5.15-r15:1.5 [1.5.15:0] USE="apng (-neon)" 0 kB
[blocks B      ] =media-libs/libpng-1.5*:0 ("=media-libs/libpng-1.5*:0" is blocking media-libs/libpng-1.5.15-r15)

Total: 2 packages (1 upgrade, 1 in new slot), Size of downloads: 826 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.15::gentoo, installed) pulled in by
    >=media-libs/libpng-1.4:0/0= required by (x11-libs/gdk-pixbuf-2.26.5::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.10.2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/libwebp-0.3.0::gentoo, installed)
    media-libs/libpng:0/0= required by (x11-wm/windowmaker-0.95.4-r1::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/ksplash-4.10.2::gentoo, installed)
    media-libs/libpng:0/0= required by (www-client/chromium-27.0.1453.12::gentoo, installed)
    media-libs/libpng:0/0= required by (x11-libs/cairo-1.12.14::gentoo, installed)

  (media-libs/libpng-1.6.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


# emerge -pv1 x11-libs/gdk-pixbuf kde-base/kdelibs media-libs/libwebp x11-wm/windowmaker kde-base/ksplash www-client/chromium x11-libs/cairo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] kde-base/kdelibs-4.10.2:4  USE="alsa bzip2 fam handbook mmx nls opengl (policykit) semantic-desktop spell sse sse2 ssl udev udisks upower -3dnow -acl (-altivec) (-aqua) -debug -doc -jpeg2k -kerberos -lzma -openexr {-test} -zeroconf" 0 kB
[ebuild   R    ] media-libs/libwebp-0.3.0  USE="gif jpeg png tiff -experimental -static-libs -swap-16bit-csp" ABI_X86="(64) -32 (-x32)" 0 kB
[ebuild   R    ] x11-libs/gdk-pixbuf-2.26.5:2  USE="X introspection jpeg tiff -debug -jpeg2k {-test}" 0 kB
[ebuild   R    ] x11-wm/windowmaker-0.95.4-r1  USE="gif jpeg nls png tiff -modelock -xinerama -xrandr" 0 kB
[ebuild   R    ] x11-libs/cairo-1.12.14  USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) -legacy-drivers -openvg (-qt4) -static-libs" 0 kB
[ebuild   R    ] kde-base/ksplash-4.10.2:4  USE="mmx sse sse2 -3dnow (-altivec) (-aqua) -debug -xinerama" 0 kB
[ebuild   R    ] www-client/chromium-27.0.1453.12  USE="cups -custom-cflags -gnome -gnome-keyring -gps -kerberos -pulseaudio (-selinux) (-system-sqlite) (-tcmalloc) {-test}" LINGUAS="-am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB

Total: 7 packages (7 reinstalls), Size of downloads: 0 kB
Comment 21 Paul Varner (RETIRED) gentoo-dev 2013-04-11 15:31:43 UTC
Created attachment 345240 [details]
emerge -auDNV --debug world output

Here is --debug output for emerge -auDNv --debug world.
Comment 22 Samuli Suominen gentoo-dev 2013-04-11 15:44:03 UTC
(In reply to comment #19)
> (In reply to comment #17)
> > Masked how? Correct package.mask entries:
> 
> It was masked correctly.  I can fix this manually, by unmerging
> =media-libs/libpng-1.5*:0
> 
> This tells me that something is preventing portage from being able to
> recognize that it can replace media-libs/libpng-1.5*:0 with
> media-libs/libpng:1.5  

icedtea-bin, thunderbird-bin, and libreoffice-bin all have deps like =media-libs/libpng-1.5* to indicate both SLOTs :0 and :1.5 are fine for them

if none of these three packages are installed from the actual Portage tree, nothing should be pulling in media-libs/libpng:1.5 in the first place

i'm curious if it would help Portage to resolve the dependencies better if those three packages would use dependency like
|| ( media-libs/libpng:1.5 =media-libs/libpng-1.5*:0 )
or
media-libs/libpng:1.5
instead of
=media-libs/libpng-1.5*

although I don't see why that would make any difference, and there is a point in using =media-libs/libpng-1.5* in them instead of :1.5 since we want to allow installation also with current stable libpng which happens to be 1.5 from :0 SLOT, to avoid forcing stable users to libpng 1.6 this soon :-/
Comment 23 Paul Varner (RETIRED) gentoo-dev 2013-04-11 21:53:56 UTC
Created attachment 345280 [details]
vdb.tar.xz

Contents of /var/db/pkg as requested on IRC
Comment 24 Paul Varner (RETIRED) gentoo-dev 2013-04-11 22:21:34 UTC
Created attachment 345290 [details]
world file

world file and emerge --info

Portage 2.1.11.60 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.5.7-gentoo x86_64)
=================================================================
System uname: Linux-3.5.7-gentoo-x86_64-Dual-Core_AMD_Opteron-tm-_Processor_2218-with-gentoo-2.2
KiB Mem:     4059684 total,     57656 free
KiB Swap:    2008120 total,   1933784 free
Timestamp of tree: Thu, 11 Apr 2013 07:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13::<unknown repository>, 2.69
sys-devel/automake:       1.5-r1, 1.10.3, 1.11.6, 1.13.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo mate-overlay local
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-g -O2 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/chroot/dns /etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-g -O2 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/mate /usr/local/portage/local"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam flac fortran gdbm gif gpm gstreamer gtk iconv icu java java6 jpeg kde kipi lcms libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xml xscreensaver xulrunner xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 25 Paul Varner (RETIRED) gentoo-dev 2013-04-11 22:28:50 UTC
Created attachment 345292 [details]
/etc/portage

Contents of /etc/portage
Comment 26 Zac Medico gentoo-dev 2013-04-11 23:20:09 UTC
This fixes the issue with the blocker reported in comment #15:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=62dbcaa4d873784f1082c184668fcdc34392925b

I don't see a blocker in comment #0 though, so for that I'm sticking with what I said in comment #12 about marking this bug as a duplicate of bug 460816.
Comment 27 Zac Medico gentoo-dev 2013-04-11 23:47:40 UTC
This is fixed in 2.1.11.61 and 2.2.0_alpha172.
Comment 28 Zac Medico gentoo-dev 2013-04-12 14:38:51 UTC

*** This bug has been marked as a duplicate of bug 465638 ***