Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 465330 - =app-emulation/virtualbox-4.2.10 with tmpfs PORTAGE_TMPDIR - setfattr: /tmp/portage/app-emulation/virtualbox-4.2.10/image//usr/lib64/virtualbox/VBoxSVC: Operation not supported
Summary: =app-emulation/virtualbox-4.2.10 with tmpfs PORTAGE_TMPDIR - setfattr: /tmp/p...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-10 04:09 UTC by eroen
Modified: 2013-10-03 23:26 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log with PORTAGE_TMPDIR on a tmpfs (build.log,378.99 KB, text/plain)
2013-04-10 04:11 UTC, eroen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eroen 2013-04-10 04:09:28 UTC
It used to work just fine, I noticed when rebuilding virtualbox after a libpng update. 

I suspect the recent change in pax-utils.eclass to do both PT and XT marking, rather than just PT by default caused the change. ( http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/pax-utils.eclass?r1=1.19&r2=1.20 )

virtualbox installs successfully if I set PORTAGE_TMPFS to an ext4 filesystem (with user_xattr enabled) or set PAX_MARKINGS=PT. Presumably, it would be possible to make the marking somehow conditional and not apply it on non-PAX systems or removing the die statement to have the install continue despite failed marking.

Note, I have CONFIG_TMPFS_XATTR=y in my kernel config. I believe xattrs should be available on tmpfs without additional mount options.

Reproducible: Always




$ emerge --info '=app-emulation/virtualbox-4.2.10'
Portage 2.2.0_alpha171 (default/linux/amd64/13.0/desktop, gcc-4.7.2, glibc-2.17, 3.8.6-occam1+ x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.8.6-occam1+-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.2
KiB Mem:     8011620 total,   2296404 free
KiB Swap:   16777212 total,  16755752 free
Timestamp of tree: Tue, 09 Apr 2013 22:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0-r1000::progress
dev-lang/python:          2.7.5_pre20130407::progress, 3.2.4-r1000::progress, 3.3.0-r1
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.2-r1, 4.8.0
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo gentoo-haskell progress java-overlay glc hasufell roslin eroen-overlay cross
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -flto -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -finline-functions -fpredictive-commoning -fgcse-after-reload -ftree-vectorize -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7-avx -flto -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -finline-functions -fpredictive-commoning -fgcse-after-reload -ftree-vectorize -O2 -pipe"
DISTDIR="/var/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=4 --autounmask --with-bdeps=y --quiet-build --nospinner"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="/var/distfiles-falcon http://mirrors.eu.kernel.org/gentoo/ http://mirrors.kernel.org/gentoo/ http://distfiles.gentoo.org "
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/var/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude ChangeLog* --exclude /metadata/cache/ --stats --delay-updates"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/haskell /var/lib/layman/progress /var/lib/layman/java-overlay /var/lib/layman/glc /var/lib/layman/hasufell /var/lib/layman/roslin /usr/local/portage /usr/local/portage-cross-musl"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apng audio audiofile avresample avx bash-completion bdf berkdb bluray bzip2 cairo caps cb cdda cdparanoia cdr cjk cli corefonts cracklib crypt cups curl cxx ddate declarative detex device-mapper dga dia djvu dmapi dri dts dvd dvdr dvi2tty dvipdfm ebook egl emboss encode exif fam ffmpeg fftw firefox fits flac fontconfig fortran g3dvl gallium gbm gcj gcrypt gdbm gif gimp git glib glibc-omitfp gmp gnuplot gnutls gold gpm graphics graphviz gs gstreamer gtk gtk3 highlight hscolour iconv icu id3tag idn imagemagick imlib inotify iproute2 ipv6 jbig jpeg jpeg2k jpg json kde kde4 kpathsea latex lcms libffi libssh2 libv4l luatex lvm lvm2 lzma lzo mad man metric mikmod mkv mms mmx mng modules mp3 mp4 mpeg mpg123 mudflap multilib multimedia musepack ncurses netlink nptl nut ocr odbc offensive ogg opengl openmp openvg optimization optimized-qmake opus pam pango pch pcre pdf pgf phonon png postscript ppds private-headers pstricks pth publishers pulseaudio python3 qt3support qt4 raw readline samba sbsms scanner science sdl session smp sna sndfile speex spell sqlite sse sse2 sse3 sse4 sse4_1 sse4_2 ssh ssl ssse3 svg t1lib tcpd tesseract theora threads tiff tls truetype udev unicode usb v4l v4l2 vaapi video vorbis vpx webp wmf wxwidgets x264 xanim xattr xcb xcomposite xetex xfs xft xinerama xml xmlpatterns xorg xosd xpm xrandr xv xvid xvmc xz zlib zsh-completion" ABI_X86="32 64" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="gnutls" DRACUT_MODULES="btrfs caps cifs crypt crypt-gpg lvm nfs ssh-client syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="mouse keyboard evdev synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en gb us en_US en_GB eng jbo no nb nn no_NO nb_NO nn_NO nor" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3 php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 python3_3" QEMU_SOFTMMU_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="intel i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND

=================================================================
                        Package Settings
=================================================================

app-emulation/virtualbox-4.2.10 was built with the following:
USE="additions alsa extensions (multilib) opengl pam pulseaudio qt4 sdk -doc -headless -java -python -vboxwebsrv -vnc" ABI_X86="64"
CFLAGS="-march=corei7-avx -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -finline-functions -fpredictive-commoning -fgcse-after-reload -ftree-vectorize -O2 -pipe"
CXXFLAGS="-march=corei7-avx -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -finline-functions -fpredictive-commoning -fgcse-after-reload -ftree-vectorize -O2 -pipe"

$ emerge -pqv '=app-emulation/virtualbox-4.2.10'
[ebuild   R   ] app-emulation/virtualbox-4.2.10  USE="additions alsa extensions opengl pam pulseaudio qt4 sdk -doc -headless -java -python -vboxwebsrv -vnc"
Comment 1 eroen 2013-04-10 04:11:01 UTC
Created attachment 345058 [details]
build.log with PORTAGE_TMPDIR on a tmpfs
Comment 3 eroen 2013-04-11 14:27:32 UTC
The pax-utils.eclass change is described in bug 431092.
Comment 4 Ben Kohler gentoo-dev 2013-10-03 23:26:22 UTC
The default was set back to PAX_MARKINGS="PT" just a few days after XT was introduced (and initially set default-on):

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/pax-utils.eclass?r1=1.19&r2=1.20

I'm gonna close this bug since you now have to explicitly turn on XT markings (without having XT available on PORTAGE_TMPDIR) to hit this.  Please re-open if you think there's anything else that needs fixing.