Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 464328 - app-portage/ufed-0.90_rc1 fails to compile with sys-libs/ncurses[tinfo]
Summary: app-portage/ufed-0.90_rc1 fails to compile with sys-libs/ncurses[tinfo]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sven Eden
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-04-03 10:49 UTC by Samuli Suominen
Modified: 2013-04-12 14:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2013-04-03 10:49:01 UTC
The output looks like:

x86_64-pc-linux-gnu-gcc -std=gnu99  -march=native -O2 -pipe -Wall -Wextra -pedantic -Wmissing-prototypes -Wstrict-prototypes  -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -o ufed-curses ufed-curses.o ufed-curses-checklist.o ufed-curses-help.o ufed-curses-globals.o ufed-curses-types.o  -lncursesw 
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.2/../../../../x86_64-pc-linux-gnu/bin/ld: ufed-curses.o: undefined reference to symbol 'cbreak'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.2/../../../../x86_64-pc-linux-gnu/bin/ld: note: 'cbreak' is defined in DSO /lib64/libtinfow.so.5 so try adding it to the linker command line
/lib64/libtinfow.so.5: could not read symbols: Invalid operation

Which is caused by missing -ltinfo linking, as in, pkg-config should be used to query libncursesw libraries:

$ pkg-config --libs ncursesw
-lncursesw -ltinfow 
$ pkg-config --libs ncurses
-lncurses -ltinfo 

Alternatively ncurses5-config can be used:

$ ncurses5-config --libs
-L/usr/lib64 -lncurses -ltinfo

Some symbols are broken into it's own library with USE="tinfo"
Comment 1 Sven Eden 2013-04-03 13:41:35 UTC
I have updated the build system to use pkg-config to determine the correct libraries.
After emerging ncurses with USE="tinfo" ufed is now linked against ncursesw and tinfow.

Could you please try out ufed-9999 to see if this really fixed your issue?
Comment 2 Samuli Suominen gentoo-dev 2013-04-03 15:48:08 UTC
9999 works now, thanks!
Comment 3 Samuli Suominen gentoo-dev 2013-04-03 16:06:38 UTC
(In reply to comment #2)
> 9999 works now, thanks!

I've added the pkgconfig dependency to ufed-9999.ebuild for you:

+  03 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> ufed-9999.ebuild:
+  Pull in virtual/pkgconfig wrt #464328
+
Comment 4 Paul Varner (RETIRED) gentoo-dev 2013-04-03 18:08:53 UTC
Thanks, I'll get an updated 0.90 out later this week.
Comment 5 Paul Varner (RETIRED) gentoo-dev 2013-04-12 14:32:29 UTC
Released in app-portage/ufed-0.90_rc2