Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 464012 - gnome-extra/gucharmap-3.8.0 with USE="vala" fails to emerge without dev-lang/vala-0.18.1
Summary: gnome-extra/gucharmap-3.8.0 with USE="vala" fails to emerge without dev-lang/...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Keywords: PATCH
: 466786 (view as bug list)
Depends on:
Blocks: gnome-3.8
  Show dependency tree
Reported: 2013-03-31 18:41 UTC by Chris Mayo
Modified: 2013-04-22 17:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Attachments (file_464012.txt,249 bytes, text/plain)
2013-04-01 10:35 UTC, Tom Wijsman (TomWij) (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Mayo 2013-03-31 18:41:00 UTC
With dev-lang/vala-0.20.0 installed but no dev-lang/vala-0.18.1:

checking pkg-config is at least version 0.9.0... yes
configure: error: vapigen-0.18 >= 0.16 not found

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/gnome-extra/gucharmap-3.8.0/work/gucharmap-3.8.0/config.log
 * ERROR: gnome-extra/gucharmap-3.8.0 failed (configure phase):
 *   econf failed
 * Call stack:
 *, line   93:  Called src_configure
 *        environment, line 3462:  Called gnome2_src_configure

I worked around this with:

@@ -243,7 +243,7 @@
-  [VAPIGEN_CHECK([0.16],[0.18])],
+  [VAPIGEN_CHECK([0.16])],
 case "$with_gtk" in
Comment 1 Chris Mayo 2013-03-31 19:02:36 UTC
Should have also said that with gobject-introspection-1.36.0 it fails even with dev-lang/vala-0.18.1 because of instance-parameter, bug 463720.
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-04-01 10:35:15 UTC
Created attachment 343914 [details]
Comment 3 Michael Hampicke 2013-04-02 07:39:20 UTC
Patch from comment #2 resolved the issu here.
Comment 4 Pacho Ramos gentoo-dev 2013-04-22 17:22:56 UTC
*** Bug 466786 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2013-04-22 17:46:52 UTC
this is solved in 3.8.1