Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 463526 - www-servers/apache-2.4.4-r3 AH00526: Syntax error on line 60 of /etc/apache2/modules.d/40_mod_ssl.conf
Summary: www-servers/apache-2.4.4-r3 AH00526: Syntax error on line 60 of /etc/apache2/...
Status: RESOLVED DUPLICATE of bug 438758
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
: 490622 (view as bug list)
Depends on:
Blocks: apache-2.4-stable
  Show dependency tree
 
Reported: 2013-03-27 19:29 UTC by tman
Modified: 2013-11-22 09:35 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2013-03-27 19:29:25 UTC
# /etc/init.d/apache2 start
 * apache2 has detected an error in your setup:
[Wed Mar 27 20:27:46.985995 2013] [core:warn] [pid 29458:tid 139948966852416] AH00111: Config variable ${SVN_REPOS_LOC} is not defined
[Wed Mar 27 20:27:46.986053 2013] [core:warn] [pid 29458:tid 139948966852416] AH00111: Config variable ${SVN_REPOS_LOC} is not defined
AH00526: Syntax error on line 60 of /etc/apache2/modules.d/40_mod_ssl.conf:
Invalid Mutex directory in argument file:/var/run/apache_ssl_mutex
 * ERROR: apache2 failed to star

Reproducible: Always



Expected Results:  
a working apache which start :))

Portage 2.1.11.58 (default/linux/amd64/13.0/desktop, gcc-4.7.2, glibc-2.16.0, 3.8.4-gentoo x86_64)
=================================================================
System uname: Linux-3.8.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-3740QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    24627872 total,  20148868 free
KiB Swap:   25081852 total,  25081852 free
Timestamp of tree: Unknown
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8::pentoo
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.13.1
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r5::gnome
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo mpd nikai ruby mgorny poly-c mva flameeyes-overlay pentoo luman qt alice wirelay Techwolf gamerlay scarabeus science gnome emacs steam-overlay lokal
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/X11/Sessions/awesome /etc/X11/Sessions/dwm /etc/conf.d/consolefont /etc/conf.d/hostname /etc/conf.d/hwclock /etc/conf.d/keymaps /etc/default/grub /etc/eix-sync.conf /etc/fstab /etc/hosts /etc/locale.gen /etc/make.conf /etc/timezone /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
Comment 1 Tomáš Mózes 2013-04-09 10:06:10 UTC
This has been discussed for 2.4.3 also. Checkpath is put after checkconfig, which fails because the directory doesn't exist.

--- apache2.orig        2013-04-09 11:45:44.713659528 +0200
+++ apache2     2013-04-09 11:43:39.849426752 +0200
@@ -71,8 +71,8 @@
 }
 
 start() {
-       checkconfig || return 1
        checkpath --directory /run/apache_ssl_mutex
+       checkconfig || return 1
 
        ebegin "Starting ${SVCNAME}"
        # Use start stop daemon to apply system limits #347301
Comment 2 Roman Žilka 2013-05-12 02:15:24 UTC
(In reply to comment #1)
> This has been discussed for 2.4.3 also.

This is a duplicate of bug 438758.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-15 12:57:35 UTC
*** Bug 490622 has been marked as a duplicate of this bug. ***
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2013-11-22 09:35:12 UTC

*** This bug has been marked as a duplicate of bug 438758 ***