Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 463228 - x11-drivers/nvidia-drivers-310.32 with kernel 3.8.4 - ACPI Error: [\_SB_.PCI0.P0P2.PEGP.SPB_] Namespace lookup failure, AE_NOT_FOUND (20121018/psargs-359)
Summary: x11-drivers/nvidia-drivers-310.32 with kernel 3.8.4 - ACPI Error: [\_SB_.PCI0...
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-25 13:46 UTC by larmbr
Modified: 2013-03-26 15:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description larmbr 2013-03-25 13:46:48 UTC
I has a fresh install of gentoo, using gentoo-kernel-3.8.4,   with xorg-server 1.13.1 installed. the nvidia-drivers version is 310.32

During booting, it regularily yeild a kernel oops, sometimes the system will boot , but sometime it just freezes then.

some dmesg context:


--- dmesg ---

[    6.659999] systemd-udevd[1432]: starting version 197
[    7.360774] nvidia: module license 'NVIDIA' taints kernel.
[    7.360780] Disabling lock debugging due to kernel taint
[    7.368727] nvidia 0000:02:00.0: enabling device (0104 -> 0107)
[    7.368741] vgaarb: device changed decodes: PCI:0000:02:00.0,olddecodes=io+mem,decodes=none:owns=none
[    7.368822] NVRM: loading NVIDIA UNIX x86 Kernel Module  310.32  Mon Jan 14 14:38:50 PST 2013
[    7.907678] ACPI Error: [\_SB_.PCI0.P0P2.PEGP.SPB_] Namespace lookup failure, AE_NOT_FOUND (20121018/psargs-359)
[    7.907684] ACPI Error: Method parse/execution failed [\_SB_.PCI0.P0P2.PEGP._DSM] (Node f6047cc0), AE_NOT_FOUND (20121018/psparse-537)
[    7.907727] BUG: unable to handle kernel paging request at 5030503c
[    7.907882] IP: [<c1313085>] acpi_ps_complete_this_op+0x116/0x160
[    7.908011] *pde = 00000000
[    7.908125] Oops: 0000 [#1] SMP
[    7.908268] Modules linked in: nvidia(PO)
[    7.908418] Pid: 1484, comm: nvidia-smi Tainted: P           O 3.8.4-gentoo #2 Acer Aspire 4743/
[    7.908565] EIP: 0060:[<c1313085>] EFLAGS: 00010206 CPU: 0
[    7.908654] EIP is at acpi_ps_complete_this_op+0x116/0x160
[    7.908746] EAX: f56b7720 EBX: f4c5f800 ECX: 50305030 EDX: 50305030
[    7.908841] ESI: f56b7fa0 EDI: 00000000 EBP: f55c1b14 ESP: f55c1b04
[    7.908933]  DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
[    7.909021] CR0: 80050033 CR2: 5030503c CR3: 3570f000 CR4: 000007d0
[    7.909116] DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
[    7.909210] DR6: ffff0ff0 DR7: 00000400
[    7.909297] Process nvidia-smi (pid: 1484, ti=f55c0000 task=f6233c00 task.ti=f55c0000)
[    7.909439] Stack:
[    7.909516]  50305030 f4c5f800 f55c1b60 f4c5f800 f55c1b38 c13124b3 f55c1b38 c1303cec
[    7.909898]  0000000f 00000000 f4c5f800 00000000 f4c5f800 f55c1b70 c1312da6 c1319563
[    7.910281]  00000000 f55c1b58 f4c5f828 f8014766 00000000 f4c5fc00 f4c5fc00 f56b7fa0
[    7.910668] Call Trace:
[    7.910753]  [<c13124b3>] acpi_ps_complete_op+0x1f/0x1fe
[    7.910846]  [<c1303cec>] ? acpi_ds_exec_end_op+0x304/0x370
[    7.910937]  [<c1312da6>] acpi_ps_parse_loop+0x714/0x856
[    7.911026]  [<c1319563>] ? acpi_ut_create_generic_state+0x27/0x41
[    7.911121]  [<c1313223>] acpi_ps_parse_aml+0x82/0x233
[    7.911213]  [<c131392c>] acpi_ps_execute_method+0x190/0x228
[    7.911304]  [<c130ee68>] acpi_ns_evaluate+0xc0/0x176
[    7.911394]  [<c13114c9>] acpi_evaluate_object+0xd1/0x1c0
[    7.911543]  [<f94ae746>] nv_acpi_dsm_method+0x116/0x1e0 [nvidia]
[    7.911639]  [<c12f8216>] ? acpi_os_wait_semaphore+0x34/0x48
[    7.911775]  [<f9488423>] _nv011908rm+0xf9/0x12a [nvidia]
[    7.911913]  [<f9009677>] ? _nv001034rm+0x62/0xd7 [nvidia]
[    7.911304]  [<c130ee68>] acpi_ns_evaluate+0xc0/0x176
[    7.911394]  [<c13114c9>] acpi_evaluate_object+0xd1/0x1c0
[    7.911543]  [<f94ae746>] nv_acpi_dsm_method+0x116/0x1e0 [nvidia]
[    7.911639]  [<c12f8216>] ? acpi_os_wait_semaphore+0x34/0x48
[    7.911775]  [<f9488423>] _nv011908rm+0xf9/0x12a [nvidia]
[    7.911913]  [<f9009677>] ? _nv001034rm+0x62/0xd7 [nvidia]
[    7.912052]  [<f9009ae3>] ? _nv001033rm+0x1b/0x1ec [nvidia]
[    7.912183]  [<f949035f>] ? _nv000793rm+0xa6/0xec [nvidia]
[    7.912313]  [<f9491ed2>] ? _nv000794rm+0x328/0x699 [nvidia]
[    7.912447]  [<f948c3a8>] ? rm_init_adapter+0x78/0x101 [nvidia]
[    7.912579]  [<f94aafa8>] ? nv_kern_open+0x428/0x7c0 [nvidia]
[    7.912673]  [<c110ed9d>] ? chrdev_open+0x7d/0x140
[    7.912762]  [<c11092d6>] ? do_dentry_open+0x1d6/0x250
[    7.912852]  [<c110ed20>] ? cdev_put+0x20/0x20
[    7.912940]  [<c110937e>] ? finish_open+0x2e/0x50
[    7.913027]  [<c1117553>] ? do_last+0x633/0xc10
[    7.913117]  [<c1114981>] ? inode_permission+0x11/0x50
[    7.913209]  [<c1114a15>] ? link_path_walk+0x55/0x740
[    7.913298]  [<c1117bcd>] ? path_openat+0x9d/0x3c0
[    7.913388]  [<c1121c64>] ? setattr_copy+0xa4/0x110
[    7.913480]  [<c10e270c>] ? shmem_setattr+0x3c/0x160
[    7.913570]  [<c1118240>] ? do_filp_open+0x30/0x80
[    7.913658]  [<c110a6c3>] ? do_sys_open+0xf3/0x1d0
[    7.913748]  [<c1113455>] ? path_put+0x15/0x20
[    7.913837]  [<c110a22b>] ? sys_fchownat+0x5b/0xb0
[    7.913927]  [<c110a7cd>] ? sys_open+0x2d/0x40
[    7.914015]  [<c1772bfa>] ? sysenter_do_call+0x12/0x22
[    7.914106] Code: 75 f0 75 5c 85 c0 8b 16 74 16 89 10 c7 40 14 00 00 00 00 8b 56 10 89 50 10 8b 16 89 42 14 eb 2a 8b 46 0c 89 42 14 eb 3e 8b 4d f0 <8b> 51 0c 39 f2 75 2b 85 c0 74 1c 8b 16 c7 40 14 00 00 00 00 89
[    7.916303] EIP: [<c1313085>] acpi_ps_complete_this_op+0x116/0x160 SS:ESP 0068:f55c1b04
[    7.916509] CR2: 000000005030503c
[    7.916607] ---[ end trace e17fa65ab07536e7 ]---
Comment 1 larmbr 2013-03-25 13:49:13 UTC
Portage 2.1.11.31 (default/linux/x86/13.0, gcc-4.5.4, glibc-2.15-r3, 3.5.0-17-generic i686)
=================================================================
System uname: Linux-3.5.0-17-generic-i686-Intel-R-_Core-TM-_i5_CPU_M_480_@_2.67GHz-with-gentoo-2.1
Timestamp of tree: Sat, 23 Mar 2013 21:15:01 +0000
ld GNU gold (GNU Binutils 2.22) 1.11
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages
Comment 2 Jeroen Roovers gentoo-dev 2013-03-25 19:17:27 UTC
Please remove the nvidia.ko driver or disable its automatic loading and see if you can reproduce the problem. The "tainted" messages basically tell you not to expect support from the kernel developers, so you're in the wrong place to file a bug report here about an nvidia driver problem (talk to Nvidia about that) and if it turns out not to be an nvidia driver problem, then but an ACPI problem, then you need to have the nvidia kernel driver out of the loop, too.
Comment 3 larmbr 2013-03-26 03:28:38 UTC
(In reply to comment #2)
> Please remove the nvidia.ko driver or disable its automatic loading and see
> if you can reproduce the problem. The "tainted" messages basically tell you
> not to expect support from the kernel developers, so you're in the wrong
> place to file a bug report here about an nvidia driver problem (talk to
> Nvidia about that) and if it turns out not to be an nvidia driver problem,
> then but an ACPI problem, then you need to have the nvidia kernel driver out
> of the loop, too.

Hi, 

I've tried to unmerge nvidia-drivers, and it boots smoothly.

Maybe this is a nvidia-drivers related bug, I will submit a bug
for nvidia and it's package mantainer.

Thanks!
Comment 4 Jeroen Roovers gentoo-dev 2013-03-26 15:32:55 UTC
Can you reproduce this problem with 310.40?
Comment 5 Jeroen Roovers gentoo-dev 2013-03-26 15:39:30 UTC
310.32 doesn't get our support with kernels >=3.7.
Comment 6 Jeroen Roovers gentoo-dev 2013-03-26 15:50:09 UTC
In fact, this is precisely why we don't patch for new kernel support.

*** This bug has been marked as a duplicate of bug 447566 ***