Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 46320 - gcc-3.3.3 emerge fails due to segmentation fault in gcj (program jc1) in ClassNotFoundException
Summary: gcc-3.3.3 emerge fails due to segmentation fault in gcj (program jc1) in Clas...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2004-03-30 21:16 UTC by Keith Lea
Modified: 2004-07-11 14:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Keith Lea 2004-03-30 21:16:07 UTC
/var/tmp/portage/gcc-3.3.3/work/build/gcc/gcj -B/var/tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava/ -B/var/tmp/portage/gcc-3.3.3/work/build/gcc/ --encoding=UTF-8 -fclasspath= -fbootclasspath=/var/tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava -ffloat-store -MD -MT java/lang/ClassLoader.lo -MF java/lang/ClassLoader.d -c /var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libjava/java/lang/ -fPIC -o java/lang/.libs/ClassLoader.o
/var/tmp/portage/gcc-3.3.3/work/build/gcc/gcj -B/var/tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava/ -B/var/tmp/portage/gcc-3.3.3/work/build/gcc/ --encoding=UTF-8 -fclasspath= -fbootclasspath=/var/tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava -ffloat-store -MD -MT java/lang/ClassLoader.lo -MF java/lang/ClassLoader.d -c /var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libjava/java/lang/ -o java/lang/ClassLoader.o >/dev/null 2>&1
/bin/sh ./libtool --tag=GCJ --mode=compile /var/tmp/portage/gcc-3.3.3/work/build/gcc/gcj -B/var/tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava/ -B/var/tmp/portage/gcc-3.3.3/work/build/gcc/ --encoding=UTF-8 -fclasspath= -fbootclasspath=/var/tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava -ffloat-store  -MD -MT java/lang/ClassNotFoundException.lo -MF java/lang/ClassNotFoundException.d -c -o java/lang/ClassNotFoundException.lo /var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libjava/java/lang/
/var/tmp/portage/gcc-3.3.3/work/build/gcc/gcj -B/var/tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava/ -B/var/tmp/portage/gcc-3.3.3/work/build/gcc/ --encoding=UTF-8 -fclasspath= -fbootclasspath=/var/tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava -ffloat-store -MD -MT java/lang/ClassNotFoundException.lo -MF java/lang/ClassNotFoundException.d -c /var/tmp/portage/gcc-3.3.3/work/gcc-3.3.3/libjava/java/lang/ -fPIC -o java/lang/.libs/ClassNotFoundException.o
gcj: Internal error: Segmentation fault (program jc1)
Please submit a full bug report.
See <URL:> for instructions.
make[3]: *** [java/lang/ClassNotFoundException.lo] Error 1
make[3]: Leaving directory `/extra/var-tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/extra/var-tmp/portage/gcc-3.3.3/work/build/i686-pc-linux-gnu/libjava'
make[1]: *** [all-target-libjava] Error 2
make[1]: Leaving directory `/extra/var-tmp/portage/gcc-3.3.3/work/build'
make: *** [bootstrap-lean] Error 2
!!! ERROR: sys-devel/gcc-3.3.3 failed.
!!! Function src_compile, Line 464, Exitcode 2
!!! (no error message)

let me know what other information you want.

Reproducible: Didn't try
Steps to Reproduce:
Comment 1 Benjamin Judas (RETIRED) gentoo-dev 2004-03-30 21:20:34 UTC
Segmentation faults during compilation mostly arise due to hardware errors.
Is your machine running hot? Is your RAM faulty?
Comment 2 Keith Lea 2004-03-30 23:39:26 UTC
My RAM is fine as far as I can tell. I don't know what it means to be "running hot."
Comment 3 Martin Holzer (RETIRED) gentoo-dev 2004-03-31 03:31:38 UTC
run memtest86 and cpuburn and report again
Comment 4 Keith Lea 2004-03-31 12:19:26 UTC
I ran memtest for one pass and it didn't report any errors. I ran cpuburnMMX and cpuburnP6 (I'm on a P4) for 10 minutes each and nothing bad happened.
Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2004-04-27 06:57:48 UTC
Can you try with gcc-3.3.3-r3?
Comment 6 Travis Tilley (RETIRED) gentoo-dev 2004-07-11 14:11:56 UTC
this bug has been sitting here for a few months... marking as NEEDINFO