Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 463180 - x11-misc/xlockmore-5.42 fails to unlock
Summary: x11-misc/xlockmore-5.42 fails to unlock
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks:
 
Reported: 2013-03-25 06:59 UTC by Nikolaj Šujskij
Modified: 2013-07-18 20:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_463180.txt,16.24 KB, text/plain)
2013-03-25 07:01 UTC, Nikolaj Šujskij
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolaj Šujskij 2013-03-25 06:59:22 UTC
After upgrading to x11-misc/xlockmore-5.42 I cannot unlock X session. Downgrading to 5.41 fixes the issue.
Comment 1 Nikolaj Šujskij 2013-03-25 07:01:30 UTC
Created attachment 343174 [details]
emerge --info

xlockmore USE flags:
"crypt gtk opengl pam truetype xinerama -debug -imagemagick -motif -nas -xlockrc"
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2013-03-25 11:44:53 UTC
Same here:

# emerge -qpv xlockmore
[ebuild   R   ] x11-misc/xlockmore-5.42  USE="crypt -debug gtk imagemagick -motif -nas opengl pam truetype xinerama -xlockrc"
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2013-03-25 13:10:10 UTC
Maybe someone seeing this problem can analyse what is going on (review system logs, etc.). I have package.masked this version for now.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2013-04-05 08:58:29 UTC
This is really strange... I've tried to debug this problem and it's gone. xlockmore-5.42 now unlocks my X session when I enter the valid password.
All I did was running xlock in debugging mode as mentioned in a README file which is shipped with the package:

  xlock -debug -verbose -erasemode no_fade -duration 2 -sequential

I use the same set of USE flags as mentioned in my previous comment.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2013-07-16 14:05:57 UTC
How about 5.43?
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2013-07-17 05:01:27 UTC
5.43 seems to work fine.
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2013-07-18 20:46:26 UTC
5.42 has left the tree.