Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 462788 - net-p2p/rtorrent-0.9.3 with sys-libs/ncurses[tinfo] - error: ‘chtype’ was not declared in this scope
Summary: net-p2p/rtorrent-0.9.3 with sys-libs/ncurses[tinfo] - error: ‘chtype’ was not...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Jason Zaman
URL: https://github.com/rakshasa/rtorrent/...
Whiteboard:
Keywords:
: 565988 (view as bug list)
Depends on: 522706 548998
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-03-23 14:35 UTC by Justin Lecher
Modified: 2018-01-14 15:27 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,165.92 KB, text/plain)
2013-03-23 14:36 UTC, Justin Lecher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2013-03-23 14:35:37 UTC
anvas.h:126:17: error: ‘va_end’ was not declared in this scope
canvas.h: In member function ‘void display::Canvas::print(unsigned int, unsigned int, const char*, ...)’:
canvas.h:131:3: error: ‘va_list’ was not declared in this scope
canvas.h:131:11: error: expected ‘;’ before ‘arglist’
canvas.h:133:12: error: ‘arglist’ was not declared in this scope
canvas.h:133:24: error: ‘va_start’ was not declared in this scope
canvas.h:134:9: error: ‘m_window’ was not declared in this scope
canvas.h:134:23: error: ‘wmove’ was not declared in this scope
canvas.h:135:54: error: ‘vw_printw’ was not declared in this scope
canvas.h:136:17: error: ‘va_end’ was not declared in this scope
window_download_transfer_list.cc: In member function ‘virtual void display::WindowDownloadTransferList::redraw()’:
window_download_transfer_list.cc:89:7: error: ‘chtype’ was not declared in this scope
window_download_transfer_list.cc:89:14: error: expected ‘;’ before ‘attr’
window_download_transfer_list.cc:92:9: error: ‘attr’ was not declared in this scope
window_download_transfer_list.cc:92:16: error: ‘A_REVERSE’ was not declared in this scope
window_download_transfer_list.cc:96:9: error: ‘attr’ was not declared in this scope
window_download_transfer_list.cc:96:16: error: ‘A_BOLD’ was not declared in this scope
window_download_transfer_list.cc:107:9: error: ‘attr’ was not declared in this scope
window_download_transfer_list.cc:107:17: error: ‘A_UNDERLINE’ was not declared in this scope
window_download_transfer_list.cc:109:28: error: ‘attr’ was not declared in this scope
make[3]: *** [text_element_value.o] Error 1
make[3]: *** [window_download_transfer_list.o] Error 1
make[3]: *** [window_download_list.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-p2p/rtorrent-0.9.3/work/rtorrent-0.9.3/src/display'



$ einfo rtorrent
Portage 2.2.0_alpha169 (default/linux/amd64/13.0, gcc-4.7.2-asneeded, glibc-2.17, 3.8.3-lh-r1 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.8.3-lh-r1-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16345232 total,   1531764 free
KiB Swap:    3987452 total,   3977944 free
Timestamp of tree: Sat, 23 Mar 2013 09:00:01 +0000
ld GNU gold (GNU Binutils 2.23.1) 1.11
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8-r1, 2.7.3-r3, 3.1.5-r1, 3.2.3-r2, 3.3.0-r1
dev-util/ccache:          3.1.9-r1::science
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.4.7, 4.5.4, 4.6.3, 4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo sunrise bicatali betagarden dummy neurogeek science Raspberry-Pi-Overlay last-hope g-ctan
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wimplicit-function-declaration"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/eselect/ /usr/share/gnupg/qualified.txt /usr/share/nano/ /var/lib/hsqldb /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wenum-compare"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS=" -vt --keep-going --autounmask-write --autounmask --quiet-build=n"
FCFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g"
FEATURES="assume-digests binpkg-logs buildsyspkg candy ccache collision-protect compressdebug distlocks ebuild-locks fixlafiles merge-sync metadata-transfer multilib-strict news noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms sign split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g"
GENTOO_MIRRORS=" /mnt/tmpfs/ http://gentoo.j-schmitz.net/mirror/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
MAKEOPTS="-j16 -l9"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-z -e -9 -v"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree"
PORTDIR_OVERLAY="/local/overlays/sunrise-reviewed /local/overlays/bicatali /local/overlays/betagarden /local/overlays/dummy /local/overlays/neurogeek /local/overlays/sci /local/overlays/gen2pi /local/overlays/lh/ebuilds /local/overlays/g-ctan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 avx bash-completion berkdb branding bzip2 cairo caps cli cracklib crypt cxx dbus dri fortran gdbm gif gmp gnome gnome-keyring gpm gstreamer gtk iconv icu ipv6 jpeg jpeg2k mmx mmxext modules mudflap multilib ncurses network-cron nls nptl nsplugin numa opengl openmp pam pcre pgo png pulseaudio qt3support raw readline session smp sse sse2 sse2_4way sse2check sse3 sse4 sse41 sse4_1 sse4_2 sse4a ssl ssse3 startup-notification tcpd threads tiff truetype unicode vaapi vdpau xinerama zlib" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport scripting-javascript wiki-publisher nlpsolver" LINGUAS="en" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_conn limit_req map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi stub_status" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_6 python2_7 python3_1 python3_2 python3_3 pypy1_9 pypy2_0" QEMU_SOFTMMU_TARGETS="i386 x86_64 arm armeb" QEMU_USER_TARGETS="i386 x86_64 arm armeb" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.6 2.7 3.1 3.2 3.3 2.7-pypy-1.9 2.7-pypy-2.0"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

net-p2p/rtorrent-0.9.2 was built with the following:
USE="ipv6 (multilib) -daemon -debug -test -xmlrpc"
CFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wimplicit-function-declaration"
CXXFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wenum-compare"
Comment 1 Justin Lecher gentoo-dev 2013-03-23 14:36:01 UTC
Created attachment 342988 [details]
build.log

build.log
Comment 2 razamatan 2014-10-21 05:42:50 UTC
rtorrent 0.9.3 was marked stable and i'm also hitting this compile issue.
Comment 3 piotr5 2015-05-08 13:54:42 UTC
I tried version 0.9.4-r1, here the error starts with 

checking for NcursesW wide-character library... yes
checking for working ncursesw/curses.h... no
checking for working ncursesw.h... no
checking for working ncurses.h... no
configure: WARNING: could not find a working ncursesw/curses.h, ncursesw.h or ncurses.h
checking if curses tinfo library is linked properly... no
adding libtinfo

during configure and then when compiling:

#error "SysV or X/Open-compatible Curses header file required"

obviously the bug in automake is that first ncurses is checked and fails since -ltinfow wasn't added to compile-flags. and then there comes the tinfo check (which strangely isn't in configure.ac). somehow these two must be reversed. adding -ltinfow to configure at the line with -lncursesw allows me to compile -- people without tinfo probably can't do that, and rebuilding configure will undo that change. actually moving this test probably wont work, I believe, since before it the variable $CURSES_LIB isn't set yet...

as a workaround I propose a use-flag tinfo which patches configure accordingly. or maybe try out if the bug in automake is fixed and port rtorrent to that new version (i.e. run autogen.sh for every ebuild) -- my automake is version 1.13.1 and can't even reproduce the original configure, I think upstream used ~1.14...
Comment 4 Justin Lecher gentoo-dev 2015-05-08 14:32:53 UTC
+  08 May 2015; Justin Lecher <jlec@gentoo.org>
+  +files/rtorrent-0.9.4-tinfo.patch, metadata.xml, rtorrent-0.9.4-r1.ebuild:
+  Add fix for ncurses[tinfo], bug #522706
+

fixed in 0.9.4-r1
Comment 5 Benda Xu gentoo-dev 2015-07-19 15:51:52 UTC
Hey Justin, have you forwarded the patch upstream?
Comment 6 Justin Lecher gentoo-dev 2015-07-29 07:26:59 UTC
(In reply to Benda Xu from comment #5)
> Hey Justin, have you forwarded the patch upstream?

No, could you do?
Comment 7 Justin Lecher gentoo-dev 2015-07-29 07:35:04 UTC
Here it is.
https://github.com/rakshasa/rtorrent/pull/317
Comment 8 Ben Kohler gentoo-dev 2017-08-17 15:05:27 UTC
I'm closing this since 0.9.6 isn't affected and it's stable everywhere that 0.9.3 is.
Comment 9 Jason Zaman gentoo-dev 2018-01-14 15:27:37 UTC
*** Bug 565988 has been marked as a duplicate of this bug. ***