Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 46216 - soundcard irq will be disabled in 2.6.X kernels, because of irq.c error.
Summary: soundcard irq will be disabled in 2.6.X kernels, because of irq.c error.
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: x86-kernel@gentoo.org (DEPRECATED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-30 01:33 UTC by Alexander Jenisch
Modified: 2004-04-27 11:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Jenisch 2004-03-30 01:33:46 UTC
i've been searching for my "irq 7: noone cared" and "irq 7 disabled" bug quite a while until i found some post, where i found a patch against an old 2.5.X kernel. the patch never found it's way into the 2.6.X tree, but i decided to give it a shot and never had any problems any longer. so it might be time to incoporate that small change into the 2.6.X tree. i'm no kernel hacker and do not know how to write patches, so i'll make it plain here:

using gentoo-dev-sources, go into /usr/src/linux/sound/pci/emu10k1/irq.c and change the return value on line 158 from "return IRQ_RETVAL(handled);" to "return IRQ_HANDLED;". this does the trick for me. hope it helps.
Comment 1 Jason Cox (RETIRED) gentoo-dev 2004-04-13 13:33:38 UTC
This sounds more like an acpi error to me. Have you built acpi into the kernel? If you have could you pass pci=noacpi on the kernel line? If you haven't built acpi into the kernel, could you try that?
Comment 2 Alexander Jenisch 2004-04-15 19:58:15 UTC
i've built in acpi into the kernel. i've tried it with your advice now. i can tell you the outcome, if i have my machine running for some time again, without a reboot.
Comment 3 Alexander Jenisch 2004-04-20 08:52:55 UTC
didn't help all too much.

irq 7: nobody cared!
Call Trace:
 [<c010834a>] __report_bad_irq+0x2a/0x90
 [<c010843c>] note_interrupt+0x6c/0xa0
 [<c0108711>] do_IRQ+0x121/0x130
 [<c0106a34>] common_interrupt+0x18/0x20
 [<c011f6f0>] __do_softirq+0x30/0x80
 [<c011f766>] do_softirq+0x26/0x30
 [<c01086ed>] do_IRQ+0xfd/0x130
 [<c0106a34>] common_interrupt+0x18/0x20
 [<c023d2e1>] acpi_processor_idle+0xb4/0x1c7
 [<c01040bc>] cpu_idle+0x2c/0x40
 [<c049687c>] start_kernel+0x19c/0x1e0
 [<c04964a0>] unknown_bootoption+0x0/0x120

handlers:
[<c02fff40>] (snd_emu10k1_interrupt+0x0/0x400)
Disabling IRQ #7
Comment 4 Alexander Jenisch 2004-04-27 10:55:29 UTC
please change this simple line. it's working. it's the only thing that helps, i don't want to change that damn line, every kernel release by hand. please, i've tried the kernel mailing list, but they seem to have better things to do.
Comment 5 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-04-27 11:31:03 UTC
But that line just papers over what is happening in the driver, so it will
not be applied.

Try asking the sound driver author to fix this.
Comment 6 Alexander Jenisch 2004-04-27 11:43:29 UTC
will do