Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 461228 - app-office/libreoffice-4.0.1.2 - crashes when scanning from USB-Scan-Device
Summary: app-office/libreoffice-4.0.1.2 - crashes when scanning from USB-Scan-Device
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-10 11:11 UTC by support
Modified: 2013-10-18 11:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
output from "soffice --backtrace" (gdbtrace.log,8.72 KB, text/plain)
2013-06-23 08:28 UTC, support
Details

Note You need to log in before you can comment on or make changes to this bug.
Description support 2013-03-10 11:11:04 UTC
every attempt to use the USB-Scanner segfaults LO, other scanning frontends (xsane, scangui) works correct

Reproducible: Always

Steps to Reproduce:
1.start soffice
2.select INSERT Picture Scan Select Source

Actual Results:  
soffice.bin[12319]: segfault at 21 ip 00007f485560173f sp 00007fff06eaaa60 error 4 in libsane-pixma.so.1.0.23[7f48555f2000+22000]


Expected Results:  
present a Scanner Device for selection
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2013-06-20 12:01:14 UTC
I frankly can't reproduce much,

If you could attach gdb and try to crash it with debug-symbols enabled it might be possible to trace the issue
But with current data there is no way how to fix this.
Comment 2 support 2013-06-23 08:28:14 UTC
Created attachment 351714 [details]
output from "soffice --backtrace"
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2013-06-23 08:33:34 UTC
You have to compile the office with  CFLAGS="-ggdb" and FEATURES=splitdebug.

Otherwise the trace is not usefull at all. http://www.gentoo.org/proj/en/qa/backtraces.xml
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2013-09-15 10:41:23 UTC
I can't reproduce this in my setup as I don't have scanner.
Please try to create the debug build or use binary version with debug useflag enabled to reproduce. And then report this issue upstream on bugs.freedesktop.org as this does not seem too gentoo-related.
Comment 5 support 2013-10-18 11:01:09 UTC
after i installed sane-backends-1.0.24 yesterday, now i can use the sane-backend in Libre-Office.