Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 459512 - dev-lang/ocaml with sys-libs/ncurses[tinfo] - .../work/ocaml-4.00.1/byterun/terminfo.c:54: undefined reference to `tgetent'
Summary: dev-lang/ocaml with sys-libs/ncurses[tinfo] - .../work/ocaml-4.00.1/byterun/t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mark Wright
URL:
Whiteboard:
Keywords:
: 486614 564762 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-02-27 13:20 UTC by Reinis Danne
Modified: 2019-03-22 10:05 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ocaml-build.log.gz (ocaml-build.log.gz,5.63 KB, application/x-gzip)
2013-02-27 13:22 UTC, Reinis Danne
Details
ocaml-4.01.0-pkg-config-ncurses.patch (ocaml-4.01.0-pkg-config-ncurses.patch,675 bytes, patch)
2014-01-18 13:06 UTC, Mark Wright
Details | Diff
files/ocaml-4.01.0-pkg-config-ncurses.patch (ocaml-4.01.0-pkg-config-ncurses.patch,450 bytes, patch)
2014-10-31 10:28 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Reinis Danne 2013-02-27 13:20:36 UTC
Trying to build ocaml with ncurses[tinfo] fails at configure. It should use pkg-config to find ncurses.


Reproducible: Always

Steps to Reproduce:
1. USE=tinfo emerge -1 ncurses
2. emerge -1 dev-lang/ocaml

Actual Results:  
x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed  -Wl,-E -Wl,-O1 -Wl,--as-needed  -Wl,-E -o ocamlrun \
          prims.o libcamlrun.a -lm  -ldl -lcurses -lpthread
libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
/var/tmp/portage/dev-lang/ocaml-4.00.1/work/ocaml-4.00.1/byterun/terminfo.c:54: undefined reference to `tgetent'
...



Portage 2.1.11.52 (default/linux/amd64/13.0/desktop/gnome, gcc-4.7.2, glibc-2.16.0, 3.7.9-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.7.9-gentoo-x86_64-Intel-R-_Core-TM-_i7-2630QM_CPU_@_2.00GHz-with-gentoo-2.2
KiB Mem:     8078324 total,    581384 free
KiB Swap:    2047996 total,   2047644 free
Timestamp of tree: Wed, 27 Feb 2013 04:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8-r1, 2.7.3-r3, 3.1.5-r1, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.6.3, 4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x11 science gamerlay bumblebee slyfox-gentoo dmol tryton local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O3 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O3 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=""
FCFLAGS="-march=native -mtune=native -O3 -pipe -ggdb"
FEATURES="assume-digests binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=native -mtune=native -O3 -pipe -ggdb"
GENTOO_MIRRORS="http://gentoo.tups.lv/source/ "
LANG="lv_LV.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/science /var/lib/layman/gamerlay /var/lib/layman/bumblebee /var/lib/layman/slyfox /var/lib/layman/dmol /var/lib/layman/tryton /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 avx bash-completion berkdb bluetooth branding bzip2 cairo cdda cdio cdr cjk cleartype cli colord consolekit cracklib crypt cups cxx dbus dirac djvu dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg fftw firefox flac fontconfig fortran gdbm gif gnome gnome-keyring gnome-online-accounts gphoto2 gpm gsm gstreamer gtk gtk3 iconv idn ipv6 jpeg kate lcms ldap libcaca libnotify live mad matroska mmx mng modules mp3 mp4 mpeg mtp mudflap multilib musepack nautilus ncurses networkmanager nls nptl ogg openexr opengl openmp opus pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 raw readline schroedinger sdl session smp socialweb speex spell sse sse2 sse41 sse4_1 ssl ssse3 startup-notification svg system-sqlite tcpd theora tiff truetype udev udisks unicode upower usb v4l v4l2 vaapi vorbis vpx wmf wxwidgets x264 xcb xetex xml xmp xpm xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="hp1018" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="lv en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="dummy fbdev i965 intel nouveau nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-libs/ncurses-5.9-r2 was built with the following:
USE="cxx gpm (multilib) tinfo unicode -ada -debug -doc -minimal -profile -static-libs -trace" ABI_X86="64"
Comment 1 Reinis Danne 2013-02-27 13:22:05 UTC
Created attachment 340326 [details]
ocaml-build.log.gz
Comment 2 Mark Wright gentoo-dev 2013-09-15 07:42:54 UTC
ocaml-4.01.0 also fails with ncurses use flag on amd64, a workaround is to add this sed in src_prepare():

sed -e 's@"-lcurses"@"-lncurses -ltinfo"@' -e 's@hasgot $libs@hasgot "$libs"@' -i "${S}/configure" || die "sed to fix ncurses failed"
Comment 3 Mark Wright gentoo-dev 2013-09-15 08:07:32 UTC
The 2nd chunk of the previous sed is unnecessary, this works:

sed -e 's@"-lcurses"@"-lncurses -ltinfo"@' -i "${S}/configure" || die "sed to fix ncurses failed"
Comment 4 Jeroen Roovers gentoo-dev 2013-09-30 22:33:30 UTC
*** Bug 486614 has been marked as a duplicate of this bug. ***
Comment 5 David Mohr 2013-11-15 23:55:55 UTC
For anyone trying to use this for the 3.12.1 version: the sed needs to go into src_unpack() since src_prepare() isn't used in that ebuild.
Comment 6 Mark Wright gentoo-dev 2014-01-18 13:06:40 UTC
Created attachment 368088 [details, diff]
ocaml-4.01.0-pkg-config-ncurses.patch

Patch (by me) to configure to call:
pkg-config --libs ncurses
to link to the correct libraries, which is -lncurse -ltinfo when ncurses is
built with the tinfo use flag and ocaml is built with the ncurses use flag.

I am applying the same patch to all versions currently in portage:
ocaml-3.11.2.ebuild
ocaml-3.12.1.ebuild
ocaml-4.00.1-r1.ebuild
ocaml-4.01.0.ebuild
Comment 7 Alexis Ballier gentoo-dev 2014-01-18 13:26:38 UTC
(In reply to Mark Wright from comment #6)
> Created attachment 368088 [details, diff] [details, diff]
> ocaml-4.01.0-pkg-config-ncurses.patch

i hope you plan to submit it upstream first
Comment 8 Jeroen Roovers gentoo-dev 2014-10-31 10:24:23 UTC
The build system wants a termcap library. With sys-libs/ncurses[-tinfo] that's libncurses but with sys-libs/ncurses[tinfo] it's libtinfo, so the configure check should try to find a termcap library and rely on `pkg-config --libs ncurses'.

Additionally, pkg-config should be called canonically (i.e. inherit toolchain-funcs.eclass and call `tc-export PKG_CONFIG' or a similar solution.
Comment 9 Jeroen Roovers gentoo-dev 2014-10-31 10:28:54 UTC
Created attachment 387868 [details, diff]
files/ocaml-4.01.0-pkg-config-ncurses.patch
Comment 10 Jeroen Roovers gentoo-dev 2014-10-31 10:33:19 UTC
(In reply to Jeroen Roovers from comment #8)
> configure check should try to find a termcap library and rely on `pkg-config
> --libs ncurses'.

/not/ rely on*
Comment 11 Jeroen Roovers gentoo-dev 2014-10-31 10:36:45 UTC
Also, why is that patch called *-config-ncurses.patch when it's about tinfo? :)
Comment 12 Alexis Ballier gentoo-dev 2016-02-05 14:18:31 UTC
*** Bug 564762 has been marked as a duplicate of this bug. ***
Comment 13 Larry the Git Cow gentoo-dev 2019-03-22 10:05:34 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=45d7b4d6d7c5e9f2ca1d742a53072f3a92cb5a91

commit 45d7b4d6d7c5e9f2ca1d742a53072f3a92cb5a91
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2019-03-22 09:46:07 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2019-03-22 10:05:26 +0000

    dev-lang/ocaml: Fixed build with sys-libs/ncurses[tinfo]
    
    Closes: https://bugs.gentoo.org/459512
    Package-Manager: Portage-2.3.62, Repoman-2.3.12
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 dev-lang/ocaml/files/ocaml-4.04.2-tinfo.patch | 13 +++++++++++++
 dev-lang/ocaml/ocaml-4.04.2-r1.ebuild         |  3 ++-
 dev-lang/ocaml/ocaml-4.05.0-r1.ebuild         |  3 ++-
 3 files changed, 17 insertions(+), 2 deletions(-)