Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 458984 - Gnome* maintained packages stabilization list for February
Summary: Gnome* maintained packages stabilization list for February
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 454906 457568 458430 458986 458988 458990 458992 458994 462938
Blocks: 463660
  Show dependency tree
 
Reported: 2013-02-24 13:32 UTC by Pacho Ramos
Modified: 2013-09-28 21:05 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Lista (LISTA.txt,12.68 KB, text/plain)
2013-02-24 14:25 UTC, Pacho Ramos
Details
Lista (LISTA.txt,12.58 KB, text/plain)
2013-03-18 09:37 UTC, Pacho Ramos
Details
Lista (LISTA (1).txt,12.58 KB, text/plain)
2013-03-24 18:14 UTC, Pacho Ramos
Details
Lista (gnome,12.48 KB, text/plain)
2013-03-25 10:31 UTC, Agostino Sarubbo
Details
stabilisation list (gnome,12.38 KB, text/plain)
2013-03-25 15:19 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2013-02-24 13:32:23 UTC
.

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2013-02-24 14:25:06 UTC
Created attachment 339942 [details]
Lista
Comment 2 Pacho Ramos gentoo-dev 2013-02-24 14:32:39 UTC
CCing co-maintainers:
 * app-admin/system-config-printer-common [gentoo]
kde (kde@gentoo.org)
gnome (gnome@gentoo.org)
reavertm@gentoo.org (Maciej Mrozowski)

 * app-admin/system-config-printer-gnome [gentoo]
gnome (gnome@gentoo.org)
reavertm@gentoo.org (Maciej Mrozowski)

 * app-misc/alexandria [gentoo]
ruby (ruby@gentoo.org)
gnome (gnome@gentoo.org)
fauli@gentoo.org (Christian Faulhammer)
john.keeping@lineone.net (John Keeping)

 * dev-libs/gmime [gentoo]
net-mail (net-mail@gentoo.org)
gnome (gnome@gentoo.org)
None specified

 * dev-libs/json-glib [gentoo]
gnome (gnome@gentoo.org)
voyageur@gentoo.org (Bernard Cafarelli)

 * dev-python/pygobject [gentoo]
gnome (gnome@gentoo.org)
python (python@gentoo.org)
None specified

 * dev-python/pygobject [gentoo]
gnome (gnome@gentoo.org)
python (python@gentoo.org)
None specified

 * dev-python/pygoocanvas [gentoo]
gnome (gnome@gentoo.org)
python (python@gentoo.org)
None specified

 * dev-python/pygtk [gentoo]
gnome (gnome@gentoo.org)
python (python@gentoo.org)
None specified

 * dev-util/nemiver [gentoo]
gnome (gnome@gentoo.org)
remi@gentoo.org (Rémi Cardona)

 * gnome-extra/gnome-dvb-daemon [gentoo]
gnome (gnome@gentoo.org)
mattst88@gentoo.org (Matt Turner)

 * media-libs/audiofile [gentoo]
gnome (gnome@gentoo.org)
sound (sound@gentoo.org)
None specified

 * media-libs/gupnp-dlna [gentoo]
net-p2p (net-p2p@gentoo.org)
gnome (gnome@gentoo.org)
None specified

 * media-libs/libcanberra [gentoo]
gnome (gnome@gentoo.org)
sound (sound@gentoo.org)
None specified

 * media-libs/libgphoto2 [gentoo]
gnome (gnome@gentoo.org)
graphics (graphics@gentoo.org)
None specified

 * media-plugins/gst-plugins-meta [gentoo]
gnome (gnome@gentoo.org)
gstreamer (gstreamer@gentoo.org)
None specified

 * media-plugins/gst-plugins-meta [gentoo]
gnome (gnome@gentoo.org)
gstreamer (gstreamer@gentoo.org)
None specified

 * media-video/pitivi [gentoo]
gnome (gnome@gentoo.org)
gstreamer (gstreamer@gentoo.org)
nirbheek@gentoo.org (Nirbheek Chauhan)

 * net-dialup/moserial [gentoo]
gnome (gnome@gentoo.org)
steev@gentoo.org

 * net-im/telepathy-connection-managers [gentoo]
gnome (gnome@gentoo.org)
voip (voip@gentoo.org)
net-im (net-im@gentoo.org)
None specified

 * net-voip/telepathy-rakia [gentoo]
gnome (gnome@gentoo.org)
voip (voip@gentoo.org)
None specified

 * net-im/telepathy-mission-control [gentoo]
gnome (gnome@gentoo.org)
net-im (net-im@gentoo.org)
None specified

 * net-irc/telepathy-idle [gentoo]
gnome (gnome@gentoo.org)
net-im (net-im@gentoo.org)
None specified

 * net-libs/farsight2 [gentoo]
voip (voip@gentoo.org)
gnome (gnome@gentoo.org)
None specified

 * net-libs/farstream [gentoo]
voip (voip@gentoo.org)
gnome (gnome@gentoo.org)
None specified

 * net-libs/gupnp-vala [gentoo]
net-p2p (net-p2p@gentoo.org)
gnome (gnome@gentoo.org)
None specified

 * net-libs/gupnp [gentoo]
net-p2p (net-p2p@gentoo.org)
gnome (gnome@gentoo.org)
None specified

 * net-libs/telepathy-farstream [gentoo]
gnome (gnome@gentoo.org)
voip (voip@gentoo.org)
None specified

 * net-libs/telepathy-farstream [gentoo]
gnome (gnome@gentoo.org)
voip (voip@gentoo.org)
None specified

 * net-libs/telepathy-glib [gentoo]
gnome (gnome@gentoo.org)
voip (voip@gentoo.org)
peper@gentoo.org (Piotr Jaroszyński)

 * net-print/libgnomecups [gentoo]
gnome (gnome@gentoo.org)
printing (printing@gentoo.org)
None specified

 * net-voip/telepathy-gabble [gentoo]
gnome (gnome@gentoo.org)
voip (voip@gentoo.org)
peper@gentoo.org (Piotr Jaroszyński)

 * net-voip/telepathy-salut [gentoo]
gnome (gnome@gentoo.org)
eva@gentoo.org (Gilles Dartiguelongue)
Comment 3 Matt Turner gentoo-dev 2013-02-24 20:18:12 UTC
(In reply to comment #2)
>  * gnome-extra/gnome-dvb-daemon [gentoo]
> gnome (gnome@gentoo.org)
> mattst88@gentoo.org (Matt Turner)

Yes, good for stable.
Comment 4 Samuli Suominen gentoo-dev 2013-02-24 20:22:11 UTC
if these are fine by gnome@ then they are fine by us too:

libgphoto2 (graphics), audiofile (sound), libcanberra (sound)
Comment 5 Gilles Dartiguelongue gentoo-dev 2013-02-25 08:25:16 UTC
gparted: ack

telepathy: watch out for packages that can only be used with empathy-3.6 due to gstreamer-1.0 usage and no slotting (rakia iirc).

gstreamer: pitivi/gnonlin has currently no stable keywords and given the stability I experienced in the past with it, I'd rather not have it stable for now.
Comment 6 Eray Aslan gentoo-dev 2013-02-25 11:28:55 UTC
(In reply to comment #2)
>  * dev-libs/gmime [gentoo]
> net-mail (net-mail@gentoo.org)
> gnome (gnome@gentoo.org)
> None specified

Go for it.
Comment 7 Pacho Ramos gentoo-dev 2013-02-25 18:36:27 UTC
(In reply to comment #5)
> telepathy: watch out for packages that can only be used with empathy-3.6 due
> to gstreamer-1.0 usage and no slotting (rakia iirc).
> 

That would affect at least to:
net-im/telepathy-connection-managers
net-voip/telepathy-rakia

But no idea about the rest (I have never used empathy :S)

> gstreamer: pitivi/gnonlin has currently no stable keywords and given the
> stability I experienced in the past with it, I'd rather not have it stable
> for now.

When I bumped pitivi it blamed to fix a ton of bugs over our old version that was living in the tree for ages... maybe it's in a better shape now :/ Could you check that latest version again?
Comment 8 Rémi Cardona gentoo-dev 2013-02-25 19:28:46 UTC
(In reply to comment #2)
>  * dev-util/nemiver [gentoo]
> gnome (gnome@gentoo.org)
> remi@gentoo.org (Rémi Cardona)

I thought I'd dropped myself from metadata on this one months ago. Please, do whatever you see fit with nemiver, I haven't touched it in years.

Cheers
Comment 9 Michael Palimaka (kensington) gentoo-dev 2013-02-26 10:32:57 UTC
(In reply to comment #2)
> CCing co-maintainers:
>  * app-admin/system-config-printer-common [gentoo]
> kde (kde@gentoo.org)
> gnome (gnome@gentoo.org)
> reavertm@gentoo.org (Maciej Mrozowski)
Sounds good from KDE herd, unless reavertm thinks otherwise.
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-02-26 15:18:12 UTC
No objection from voip herd.
Comment 11 Christian Faulhammer (RETIRED) gentoo-dev 2013-02-26 20:11:31 UTC
(In reply to comment #2)
>  * app-misc/alexandria [gentoo]
> ruby (ruby@gentoo.org)
> gnome (gnome@gentoo.org)
> fauli@gentoo.org (Christian Faulhammer)
> john.keeping@lineone.net (John Keeping)

 Good to go.
Comment 12 Pacho Ramos gentoo-dev 2013-03-18 09:37:24 UTC
Created attachment 342476 [details]
Lista
Comment 13 Pacho Ramos gentoo-dev 2013-03-24 18:14:47 UTC
Created attachment 343124 [details]
Lista

Updated list
Comment 14 Agostino Sarubbo gentoo-dev 2013-03-25 10:31:11 UTC
Created attachment 343216 [details]
Lista

Dropped libpeas.
Comment 15 Agostino Sarubbo gentoo-dev 2013-03-25 15:19:45 UTC
Created attachment 343246 [details]
stabilisation list

Drop anjuta
Comment 16 Agostino Sarubbo gentoo-dev 2013-03-25 16:06:35 UTC
amd64 stable
Comment 17 Agostino Sarubbo gentoo-dev 2013-03-25 16:45:40 UTC
x86 stable
Comment 18 Nikoli 2013-03-25 21:05:59 UTC
dev-python/pygoocanvas-0.14.1-r1 is definitely not good enough for being marked stable: it was ported to python-r1 in wrong way and fails to build when using recommended way of not installing gtk-doc, see bug #458428
Comment 19 Agostino Sarubbo gentoo-dev 2013-03-26 16:57:24 UTC
ppc stable
Comment 20 Agostino Sarubbo gentoo-dev 2013-03-27 10:35:55 UTC
ppc64 stable
Comment 21 Agostino Sarubbo gentoo-dev 2013-03-28 16:06:31 UTC
arm stable
Comment 22 Agostino Sarubbo gentoo-dev 2013-03-29 13:48:18 UTC
ia64 stable
Comment 23 Agostino Sarubbo gentoo-dev 2013-04-01 17:56:25 UTC
alpha stable
Comment 24 Agostino Sarubbo gentoo-dev 2013-04-01 18:26:10 UTC
sparc stable
Comment 25 Agostino Sarubbo gentoo-dev 2013-04-04 19:00:04 UTC
@HPPA:

The list works for me and I haven't the problem described in bug 459752. Tell me if I can proceed or you have any objection.
Comment 26 Agostino Sarubbo gentoo-dev 2013-04-09 16:45:44 UTC
sh stable
Comment 27 Agostino Sarubbo gentoo-dev 2013-04-10 20:22:26 UTC
hppa stable
Comment 28 Brandon 2013-04-12 02:42:09 UTC
THANK YOU!
Comment 29 Agostino Sarubbo gentoo-dev 2013-04-13 20:56:47 UTC
s390 stable
Comment 30 Pacho Ramos gentoo-dev 2013-08-23 07:36:53 UTC
m68k -> ping!
Comment 31 Agostino Sarubbo gentoo-dev 2013-09-28 20:54:30 UTC
M68K is not anymore a stable arch, removing it from the cc list