Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 458912 - x11-misc/electricsheep-2.7_beta11 with media-video/ffmpeg-1.0.4 - electricsheep.c:702:4: error: 'AVStream' has no member named 'stream_copy'
Summary: x11-misc/electricsheep-2.7_beta11 with media-video/ffmpeg-1.0.4 - electricshe...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks: ffmpeg-0.11-breakage
  Show dependency tree
 
Reported: 2013-02-23 21:26 UTC by Jouni Rinne
Modified: 2013-03-04 19:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,8.49 KB, text/plain)
2013-02-23 21:26 UTC, Jouni Rinne
Details
emerge --info (emerge_info,5.31 KB, text/plain)
2013-02-23 21:27 UTC, Jouni Rinne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jouni Rinne 2013-02-23 21:26:52 UTC
Created attachment 339856 [details]
build.log

Electricsheep-2.7_beta11 does not seem to like the ffmpeg upgrade to 1.0.4, it fails to (re)compile after the upgrade broke it.

Also, the 2.7_beta11 version of electricsheep currently in portage is badly outdated (~5 years old); the latest in electricsheep website is b34, unfortunately they don't provide source tarballs, only svn access.
Comment 1 Jouni Rinne 2013-02-23 21:27:25 UTC
Created attachment 339858 [details]
emerge --info
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-02-27 14:15:31 UTC
> maintainer-needed@gentoo.org

This package is currently not maintained, it may take a while for a fix to land.
Comment 3 Pacho Ramos gentoo-dev 2013-03-02 19:23:37 UTC
No idea if livav oriented patches also could help with ffmpeg:
http://patch-tracker.debian.org/patch/series/view/electricsheep/2.7~b12+svn20091224-1.1/fix_ftbfs_libav_0.7.patch

If you could check (I am still running stable ffmpeg)
Comment 4 Alexis Ballier gentoo-dev 2013-03-03 12:29:47 UTC
+  03 Mar 2013; Alexis Ballier <aballier@gentoo.org>
+  electricsheep-2.7_beta11.ebuild,
+  +files/electricsheep-2.7_beta11-ffmpeg1.patch:
+  fix build with ffmpeg-1, bug #458912
+
Comment 5 Jouni Rinne 2013-03-04 17:23:23 UTC
Well, now electricsheep compiles, but segfaults immediately. Should I open a new bug?
Comment 6 Pacho Ramos gentoo-dev 2013-03-04 19:29:20 UTC
I think we can use this one, please please provide a backtrace 
http://www.gentoo.org/proj/en/qa/backtraces.xml