Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 45871 - gnome-pilot 0.1.71 failed to compile
Summary: gnome-pilot 0.1.71 failed to compile
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords:
: 54844 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-03-27 02:27 UTC by Helge Haugland
Modified: 2006-06-04 08:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to comment out undefined LOG macro (gnome-pilot-0.1.71-LOG.patch,15.77 KB, patch)
2004-08-04 17:21 UTC, Mark Wagner
Details | Diff
Updated ebuild to apply patch. (gnome-pilot-0.1.71-r1.ebuild,1.38 KB, text/plain)
2004-08-04 17:22 UTC, Mark Wagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helge Haugland 2004-03-27 02:27:11 UTC
Compiling gnome-pilot 0.1.71 results in errors about "valid preprocessing token". gnome-pilot 2.0.10-r1 already installed, why is 0.1.71 also needed?

Reproducible: Always
Steps to Reproduce:
1. emerge sync
2. emerge -u world
3.

Actual Results:  
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"gpilotd\"
-DGP_PILOT_LINK_VERSION=\"0.11.8\" -I/usr/include/gnome-1.0
-DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/include/orbit-1.0 -I/usr/include/gtk-1.2
-I/usr/X11R6/include -I/usr/include/libcapplet1 -I/usr/include/gnome-1.0
-DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/include/orbit-1.0 -I/usr/include/gtk-1.2
-I/usr/X11R6/include -I/usr/include/gnome-1.0 -DNEED_GNOMESUPPORT_H
-I/usr/lib/gnome-libs/include -I/usr/include/glib-1.2 -I/usr/lib/glib/include
-I/usr/include/orbit-1.0 -I/usr/include/gtk-1.2 -I/usr/X11R6/include
-I/usr/include/libcapplet1   -I/usr/include/gnome-vfs-1.0
-I/usr/lib/gnome-vfs-1.0/include -I/usr/include/gnome-xml
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/include/orbit-1.0
-I/usr/include/gconf/1 -I/usr/include/gtk-1.2 -I/usr/X11R6/include -D_REENTRANT
-I/usr/include/libpisock -I/usr/include/glib-1.2 -I/usr/lib/glib/include
-I/usr/include/orbit-1.0     -Wall -Wmissing-prototypes -Wmissing-declarations
-Wpointer-arith -g -DGNOMELOCALEDIR=\""/usr/share/locale"\"  -c manager.c
gpilotd.c: In function `do_sync':
gpilotd.c:472: warning: implicit declaration of function `gethostname'
gpilotd.c: In function `visor_devices_in':
gpilotd.c:861: warning: type defaults to `int' in declaration of `firstime'
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"gpilotd\"
-DGP_PILOT_LINK_VERSION=\"0.11.8\" -I/usr/include/gnome-1.0
-DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/include/orbit-1.0 -I/usr/include/gtk-1.2
-I/usr/X11R6/include -I/usr/include/libcapplet1 -I/usr/include/gnome-1.0
-DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/include/orbit-1.0 -I/usr/include/gtk-1.2
-I/usr/X11R6/include -I/usr/include/gnome-1.0 -DNEED_GNOMESUPPORT_H
-I/usr/lib/gnome-libs/include -I/usr/include/glib-1.2 -I/usr/lib/glib/include
-I/usr/include/orbit-1.0 -I/usr/include/gtk-1.2 -I/usr/X11R6/include
-I/usr/include/libcapplet1   -I/usr/include/gnome-vfs-1.0
-I/usr/lib/gnome-vfs-1.0/include -I/usr/include/gnome-xml
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/include/orbit-1.0
-I/usr/include/gconf/1 -I/usr/include/gtk-1.2 -I/usr/X11R6/include -D_REENTRANT
-I/usr/include/libpisock -I/usr/include/glib-1.2 -I/usr/lib/glib/include
-I/usr/include/orbit-1.0     -Wall -Wmissing-prototypes -Wmissing-declarations
-Wpointer-arith -g -DGNOMELOCALEDIR=\""/usr/share/locale"\"  -c queue_io.c
manager.c:380:90: pasting ""gpilotd: "" and ""Base %s is to be ignored by sync""
does not give a valid preprocessing token
make[2]: *** [manager.o] Error 1
make[2]: *** Waiting for unfinished jobs....
queue_io.c:324:48: pasting ""gpilotd: "" and ""assigned handle num %u"" does not
give a valid preprocessing token
queue_io.c:368:40: pasting ""gpilotd: "" and ""gpc_queue_purge_request()"" does
not give a valid preprocessing token
make[2]: *** [queue_io.o] Error 1
make[2]: Leaving directory
`/var/tmp/portage/gnome-pilot-0.1.71/work/gnome-pilot-0.1.71/gpilotd'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/var/tmp/portage/gnome-pilot-0.1.71/work/gnome-pilot-0.1.71'
make: *** [all-recursive-am] Error 2
 
!!! ERROR: app-pda/gnome-pilot-0.1.71 failed.
!!! Function src_compile, Line 55, Exitcode 2
!!! (no error message)


Expected Results:  
no errors

# emerge info
Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3_pre20040207-r0,
2.6.4-gentoo-r1)
=================================================================
System uname: 2.6.4-gentoo-r1 i686 AMD Athlon(tm) XP 1800+
Gentoo Base System version 1.4.3.13p1
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -fforce-addr"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -fforce-addr"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://128.213.5.34/gentoo/ 
http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/
http://gentoo.tiscali.nl/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X aalib acpi alsa apache2 apm arts avi berkdb bonobo cdr crypt cups
curl dga directfb dvd encode esd evo fbcon flash foomaticdb gb gd gdbm gif gnome
gnomedb gpm gtk gtk2 gtkhtml guile imap imlib imlib2 java jpeg kde ldap libg++
libgda libwww mad maildir mbox mcal mikmod mmx motif mozilla mpeg mysql nas
ncurses nls oggvorbis opengl oss pam pda pdflib perl plotutils png postgres ppds
python qt quicktime readline ruby samba scanner sdl slang slp spell sse ssl svga
tcltk tcpd tiff truetype usb wmf x86 xface xml xml2 xmms xv zlib"
Comment 1 Alastair Tse (RETIRED) gentoo-dev 2004-03-28 09:33:43 UTC
it's in because evolution-1.2.4 (gtk1) is still in portage.
Comment 2 Mark Wagner 2004-08-04 17:19:41 UTC
Umm, really? It looked to be caused by the use of a preprocessor macro "LOG" when it isn't defined. My guess is that it was used during development but either wasn't removed for release or all uses weren't surrounded by #ifdef DEBUG_CODE ... #endif (some were).

Anyhoo, here is the patch that comments them out and a gnome-pilot-0.1.71-r1 ebuild. I just added the patching to the 0.1.71 ebuild. I didn't fix the bad form of the ebuild.
Comment 3 Mark Wagner 2004-08-04 17:21:40 UTC
Created attachment 36786 [details, diff]
Patch to comment out undefined LOG macro
Comment 4 Mark Wagner 2004-08-04 17:22:31 UTC
Created attachment 36787 [details]
Updated ebuild to apply patch.
Comment 5 foser (RETIRED) gentoo-dev 2004-08-08 07:29:57 UTC
i wonder why noone ever complained about the LOG macro before ?
Comment 6 foser (RETIRED) gentoo-dev 2004-08-19 16:14:58 UTC
*** Bug 54844 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-06-04 08:43:32 UTC
Dead bug. 2.0.13 is stable, reopen if you can reproduce it there.