Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458614 - app-misc/screen-4.0.3-r6 with sys-libs/ncurses[tinfo] - configure: error: !!! no tgetent - no screen
Summary: app-misc/screen-4.0.3-r6 with sys-libs/ncurses[tinfo] - configure: error: !!!...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sven Wegener
URL:
Whiteboard:
Keywords:
: 459658 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-02-21 16:13 UTC by Travis Hansen
Modified: 2013-04-06 09:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Link against tinfo (patch,486 bytes, text/plain)
2013-04-02 20:47 UTC, Andreas Schäfer
Details
patch to link with tinfo (screen-4.0.3-ncurses-tinfo.patch,406 bytes, text/plain)
2013-04-05 20:24 UTC, Milan Freml
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Travis Hansen 2013-02-21 16:13:12 UTC
configure: checking libncurses...
configure: error: !!! no tgetent - no screen


Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2013-03-05 10:59:23 UTC
*** Bug 459658 has been marked as a duplicate of this bug. ***
Comment 2 Andreas Schäfer 2013-04-02 20:47:19 UTC
Created attachment 344118 [details]
Link against tinfo
Comment 3 Andreas Schäfer 2013-04-02 20:49:08 UTC
Occurs for me as well on several boxes. Steps to reproduce: 

emerge -av1 =sys-libs/readline-6.2_p4

The attached patch fixes the compilation for me. Please note that it is not sufficient to just "append-ldflags -L. -ltinfo".
Comment 4 Justin Lecher gentoo-dev 2013-04-03 06:29:18 UTC
(In reply to comment #2)
> Created attachment 344118 [details]
> Link against tinfo

LDFLAGS are not for libs.
Comment 5 Milan Freml 2013-04-05 20:24:50 UTC
Created attachment 344554 [details]
patch to link with tinfo

Supplied patch adds -ltinfo and compiles screen-4.0.3-r8.ebuild; It should be relatively easy to create screen-4.0.3-r9.ebuild...
Comment 6 Justin Lecher gentoo-dev 2013-04-06 07:00:51 UTC
(In reply to comment #5)
> Created attachment 344554 [details]
> patch to link with tinfo
> 
> Supplied patch adds -ltinfo and compiles screen-4.0.3-r8.ebuild; It should
> be relatively easy to create screen-4.0.3-r9.ebuild...

you need to use pkg-config to detect the libs. YOur patch will fail on system not having libtinfo
Comment 7 Justin Lecher gentoo-dev 2013-04-06 09:06:33 UTC
+  06 Apr 2013; Justin Lecher <jlec@gentoo.org> screen-4.0.3-r6.ebuild,
+  screen-4.0.3-r7.ebuild, screen-4.0.3-r8.ebuild, metadata.xml:
+  Add fix for detection of tgetent in ncurses/tinfo, #458614
+