Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458068 - x11-themes/gnome-themes-standard: narrow scrollbars might violate accessibility regulation
Summary: x11-themes/gnome-themes-standard: narrow scrollbars might violate accessibili...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 09:29 UTC by Klaus Kusche
Modified: 2013-07-24 20:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to enable horrible scroll bars in x11-themes/gnome-themes-standard-3.6.2 (gnome-themes-standard-3.6.2-ugly-scrollbar.patch,1.51 KB, patch)
2013-02-18 11:32 UTC, Alexandre Rostovtsev (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Kusche 2013-02-18 09:29:34 UTC
Up to now, out student's labs have been Xfce + purely Gtk2.
I just wanted to upgrade them for the summer term,
and I noticed that some important programs now require Gtk3.

However, I can't install Gtk3, because Gentoo doesn't offer any Gtk3 theme
which conforms to usability and accessability regulations
(at least, I was unable to find such a theme in Gentoo),
and these regulations are mandatory for us.

Please provide some themes which can be legally installed in public places etc.
(at the first glance, clearlooks-phenix could be a good candidate,
but Gentoo doesn't provide it for gtk 3.6.
The Xfce themes would most likely also qualify, 
but Xfce stopped supporting gtk3 at 3.2).

In all of Gentoo's gtk3 themes, scrollbars are the most obvious violation
of usability and accessability regulations:

1.) Arrow Buttons in scrollbars are absolutely mandatory:
In cases where dragging is difficult, imprecise or impossible, 
either due to the pointing device (trackball, presenter = gyro mouse, 
touchpad without scroll area, keyboard's pointing stick, ...)
or due to the user's limited abilities, 
the arrow buttons are the only way for fine-grained scrolling
with the pointer (when only clicking but not dragging).

2.) The regulations require a minimum size of all pointer targets
(anything you click at), both horizontally and vertically.
Similar reasons as above: Imprecise pointing devices, 
users with limited pointing exactness, small high-resolution screens, ...
The exact value depends on screen size and resolution,
but as a rule of thumb, 16 pixels is ok, anything less isn't.
The scrollbar width of all modern gtk3 themes is definitely way too small.

For reference, look at KDE or at Windows:
They both know how scrollbars must be done right.
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-18 11:32:49 UTC
Created attachment 339234 [details, diff]
patch to enable horrible scroll bars in x11-themes/gnome-themes-standard-3.6.2

(In reply to comment #0)
> However, I can't install Gtk3, because Gentoo doesn't offer any Gtk3 theme
> which conforms to usability and accessability regulation

What regulations are these? Is it just a policy adopted by your institution, or is it a law in your country? In the latter case, the developers of gnome-themes-standard should be informed about it.

> the arrow buttons are the only way for fine-grained scrolling
> with the pointer (when only clicking but not dragging).

Gtk scroll bars can be scrolled using a scroll wheel. Virtually all modern pointing devices (mice, touchpads, trackballs) have a hardware scroll wheel or a scroll touch area.

But if you really are forced by law to have buttons and horrible fat scroll bars, try the attached patch for x11-themes/gnome-themes-standard.
Comment 2 Gilles Dartiguelongue gentoo-dev 2013-02-18 11:43:49 UTC
please note that enabling accessibility in gnome3 will do most of what you want (or at least should). If you have any problem with default gtk themes, you should talk to upstream directly.

Xfce themes are not an option, Xfce upstream stopped supporting new gtk+-3 due to "horrible theme engine permanent changes" to paraphrase a recent bug report we had.

If clearlooks-phenix is a good candidate, I'd suggest filing a bug request to its maintainer for an update.

Imho, there is nothing for the gentoo gnome team to do directly, maybe add ourselves to clearlooks-phenix maintainers but that all.
Comment 3 Klaus Kusche 2013-02-18 12:55:21 UTC
(In reply to comment #1)
> Created attachment 339234 [details, diff] [details, diff]
> patch to enable horrible scroll bars in
> x11-themes/gnome-themes-standard-3.6.2
> 
> (In reply to comment #0)
> > However, I can't install Gtk3, because Gentoo doesn't offer any Gtk3 theme
> > which conforms to usability and accessability regulation
> 
> What regulations are these? Is it just a policy adopted by your institution,
> or is it a law in your country? In the latter case, the developers of
> gnome-themes-standard should be informed about it.

It is more complex. These are rather general recommendations published by the government concerning user interfaces. They e.g. state that all applications must be fully keyboard operable (without mouse, having shortkeys etc. for everything), a twodimensional pointing device with two buttons only must suffice, each drag operation must have a click-only equivalent, combined keys must have sequential key combination equivalents, and virtually hundreds of general rules like that. How these regulations will apply to specific GUI's and applications leaves ample room for interpretations and discussion...

These regulations are mandatory only for computing facilities and services operated or developed by the state or on contracts with the government (we are a private, but partly state-funded school, so they apply to us). 

Private companies etc. are formally not bound to these regulations, hence, installing gtk3 "as is" should not be a problem outside public services. However, if an employee with limited abilities sues a company because of missing accessability support or usability deficits, the court will most likely use the public regulations as a base for its judgement, even if they are not mandatory for private companies.

Upstream gtk3 reaction was less than helpful:
"Switch to the "Raleigh" theme (this is the "no themes defined" theme,
looks 15 years old, very similar to Motif), and all your problems are solved.
If there is just problem 2., you can also use the "high contrast" theme,
which widens the scrollbars and most other small pointer targets,
but has no arrow buttons."

> > the arrow buttons are the only way for fine-grained scrolling
> > with the pointer (when only clicking but not dragging).
> 
> Gtk scroll bars can be scrolled using a scroll wheel. Virtually all modern
> pointing devices (mice, touchpads, trackballs) have a hardware scroll wheel
> or a scroll touch area.

The scroll area on my notebook's touch pad doesn't work with linux (for some technical reasons, I use the old mouse protocol, not evdev). The presenters (gyro mice) for the beamers also do not play nicely with linux. One of our labs still has pre-scroll-whell mice.

> But if you really are forced by law to have buttons and horrible fat scroll
> bars, try the attached patch for x11-themes/gnome-themes-standard.

I'll try it.
Comment 4 Klaus Kusche 2013-02-18 13:18:55 UTC
(In reply to comment #2)
> please note that enabling accessibility in gnome3 will do most of what you
> want (or at least should). If you have any problem with default gtk themes,
> you should talk to upstream directly.

No gnome3 here, not now and not in the foreseeable future.
Hence, no gnome3 settings dialogs or accessability utilities.
The settings of Xfce only affect gtk2, not gtk3.

> Xfce themes are not an option, Xfce upstream stopped supporting new gtk+-3
> due to "horrible theme engine permanent changes" to paraphrase a recent bug
> report we had.

I fully agree with them, I'd prefer to stay with gtk2 only for another two to three years, until gtk3 has stabilized its API's (including theme API), fixed its ressource regressions, and so on. See my bug 449774.

And many other theme developers (like qtcurve-gtk) also stopped supporting
gtk3. The number of separately developed gtk3 themes dropped to less than
a third between gtk3.2 and gtk3.6...
For my purposes, gtk3 only brings pain, no gain.
However, some people at Gentoo decided differently...

> If clearlooks-phenix is a good candidate, I'd suggest filing a bug request
> to its maintainer for an update.

Upstream clearlooks-phenix version 3 should work fine with gtk3.6 (I did not test in detail). It's just the gentoo ebuild which is not up to date and has not been keyworded yet. Shall I write a separate bug report or should this
bug report cc'ed to him?

> Imho, there is nothing for the gentoo gnome team to do directly, maybe add
> ourselves to clearlooks-phenix maintainers but that all.

Well, except for updating the clearlooks-phenix ebuild or perhaps providing
an ebuild with some other suitable theme (does anyone know any candidates?), there is no quick solution on Gentoo's side. Providing a choice between gtk2 and gtk3 for all packages where upstream supports this choice would be an even nicer solution (then, my systems would continue to be gtk2 only), but this is not the bug to discuss that.
Comment 5 Klaus Kusche 2013-02-18 13:39:35 UTC
(In reply to comment #1)
> Created attachment 339234 [details, diff] [details, diff]
> patch to enable horrible scroll bars in
> x11-themes/gnome-themes-standard-3.6.2

Theme mess, patch doesn't apply. The gtk2 version patched fine, 
but x11-themes/gnome-themes-standard-3.6.2 doesn't have a file 
Adwaita/gtk-3.0/gtk-widgets.css as required in your patch.

I also checked /var/db/pkg/x11-themes/gnome-themes-standard-3.6.2/CONTENTS,
also no Adwaita/gtk-3.0/gtk-widgets.css . There are only gtk-dark.css, gtk.css, gtk.gresource and settings.ini in gtk-3.0.

However, basically your patch does what I would have done, too.
It's just that I don't want to maintain that patch and port it to the latest gtk3 theme standard changes every few weeks, and I don't want to patch a few dozen machines manually after each update, given that updates happen often.
Comment 6 Gilles Dartiguelongue gentoo-dev 2013-02-18 14:50:17 UTC
I didn't realize it was you again :)

Providing a gtk theme for your needs sounds like a reasonable solution, much faster and easier than trying to convince upstream to do actually accessible themes wrt legislation in whatever country has such policy.

I've asked hasufell if gnome can be added to maintainers and he agreed so I'll see if I can bump that asap.
Comment 7 Klaus Kusche 2013-02-18 16:04:25 UTC
(In reply to comment #6)
> Providing a gtk theme for your needs sounds like a reasonable solution, much
> faster and easier than trying to convince upstream to do actually accessible
> themes wrt legislation in whatever country has such policy.
> 
> I've asked hasufell if gnome can be added to maintainers and he agreed so
> I'll see if I can bump that asap.

I quickly checked upstream clearlooks again. Seems to be perfectly fine for 3.6,
so it just needs some ebuild polishing and keywording (and version bumping in future).

It even has less bugs than adwaita (progress bar in adwaita is broken here, some background colors in adwaita are wrong, west/east tabs have some minor optical problems in adwaita, ...). Most important: Clearlooks gtk2 and gtk3 look almost identical, whereas adwaita gtk2 differs significantly from gtk3 and has many
wrong background colors.

So providing clearlooks seems to be a better choice than providing a slightly modified adwaita: It gives users more choices and styles, and it hopefully needs
less work to maintain than an adwaita patch.
Comment 8 Pacho Ramos gentoo-dev 2013-02-18 19:10:30 UTC
Have you tried x11-themes/light-themes? It's Ubuntu theme, maybe it has this accessibility problems solved :/ (I am currently only running 0.1.8.32 as newer versions don't work with Gnome2, no idea how newer versions behave in that area)
Comment 9 Klaus Kusche 2013-02-19 06:38:31 UTC
(In reply to comment #8)
> Have you tried x11-themes/light-themes? It's Ubuntu theme, maybe it has this
> accessibility problems solved :/ (I am currently only running 0.1.8.32 as
> newer versions don't work with Gnome2, no idea how newer versions behave in
> that area)

They don't help much:
* They don't have scroll arrow buttons in gtk3, only in gtk2. And the scrollbars are a little bit wider than adwaita etc., but thinner than e.g. clearlooks.
* They require the murrine and unico engines. We take great care to keep our systems slim and efficient.
* And w.r.t. usability and accessability: Many parts of the light-themes are rather low contrast, using e.g. grey instead of black as foreground color, or grey background where it should be white, or only minimally different shades of grey for elements with should stand out clearly.
Comment 10 Klaus Kusche 2013-03-10 13:26:08 UTC
Any chances to get x11-themes/clearlooks-phenix maintained and version-bumped?
(rekey this as a version bump request?)
Comment 11 Pacho Ramos gentoo-dev 2013-03-10 15:05:02 UTC
(In reply to comment #10)
> Any chances to get x11-themes/clearlooks-phenix maintained and
> version-bumped?
> (rekey this as a version bump request?)

File a bug requesting that bump for the affected package ;) (it's not maintained by gnome team)
Comment 12 Pacho Ramos gentoo-dev 2013-07-23 20:14:06 UTC
I am not sure what we are supposing to do with this bug if we won't change gnome-themes-standard :/
Comment 13 Klaus Kusche 2013-07-24 05:54:06 UTC
(In reply to Pacho Ramos from comment #12)
> I am not sure what we are supposing to do with this bug if we won't change
> gnome-themes-standard :/

There is no need to change the standard theme, as long as some alternative theme
with wide scrollbars and scrollbuttons is provided. 
Candidates are Clearlooks-Phenix (maintained upstream I think,
but unfortunately with no useful download file or version numbering,
see bug 461280), the old xfce themes (unmaintained upstream,
they have been pissed off by gtk's theme policy) and oxygen-gtk
(nice, but ressource intensive and almost impossible to reconfigure
without kde installed).
Comment 14 Pacho Ramos gentoo-dev 2013-07-24 20:47:00 UTC
This should need to go to upstream then. Regarding bug 461280, maybe its maintainer could take a snapshot :/