Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 45785 - ndiswrapper 0.6: sandbox access violation
Summary: ndiswrapper 0.6: sandbox access violation
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Mobile Herd (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on: 32737
Blocks:
  Show dependency tree
 
Reported: 2004-03-26 02:47 UTC by Christian Bartels
Modified: 2004-08-17 23:07 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Bartels 2004-03-26 02:47:40 UTC
i get this error when emerging ndiswrapper 0.6:

make -C driver
make[1]: Entering directory `/var/tmp/portage/ndiswrapper-0.6/work/ndiswrapper-0.6/driver'
make[1]: Warnung: Kein Jobserver verf
Comment 1 Christian Bartels 2004-03-26 02:47:40 UTC
i get this error when emerging ndiswrapper 0.6:

make -C driver
make[1]: Entering directory `/var/tmp/portage/ndiswrapper-0.6/work/ndiswrapper-0.6/driver'
make[1]: Warnung: Kein Jobserver verfügbar: setzen -j1. Fügen »+« zur Ursprungsregel hinzu.
make -C //usr/src/linux SUBDIRS=/var/tmp/portage/ndiswrapper-0.6/work/ndiswrapper-0.6/driver DRV_VERSION=0.6 modules
make[2]: Entering directory `/usr/src/linux-2.6.4-gentoo-r1'
*** Warning: Overriding SUBDIRS on the command line can cause
***          inconsistencies
make[3]: »arch/i386/kernel/asm-offsets.s« ist bereits aktualisiert.
  CHK     include/asm-i386/asm_offsets.h
ACCESS DENIED  open_wr:   /usr/src/linux-2.6.4-gentoo-r1/include/asm-i386/asm_offsets.h.tmp
/bin/sh: line 1: include/asm-i386/asm_offsets.h.tmp: Keine Berechtigung
  UPD     include/asm-i386/asm_offsets.h
mv: Aufruf von stat für ,,include/asm-i386/asm_offsets.h.tmp" nicht möglich: Datei oder Verzeichnis nicht gefunden
make[2]: *** [include/asm-i386/asm_offsets.h] Fehler 1
make[2]: Leaving directory `/usr/src/linux-2.6.4-gentoo-r1'
make[1]: *** [default] Fehler 2
make[1]: Leaving directory `/var/tmp/portage/ndiswrapper-0.6/work/ndiswrapper-0.6/driver'
make: *** [all] Fehler 2

!!! ERROR: net-wireless/ndiswrapper-0.6 failed.
!!! Function src_compile, Line 40, Exitcode 2
!!! (no error message)

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-net-wireless_-_ndiswrapper-0.6-7966.log"

open_wr:   /usr/src/linux-2.6.4-gentoo-r1/include/asm-i386/asm_offsets.h.tmp
-------------------------------------------------------------------------------

Reproducible: Always
Steps to Reproduce:
1. emerge ndiswrapper
2.
3.
Comment 2 Tim Rädisch 2004-03-26 09:24:15 UTC
Try to compile with 'FEATURES="-sandbox" emerge ndiswrapper'
Comment 3 Christian Bartels 2004-03-26 09:50:05 UTC
k, this works. thx.
Comment 4 Peter Johanson (RETIRED) gentoo-dev 2004-03-27 12:14:19 UTC
Known problem. See bug #32737 for the gory details. johnm and i are finally merging things today or tomorrow.
Comment 5 Erik Proper 2004-05-04 08:09:06 UTC
Doing an emerge ndiswrapper leads to a sandbox violation. The violation I am
getting seems to be different than the one reported before:

make[2]: Entering directory `/usr/src/linux-2.6.5-gentoo-r1'
*** Warning: Overriding SUBDIRS on the command line can cause
***          inconsistencies
make[3]: `arch/i386/kernel/asm-offsets.s' is up to date.
  CC [M]  /var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver/wrapper.o
  CC [M]  /var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver/loader.o
  CC [M]  /var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver/winsyms.o
  CC [M]  /var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver/ndis.o  CC [M]  /var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver/misc_funcs.o
  CC [M]  /var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver/proc.o  CC [M]  /var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver/divdi3.o
  LD [M]  /var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver/ndiswrapper.o
ACCESS DENIED  open_wr:   /usr/src/linux-2.6.5-gentoo-r1/.tmp_versions/ndiswrapper.mod
/bin/sh: line 1: .tmp_versions/ndiswrapper.mod: Permission denied
  Building modules, stage 2.
  MODPOST
ACCESS DENIED  open_wr:   /usr/src/linux-2.6.5-gentoo-r1/.__modpost.cmd
/bin/sh: line 1: ./.__modpost.cmd: Permission denied
make[3]: *** [__modpost] Error 1
make[2]: *** [modules] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.5-gentoo-r1'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/var/tmp/portage/ndiswrapper-0.6-r1/work/ndiswrapper-0.6/driver'
make: *** [all] Error 2
 
!!! ERROR: net-wireless/ndiswrapper-0.6-r1 failed.
!!! Function src_compile, Line 31, Exitcode 2
!!! (no error message)
 
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------LOG FILE = "/tmp/sandbox-net-wireless_-_ndiswrapper-0.6-r1-25769.log"
 
open_wr:   /usr/src/linux-2.6.5-gentoo-r1/.tmp_versions/ndiswrapper.mod
open_wr:   /usr/src/linux-2.6.5-gentoo-r1/.__modpost.cmd
Comment 6 Doug Goldstein gentoo-dev 2004-05-15 16:37:48 UTC
Any idea when this will be fixed? Peter Johanson said "today or tomorrow" and that was 45+ days ago.

Also ndiswrapper 0.7 is out.
Comment 7 Doug Goldstein gentoo-dev 2004-05-15 16:39:10 UTC
I also get with FEATURES="-sandbox" the following error...

/usr/sbin/ebuild.sh: line 57: kernel-mod_pkg_postinst: command not found

However it will merge fine.
Comment 8 James Doherty 2004-05-20 06:37:36 UTC
Erik, I am also getting the same sandbox error as you (ACCESS DENIED  open_wr:   /usr/src/linux-2.6.5-gentoo-r1/.tmp_versions/ndiswrapper.mod). Like you, I'm running linux-2.6.5-gentoo-r1. Hope its fixed soon :) 
Comment 9 James Doherty 2004-05-21 20:07:15 UTC
I am also getting the exact same error with ndiswrapper 0.7 (I renamed the 0.6 ebuild)
Comment 10 Mark Knecht 2004-07-08 11:17:31 UTC
Happened for me this morning on the 0.8 ebuild. The FEATRES="-sandbox" work around seems to have worked.

I guess this isn't getting fixed?
Comment 11 Peter Johanson (RETIRED) gentoo-dev 2004-07-08 11:20:42 UTC
This has been solved finally by the kernel build folks. Use at least a 2.6.6 kernel, and the latest ndiswrapper ebuild will use the new M= syntax, which prevents htis sandbox violation.
Comment 12 Doug Goldstein gentoo-dev 2004-08-17 23:07:19 UTC
definetly fixed in 0.9 which is now in ~x86