Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456248 - kde-base/kde-meta ebuild improvement proposal.
Summary: kde-base/kde-meta ebuild improvement proposal.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-09 00:28 UTC by Michael
Modified: 2020-11-06 04:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
actual improved ebuild (kde-meta-4.10.0-r1.ebuild,1.15 KB, text/plain)
2013-02-09 00:30 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2013-02-09 00:28:38 UTC
Little but useful for some users (ok, it's useful for me) ebuild improvement, makes kdeedu-meta, kdetoys-meta and kdetoys-meta optional. 

Reproducible: Always




# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-meta/kde-meta-4.10.0.ebuild,v 1.1 2013/02/07 04:57:43 alexxy Exp $

EAPI=5
inherit kde4-meta-pkg

DESCRIPTION="KDE - merge this to pull in all split kde-base/* packages"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="accessibility nls sdk semantic-desktop games toys edu"

RDEPEND="
	$(add_kdebase_dep kate)
	$(add_kdebase_dep kdeadmin-meta)
	$(add_kdebase_dep kdeartwork-meta)
	$(add_kdebase_dep kdebase-meta)
	edu? ( $(add_kdebase_dep kdeedu-meta) )
	games? ( $(add_kdebase_dep kdegames-meta) )
	$(add_kdebase_dep kdegraphics-meta)
	$(add_kdebase_dep kdemultimedia-meta)
	$(add_kdebase_dep kdenetwork-meta)
	$(add_kdebase_dep kdeplasma-addons)
	toys? ( $(add_kdebase_dep kdetoys-meta) )
	$(add_kdebase_dep kdeutils-meta)
	accessibility? ( $(add_kdebase_dep kdeaccessibility-meta) )
	nls? ( $(add_kdebase_dep kde-l10n) )
	sdk? (
		$(add_kdebase_dep kdebindings-meta)
		$(add_kdebase_dep kdesdk-meta)
		$(add_kdebase_dep kdewebdev-meta)
	)
	semantic-desktop? (
		$(add_kdebase_dep kdepim-meta "" 4.4.11.1)
	)
"
Comment 1 Michael 2013-02-09 00:30:37 UTC
Created attachment 338366 [details]
actual improved ebuild
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-02-10 04:59:29 UTC
The issue of adding use flags for kde-meta has been raised a few times before.
Our answer is that if you don't want all kde packages, you shouldn't use kde-meta.
Comment 3 Michael 2013-02-10 21:06:13 UTC
(In reply to comment #2)
> The issue of adding use flags for kde-meta has been raised a few times
> before.
> Our answer is that if you don't want all kde packages, you shouldn't use
> kde-meta.

Yes. It has been. 
Because policy of no-use-flags-in-meta-packages is beyond reason. And it isn't even works right now, as you can see there are quite a few USE flags in this ebuild already. 
I was spending some time, reading old issues about it. Point was "meta packages is workaround until sets is unavailable", then point was "now sets are avaiable, and meta packages will be converted to sets" (in 2008). Didn't happen.

Now. I really can't see why USE="accessibility" allowed to exist, and USE="games" is not.