Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456186 - media-sound/amarok-2.6.0 - make[2]: *** No rule to make target `/usr/lib64/libGLU.so', needed by `lib/amarok_context_applet_spectrum_analyzer.so'. Stop.
Summary: media-sound/amarok-2.6.0 - make[2]: *** No rule to make target `/usr/lib64/li...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Jorge Manuel B. S. Vicetto
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 16:32 UTC by Martin Buerger
Modified: 2013-06-13 02:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.tgz (build.log.tgz,105.32 KB, application/x-gzip-compressed-tar)
2013-02-12 16:14 UTC, Martin Buerger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Buerger 2013-02-08 16:32:23 UTC
emerging amarok-2.6.0 fails du to missing lib. see build log.

Reproducible: Always

Steps to Reproduce:
1. emerge amarok
Actual Results:  
fails to build

Expected Results:  
builds successfully

build log: http://bpaste.net/show/75994/
emerge --info: http://bpaste.net/show/75997/
Comment 1 Jeroen Roovers gentoo-dev 2013-02-12 14:29:25 UTC
(In reply to comment #0)
> build log: http://bpaste.net/show/75994/
> emerge --info: http://bpaste.net/show/75997/

1) Please attach the entire build log to this bug report.
2) Please post your `emerge --info' output in a comment.
Comment 2 Martin Buerger 2013-02-12 16:10:39 UTC
# emerge --info
Portage 2.1.11.50 (default/linux/amd64/13.0, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.1
KiB Mem:     8166548 total,   3545464 free
KiB Swap:    1004056 total,   1004056 free
Timestamp of tree: Tue, 12 Feb 2013 15:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/var/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acl alsa amd64 apng berkdb bzip2 chm cli consolekit cracklib crypt cups cxx dbus djvu dri dvd ebook encode exif extras ffmpeg flac fortran gcj gdbm gles gles2 gnutls gudev hwdb iconv inotify jpeg jpeg2k kde lzma minizip mmx mmxext modules mp3 mudflap multilib mysql ncurses nls nptl nsplugin ogg openmp pam pcre png policykit qt3support qt4 readline semantic-desktop session sse sse2 sse3 ssl ssse3 tcpd threads truetype udev unicode vmware-tools vorbis x264 xvfb xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon svga vesa fbdev r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 Martin Buerger 2013-02-12 16:14:50 UTC
Created attachment 338708 [details]
build.log.tgz
Comment 4 Jeroen Roovers gentoo-dev 2013-02-13 19:17:19 UTC
Comment on attachment 338708 [details]
build.log.tgz

Why would you put a single file in a tar archive?
Comment 5 Chris Reffett gentoo-dev Security 2013-03-15 21:43:28 UTC
Please rebuild media-libs/glu, then try emerging amarok again.
Comment 6 Martin Buerger 2013-03-17 15:32:52 UTC
media-libs/glu was not installed. Probably due to the fact that my use flags contained gles and gles2. I disabled both and enabled opengl use flag. I did 'emerge -uDN world' which in turn also installed media-libs/glu and finally amarok also build and installed correctly.
Comment 7 Chris Reffett gentoo-dev Security 2013-06-13 02:03:08 UTC
This does not appear to be a problem any more in latest stable, since they seem to have removed the spectrum analyzer.