Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455974 - x11-drivers/nvidia-drivers-313.18 fail to build with kernel >3.7.5
Summary: x11-drivers/nvidia-drivers-313.18 fail to build with kernel >3.7.5
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-07 09:19 UTC by Justin Lecher
Modified: 2013-02-07 09:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2013-02-07 09:19:16 UTC
Interesting bug

setting SUBLEVEL in /usr/src/linux to 6 make the drivers stop build. When using gentoo-sources-3.7.6 they won't build (see build.log) but when editing the SUBLEVEL to <6 it works.

>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-313.18
 * NVIDIA-Linux-x86_64-313.18.run SHA256 SHA512 WHIRLPOOL size ;-) ...                                                            [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     3.7.6-gentoo
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-313.18.run to /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
 * Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...                                                           [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
 * Preparing nvidia module
make -j16 -l12 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/usr/src/linux CC=x86_64-pc-linux-gnu-gcc clean module 
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1
 * ERROR: x11-drivers/nvidia-drivers-313.18 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-313.18'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-313.18'`.
 * The complete build log is located at '/var/log/portage/build/x11-drivers/nvidia-drivers-313.18:20130207-091622.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/'

>>> Failed to emerge x11-drivers/nvidia-drivers-313.18, Log file:



>>> Running pre-merge checks for x11-drivers/nvidia-drivers-313.18
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     3.7.5-gentoo
 * Checking for suitable kernel configuration options...                                                                          [ ok ]

>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-313.18
 * NVIDIA-Linux-x86_64-313.18.run SHA256 SHA512 WHIRLPOOL size ;-) ...                                                            [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     3.7.5-gentoo
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-313.18.run to /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
 * Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...                                                           [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work ...
 * Preparing nvidia module
make -j16 -l12 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/usr/src/linux CC=x86_64-pc-linux-gnu-gcc clean module 
NVIDIA: calling KBUILD...
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (		\
echo >&2;							\
echo >&2 "  ERROR: Kernel configuration is invalid.";		\
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";	\
echo >&2 ;							\
/bin/false)
mkdir -p /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/kernel/.tmp_versions ; rm -f /var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/kernel/.tmp_versions/*

  WARNING: Symbol version dump /usr/src/linux-3.7.6-gentoo/Module.symvers
           is missing; modules will have no dependencies and modversions.

make -f scripts/Makefile.build obj=/var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/kernel
(cat /dev/null;   echo kernel//var/tmp/portage/x11-drivers/nvidia-drivers-313.18/work/kernel/nvidia.ko;) > /var/tmp/portage/x11-drivers/n
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2013-02-07 09:50:47 UTC

*** This bug has been marked as a duplicate of bug 447566 ***